Jump to content

(Web Client) Cursor jumps to top of Note while typing

Recommended Posts

@Scott T.

This is happening to me right now.  Autosave kicks in and the cursor jumps to the beginning of the note as I'm typing further down in the note. Makes typing in the Web Client unusuable.  Please provide an update, this move to the new Evernote has been frustrating and I'm dreading the thought of migrating my notes to another platform.

Windows 10 64-bit

Firefox 84.0.2

  • Like 8
Link to comment

Same here. 

I've been using Evernote for about half a year and never experienced this bug, but now it happened three times in a few minutes. I'm using web version on Chrome. 

I tried switching to classic editor and it helped, but the new editor still shows this bug

  • Like 2
Link to comment

Have been using Evernote for several months, but only came across this issue yesterday. It is extremely frustrating and results in constant rework. As has been stated elsewhere it seems to be connected to Evernote's Autosave. This has to be fixed ASAP.

  • Like 1
Link to comment

I'm having the same issue where the cursor keeps jumping to the top of the note on auto save. The issue appears to have start happening after the January 12 release of the Web Client (10.6.9-web (225)). Please fix this ASAP, it's making the web client unusable.

I'm using the latest version of Chrome (87.0.4280.141) on macOS Catalina (10.15.7).


Link to comment

This problem started happening to me today. I think it may have also happened once or twice within the past year, but today was bad enough to find this forum and post about it.

  • Windows 10 Home 64-bit Version 10.0.19041 Build 19041
  • Chrome Version 87.0.4280.141 (Official Build) (64-bit)
  • Chrome web 10.6.9-web (225) New Editor
  • Editing an existing text-only note

I tried turning on Chrome's "Do Not Track" setting without success.

My laptop's touchpad is already turned off.

Switching from "New Editor" to "Classic Editor" seems to have fixed the issue. When I switched, Evernote asked me to take a survey about why I was switching and to inform me that the "Classic Editor" would not be available for much longer.

Link to comment

Please someone fix this! Finding Evernote extremely difficult to use like this, so frustrating. 

It's happening every few minutes, I think when autosave is kicking in. Oh and a couple of times it has created a duplicate of my note. 

I am on the Google Chrome web client. Chrome version: Version 87.0.4280.141 (Official Build) (x86_64) MacOS Mojave 10.14.6

The only thing I have in my note is text and a table.

I am using the New Editor.

It wasn't happening previously, I started using Evernote in mid December and didn't notice this problem, but I think there has been an update and since then in the last couple of weeks this problem has popped up and it is relentless!



Edited by Scurrumptious
Remembered something else that happens during this bug
  • Like 1
Link to comment

Same problem. Cursor jumps to top of page at seemingly random intervals--sometimes as often as every few seconds; other times I get several minutes of uninterrupted use. Details:

  • Just typing text (sometimes with checkboxes, sometimes without) -- not using tables or attachments or any advanced functionality. Literally just typing.
  • MacBook Pro
  • Catalina 10.15.5
  • Using Evernote in browser, Chrome 87.0.4280.88
  • Using "New Editor" (I'll switch to Classic and see if that makes a difference and report back)
  • I run AdBlock Plus and Ghostery but they are both disabled on Evernote
  • I'll try the "block Google tracking" trick, but from the comments above it sounds like that's not a stable/consistent fix

This might have been a problem for a while, but it's just the past few days that it has hit the "OK, Evernote is now incredibly frustrating" for me. I was so happy to find this forum topic, but then baffled that a bug like this--that interferes with THE core functionality of Evernote--hasn't been fixed in a year and a half.

UPDATE: The "block Google tracking" toggle did not work. I have been an Evernote Premium customer for several years, but this bug interferes with functionality so badly that I have started looking for another app to meet my needs. (And it's not only the "not fixed for 18 months" issue that worries me--it's the "no staff replies for over a year".)

Edited by sparrish
Edit 1: I omitted which editor I was using in my details; edit was to add the "New Editor" bullet. Edit 2: Adding that the Google tracking toggle didn't help, and I'm very concerned that this problem is not being addressed.
  • Like 1
Link to comment

Unable to use evernote.

Windows evernote 10.6.9 has a 'spelling check disfunction' and evernote web's cursor jumping every second, and it becomes more severe. 

Need some improvement as soon as possible.

Almost unable to do any work.

Link to comment
On 1/9/2020 at 8:22 PM, Scott T. said:

Also, for those having problems, can you let me know any specific browser plugins you might be using, especially any ad blockers?

2 different macs, both running Catalina using Safari

No extensions other than web clipper


FWIW My iPad does the same thing.

Link to comment

I reported this back in 2019 when I was using Evernote on the web. Since then I was able to return to the app which didn't seem to have those problems, and I thought it might have disappeared since the release of the all-new Evernote. But since the start of January 2021 I'm back using Evernote web (this time Mac Bug Sur and Firefox, Evernote version 10.6.9-web (225)), and only in the last few days (since approximately 13 Jan 2021) the cursor jumping problem has returned. It's hugely frustrating.

Link to comment

Same here. Started a few days ago. Chrome, Mac OS X (High Sierra).  Happens right after autosave, which is triggered every time I stop typing (after a second or two of inactivity), and also periodically by default (every few seconds). 

So far the only workaround I found is to type fast enough so that there are no time gaps long enough for autosave to be triggered.

Makes the program useless if not fixed.

Link to comment
On 1/10/2020 at 11:48 AM, Scott T. said:

Thanks @Nik Silver. Our Editor QA said he'd mention the Google Analytics in their standup this morning. He said that sounded like an interesting possibility. I'll post if I hear anything back. Let me know if that seems to solve the problem for you.

Can you escalate the issue? This is a pretty mission critical bug to address - users can't effectively do what the platform was created to do - take notes. All the usability features that evernote offers are great, but if I keep getting interrupted by my cursor getting bumped up to the top of the page, they're useless. If I'm taking notes during a meeting in a notebook that is really, really long, and I have to jump back and forth every five minutes - I lose vital information because now I'm focusing on scrolling back to where I was, not what was said in the meeting. I only started using Evernote on a daily basis in December, and I see here that this has been going on for years! That makes me think I've adopted the wrong solution for my note keeping. 

I'm using Google Chrome (most up to date version - literally just updated it 5 seconds ago, and the bug happened within 30 seconds of using evernote) on a 2020 MacBookAir.

I don't want to sound like a Karen here, but the fact that this issue has been going on for years (even several days would be too long) is pretty absurd. If I'm still seeing the issue in a week. I'll have to switch to something else. I just can't see how the platform is functional with this bug.

Link to comment

Re: Cursor jumps to start of note - while I am typing

It makes Evernote unusable for notes. As it does it every 10 to 20 words.

I think it always happens when I pause to think. But there looks to be other factors as well. 


Re:Regression - I have see this bug before - or something very similar.


Re: Cause/reproduce : Looks related these:

  undo, delete, pausing while I think, cursor is in the middle of a note rather than the end.


e.g. I typed "- how about now" on a new line.  ... first I typed "- " then did undo ctrl+z to remove the bullet. Then typed the rest. I paused after typing now and the cursor jumped to the start of the note. It was not the last line of text in the note. Maybe I hit delete at some point, not sure. 

It is hard to reproduce consistently. , there looks to be more than one cause.

Re: my system
  I am using chrome on windows 10 

  Version 87.0.4280.141 (Official Build) (64-bit)

Link to comment

Add me to the list of users experiencing this problem for the last week or so.

Win 10 with Chrome Version 87.0.4280.88 (Official Build) (64-bit)

Cursor regularly jumps to the top of the note, duplicate notes being created and long pauses while saving (ie. the characters I've typed will stop appearing on the screen, and eventually catchup after a 5-20 seconds).

As others have said, this is unusable in it's current state.  I've taken to typing out blocks of text in Notepad and pasting them in. 

This is ridiculous.

Link to comment
On 1/18/2021 at 8:37 AM, Nik Silver said:

But since the start of January 2021 I'm back using Evernote web (this time Mac Bug Sur and Firefox, Evernote version 10.6.9-web (225)), and only in the last few days (since approximately 13 Jan 2021) the cursor jumping problem has returned. It's hugely frustrating.

One additional quirk: Twice now when this has happened Evernote has noticed some kind of conflict and created a duplicate note. Here's the popup I saw after it happened in a note (called "People") that I was editing.


Link to comment
  • Shane D. changed the title to (Web Client) Cursor jumps to top of Note while typing

Having the same issue, and am extremely frustrated by it.

Evernote also keep producing copies of the note I'm working on

Seriously how can you ship a release that has such an issue?

I paid for this and its unusable!

Link to comment

I've been experiencing this issue for the past few days/week. I use Evernote everyday. I found that switching to the Classic Editor gets around the bug.

  • Linux Ubuntu 20.04
  • Evernote Web client
  • Chrome 87.0.4280.88

Good luck getting a fix soon.

Link to comment

I am a paid subscriber who has been using Evernote forever. Never had the problem with the standalone app, only with the web version. I like using the web version because it works well with the spelling and grammar checker. I've had this cursor jumping problem for some time on my Windows 10 laptop. Tried Chrome, Edge and Firefox. All have the same problem with the cursor jumping to the start of a note. Today I tried reverting to the Classic Editor instead of the New Editor. So far, no cursor jumps. Will see if this keeps working. If so, then perhaps there is a clue in this to help fix the problem.

  • Like 1
Link to comment
On 1/15/2021 at 11:27 AM, dctatt said:

Switching from "New Editor" to "Classic Editor" seems to have fixed the issue.

I'm still having this issue. Not quite as frequently as last week, but it definitely happened during an autosave. Switching to "Classic Editor" still fixes it.

Link to comment

i'm having this issue as well. Chrome/Windows/Web-Client. Not sure what is doing this but it's pretty bad as sometimes you don't notice the jump untill you're halfway writing. This isn't that useable sadly and it's getting worse. Any solutions greatly appreciated. 

Link to comment

Ok, so i've tried a work-around that seems to be working thus far (30 mins and counting). I'm using the Brave browser now and so far so good. The idea came to me because I don't have any plugins installed on it and it's very "light-weight" when it comes to adons and Google-like ad-sense analytics. I will repost if this doesn't work in the long term but again, so far I'm happy with the results. I hope this helps out anyone else on here struggling. ✌

  • Like 1
Link to comment

I have found that switching from the "New Editor" to the "Classic Editor" when using Evernote in my browser fixes the problem. I will switch back to the "New Editor" when Evernote fixes the issues.

  • Like 2
Link to comment

Same, started two days ago.  Recently paying subscriber, long time user.  Doing it on the PC. 

And the lack of support reminds me once again:  Evernote is a great concept and service but the management are so disappointing.  They just ignored the furore when they started trying to push people into subscribing a few years ago.  Didn't change anything.  Despite being a lead story on many speciality sites.  And issues... there is no timely responsiveness to serious issues that are having immediate, serious consequences for users.  There is a disconnection between their stated aim and their actions: they provide a service that they want people to rely on yet they don't back that up by keeping it "up" and reliable.  That issue with the string of additional docs being created... it still happens from time to time.  Yet, my post as a registered, paid-up user needs to be approved by a moderator.  Priorities.

I work in disability and mental health and have a separate background in psychology, human factors and industrial and organizational psych.  There are clear indicators of issues of culture and priorities that likely stem from individuals with high levels of influence.

And folks, I will publish this post of mine online and tag certain sites and relevant youtubers if you either fail to upload it or there is no useful, timely response. And I won't blame the mod, I will ensure it is known to be the result of the rules as set by the management and their culture.

  • Like 1
Link to comment

Often, when I'm editing the middle of a Note, the cursor jumps to the top of the Note and starts entering text there, not where I initially placed the cursor and began typing.  So, the first letter or two will appear where I began typing in the middle of the Note, then suddenly it continues to type the rest of that word at the very top of the Note. I'm using Chrome.

Link to comment

All has been well with the cursor jumping problem since I reverted to the "Classic Editor" when using the web client in the Edge browser on my Windows 10 laptop. However, today I went to enter a new note and before I started I saw that Evernote had switched me back to the "New Editor" without any input from me. Easy enough to make the swith back to the "Classic Editor."

  • Like 2
Link to comment
14 hours ago, Ki6rbw said:

Often, when I'm editing the middle of a Note, the cursor jumps to the top of the Note and starts entering text there, not where I initially placed the cursor and began typing.  So, the first letter or two will appear where I began typing in the middle of the Note, then suddenly it continues to type the rest of that word at the very top of the Note. I'm using Chrome.

use old editor , this is a common bug and using the old editor eliminates it for now.

  • Like 1
Link to comment

Same frustrating cursor jump issue. How can a leading app like this have such a recurring problem that's been happening over the past 5 years????  A google search shows that this problem has been around for years...

Based on above suggestions, I switched from New Editor to Classic Editor... And then ANOTHER PROBLEM pops up: the editor does not autoscroll up when you are typing at the bottom of the page!!!! So you can't see what you're typing when you're at the bottom of the page and you must keep hitting the down button to scroll down...

I've been looking for an alternative app to Evernote.  Any ideas?


Going to try Onenote...


Link to comment
On 1/24/2021 at 2:00 PM, higginstony said:

How do I access the old editor?   I use evernote via browser (vs. native application) and I have the same cursor-jumping issue.   When I login via browser I get version "10.6.9-web (225)".

i feel that they have gotten rid of switching to the old editor, to switch you will have to switch the browser EN to old EN which may or may not be a good option for you. you can switch by going to account info and there will be an option to switch to the old EN. if you need any help make sure you reply with my name or qoute.

Link to comment

I am having the same issue, and if you use this app for anything writing-based that takes more than approximately one minute to execute, the program becomes so frustrating as to be useless. I don't understand how this kind of bug can exist this long on an app that is supposed to be for taking notes. 

Link to comment

Any timeline on when this will be fixed? Switching to old editor is not an option for me because I need to copy/paste graphics I clip into Evernote, and this doesn't work in the old editor due to another bug! And I'm not moving from Chrome to another browser just for this issue.

  • Like 1
Link to comment

This has been happening to me for about a month, when using a Win-10 machine with the Chrome browser or a Chrome Book. All software has the latest updates.

I went from the free version to Premium, today. Still happening.


Link to comment

I am having the EXACT same problem as reported in this thread. Most specifically here: https://discussion.evernote.com/forums/topic/133340-web-client-cursor-jumps-to-top-of-note-while-typing/?do=findComment&comment=602583

I am on Windows 10, Using MS Edge

Microsoft Edge is up to date.
Version 88.0.705.50 (Official build) (64-bit)

Evernote is installed as a PWA.  This has worked GREAT up until about 2 weeks ago or so - not sure of exact time.  It is rendering my Evernote experience frustrating and close to useless.  May have to switch to OneNote.. : (


Link to comment

Just change to the "Classic Editor" instead of the "New Editor". This has fixed the jumping problem for me. I will switch back to the "New Editor" when Evernote fixes this problem. Just keep an eye on which editor is active, since the web client reverts to the "New Editor" from time to time. Very infrequent but it happens.

Link to comment

Same problem and I can't even try the switch to classic editor.  I agree with everyone else, this is pretty ridiculous for a note-taking app?

Recs for a different app that works?

Mac OSX Mojave

Firefox 84.0.2

Chrome 87.0.4280.141 (not to mention in Chrome, randomly will start saving multiple versions of my note so i have to go and delete a hundred notes of the same note)


Link to comment

Come on folks, can we please get this fixed. It's really a critical bug that affects usability and should have been picked up with any basic quality assurance testing.

Why the slow response?

  • Like 3
Link to comment

I am echoing all of the issues about the cursor jumping. It makes it difficult to take notes and do work on Evernote because I spend a lot of my time finding the cursor and trying to follow my work. 

Link to comment

The issue: 

  1. Adding content somewhere in a note using the new note editor following my usual workflow.
  2. In trying to continuously save, the note editor will take the cursor away while I am typing and put it on top of the note.
  3. This will almost always result in a duplicate note since I would have added one extra letter/word/sentence in the previous cursor position (not having realized that the cursor has jumped to the top)

The impact:

  1. Stops my most common workflow of adding basic text into the Note Editor.
  2. Need to delete the duplicate note.
  3. Have to bring the cursor back to it's initial position and continue my now broken chain of thought.
  4. This has impacted users for over a week now and is quite frustrating to deal with as it effects a very basic workflow of most users.


Hope this gets resolved soon!


  • Like 1
Link to comment

The stop-gap "solution" of using the classic editor has revealed another issue...

When I edit an existing note in the classic web editor, then view that note in the Android or Windows client, the size of the new/updated text is different.  If I then update the text size on Android or Windows, it is different again when viewed in the legacy web client, and vice versa.  Setting the text size in one client (Android, web classic, web new, Windows new or Windows "Legacy") seems to be interpreted differently by every other client! 

Text colours are also inconsistent between platforms, which I have flagged in another thread.  I've tried the "Simplify Formatting" button to try and fix up the inconsistent text size, but that also behaves differently on different platforms (ie. whether it removes the text colour, what size the text ends up being afterwards, and whether it removes bold/italic settings).

I found this (made up) quote on a Reddit thread which seems sadly accurate...

From Evernote's CEO:


"I have noticed a disturbing amount of discontent with our fabulous v10 release. In light of poor user response, Evernote will continue to remove features until user morale improves."

I'm back to using the new web editor, editing text in Windows Notepad and pasting it in to avoid the classic editor messing up the text formatting.

Making a text editor with consistent functionality across multiple platforms must be harder than it looks, but it is pretty core functionality for a note-taking platform!  I don't care about fancy new features if I can't consistently author and edit text!!!

I've been playing with Notion, and it loads notes (even really long ones) extremely quickly, text editing (including size and colour) is consistent across Windows, Web and Android, and whilst it's missing some Evernote features that I would miss, it has some additional ones that look really nice. 

I was a very early user of Evernote, I have loved it for over a decade, and have recommended it to lots of people.  I really don't want to move 1,000s of notes to a new platform, but unfortunately Evernote seems to be getting worse and worse and if things don't improve soon I may be left with no choice.

  • Like 3
Link to comment

Hey all,

Huge fan over Evernote, but it is becoming unusable due to these bugs. My cursor keeps jumping to the top of the page, and many duplicate notes continue to be created.


Hoping for a solution soon, thank you!

  • Like 1
Link to comment

jumping cursor and duplicate notes
Evernote is now just unusable.

I am another user of many years with thousands of notes.
This issue may be the one that pushes me over the edge.
I am frustrated and angry.
This must get fixed.
I will keep checking back here while I search for a new note taking app.

Ps:  As others have said, fancy new features mean nothing to me.  I am not interested.
I just need the basics to work!

  • Like 3
Link to comment

Has anyone here noticed that this problem has gone away? I have, I'm happy to say. So I can switch back from the Classic editor now (which I'm thankful for as it's pretty poor!).

Not sure whether Chrome has updated. I'm on Version 87.0.4280.88 (Official Build) (64-bit)

  • Like 1
Link to comment

After reading the most current posts, I decided to switch back to the "New Editor." After two days of use, I can say that the cursor jumping problem is almost gone. It occurs so infrequently now that I will stay with the "New Editor." I hope that further improvements are coming so that this issue can be said to be completely fixed. Other issues remain, but they are truly minor in comparison to the jumping issue.

Link to comment

Just checking in on status of Evernote.  I got burned Sooo bad when it made the big jumt to v10 I think it was then that I told myself I will never again just automatically click to update ANYTHING EVERNOTE!!!!!   

v10.3 was released Early January.  I set a reminder to check in on it 1 month later. AND more problems!!!!!!!!!!!!!!!! 

Sooo, tell me, when do I approve ANY update from my current one which STILL has issues given that EVERY update has issues??? 

As someone said earlier, "I don't care about fancy new features if I can't consistently author and edit text!!!" 

I don't want my car to make toast for me on the way to work!!!! My car that you made used to be awesome until YOU decided it needed to make toast for me.  I now have engine and transmission problems with that once awesome car that if you just removed the toaster, it would be old faithfull again. 

You need to Evernote A&B   

A: Just author, edit, and save search these notes from multiple devices  OR ALL the services of the old platform (I didn't use 70% of them) when it was at its best. 

B. Go hog wild for those who DO want a toaster in their car.  (Psst, I don't know anyone who does AND more realistically, I honestly do not know anyone who uses all the GARBAGE you try to get this thing to do!!!  YES!  It IS GARBAGE or waste if nobody uses it AND in trying to UNSUCCESSFULLY make it work, it totally wrecks what I know EVERYONE that uses it ACTUALY does with it, which AGAIN, is Just author, edit, and save search these notes from multiple devices!!!  Thought...

Is there anyway to make Evernote alacarte?????????????  To be able to buy ONLY the services the user needs so YOU stop bringing me to a grinding HAULT because of your toaster that I and EVERYONE  else I know of, has absolutely NO use for!!!  Offer individual services or abilities, small common bundles that someone who uses this as an artist, or a business manager, or a scheduler, or someone who needs a platform for multiple to acess 1 / the same project.  I have NO need for ANY of that. 

Hey, Revive the Old / prior system for people like me who were happy back then but are angry now,  then continue with this new platform or what ever you call it for those who insist on having that toaster in their car. 


Link to comment

Wow, a month later since the re-occourance of the "cursor jumping to top" bug has resurfaced, and still no fix? Is this a sign Evernote is stagnating?

The fact that such a show stopping bug still this still exists a month later, even with users posting incessantly about it, is a sign that Evernote doesn't have its priorities in order. @jimsnyder8's post may have been a bit agressive but his point is right on target. @amandagene is right, you spend most of your time scrolling back to where you were. To anyone experiencing it, this is unusable.  Almost better off using a pen and paper, at least it doesn't pro-actively fight you.

I was increasing my usage and considering paying, but I've now back peddled to switching note taking clients entirely.  Half my work is done on a Linux computer for which there is no client, and I can live with the web interface as a result, but not with this bug.

Link to comment

I don't know. Getting legit styles instead of the primitive "everything-is-custom-formatting" approach of the old Evernote was a huge deal for me. It kind of brought Evernote out of the dark ages and back into play as something I could actually use to write things again. I'm not saying it's wrong to be frustrated with such an obvious and debilitating bug, because that was completely infuriating to try to deal with--I'm just adding a data point that the "new editor" was a big improvement for me and I appreciate Evernote not stagnating in that regard.

Link to comment

After using the "New Editor" extensively for two full days, I can say that the problem has been greatly reduced, but it has not been eliminated. The reduction is enough to allow me to get my work done with the "New Editor", but more needs to be done.

Link to comment
  • 2 months later...
  • 2 weeks later...

Happening to me:

MIcrosoft Edge Version 90.0.818.56 (Official build) (64-bit)

Windows 10 Home: 19042.928

Evernote v 10.13.4 web 249
Editor: v123.0.15939
Service: v1.34.4

Could someone at Evernote update this thread - is this bug being worked on? I am happy to provide video of my experience or any other feedback of what's happening if that would be helpful.

Link to comment
On 4/24/2021 at 6:06 PM, Dick M said:

Hard to believe that such a simple problem cannot be resolved after being reported over 4 months ago.

It's also an issue I've never had and I use the web app multiple times a day on Firefox and Chrome on three different Linux versions. This would tend to suggest that it's an unusual bug.

Link to comment
  • 4 weeks later...
On 4/24/2021 at 9:06 AM, Dick M said:

Hard to believe that such a simple problem cannot be resolved after being reported over 4 months ago.


Weird cursor jumping has been a known issue at Evernote since early 2014. Source: Evernote - The Bug Ridden Elephant.

You could likely search these forums and find weird cursor jumping (and other cursor bugs) reports going back to even earlier years.

As a non-coder, it is hard for me to comprehend how an ultra basic "feature" of a note-taking program can fail for so many years. I can only suspect that the root cause of these cursor bugs is so deep and entangled in the code that nobody dares to even try to fix it. Far more fun to change typography, color schemes, and other brand refreshments. That could be why, even now, after 7+ years of cursor bugs, even after the latest rebuild, all we hear is:


On 2/8/2021 at 10:18 AM, Nick L. said:

Hey folks, 

We have introduced a partial fix for this in Evernote Web 10.7.5 with the new editor. Please let me know if you're seeing this issue on this version. 



Maybe there's some other explanation for the cursor bugs that I don't understand. Please enlighten me if you know the answer.

I'd love for an Evernote employee to just say "We're not going to build things like Home screens, Tasks, and new logos until basic elements like cursors just work because typing is important." Then it would be great if they could just follow through on that.

I won't hold my breath.

Link to comment
  • Level 5

Comment, comment, comment, history, 2014, back then, we in the trenches, …

And I ask myself: Nicely written, but is there any substance to it ?

No - the code base 2014 has nothing to do with the code base 2021. If there is a problem to be tackled today, it can’t be tackled the way it was done back then.

So let us hope they get this nasty cursor movement under control, and that is it. See, it just takes 16 words to make this statement.

Link to comment
19 hours ago, PinkElephant said:

Comment, comment, comment, history, 2014, back then, we in the trenches, …

And I ask myself: Nicely written, but is there any substance to it ?

No - the code base 2014 has nothing to do with the code base 2021. If there is a problem to be tackled today, it can’t be tackled the way it was done back then.

So let us hope they get this nasty cursor movement under control, and that is it. See, it just takes 16 words to make this statement.

Do you know this to be literally true? i.e. That there wasn't a single character from the old code base brought to the new code base? Has Evernote said this?

It may very well be true - I don't know.

Unfortunately, I can only think of two plausible explanations for these cursor bugs.

  1. Evernote truly does have two entirely separate code bases, but, just by astounding coincidence, they programmed infuriating cursor jumping bugs into both of them. It is just a further coincidence that the symptoms of those bugs - on two entirely separate code bases - are pretty much indistinguishable. This seems to be what you're saying, @PinkElephant.
  2. The company programmed infuriating cursor jumping bugs into the original code 7+ years ago. Years later, those bugs live on in Legacy... AND Evernote chose to copy-paste some/all of those bugs into the new code base.

Both explanations are quite cynical, but I'm no coder. This is all I can think of as a layperson. Is there a more optimistic explanation out there?

Link to comment
  • Level 5

The old apps were written natively, if I am not mistaken large parts in C+.

V10 is based on frameworks that nest the app on the device and handles all operations to and from the OS. AFAIK the nested app is coded using Java Script.

You can now believe it is a feature, and was therefore added to the new app. Maybe to please some forum users who enjoy ranting about it …

IMHO it is a bug, and should be treated  as such. This means that those subscribers who encounter it (I don’t) should issue a support ticket.

Link to comment
  • Shane D. featured this topic
  • 3 weeks later...
  • 11 months later...

Had been enjoying Evernote, but this has to be a most frustrating glitch.  Is there a way to, at least, decrease the frequency of the refresh / update?  I don’t know enough. All I want to do is write my notes, I don’t want to become an investigative engineer.

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...