Jump to content
Jackolicious

mac Evernote 5.6 Beta 4

Recommended Posts

Hi everyone,

 

We've just released a new version of Evernote for Mac that should be faster and more stable than ever. 5.5 users with "update to beta" checked in their preferences should start seeing this build as available for download. Here's the link for your reference: http://goo.gl/av6f2N

 

Please post questions and comments here. We're all looking forward to your feedback!

  • Like 1

Share this post


Link to post

The black sidebar now retains its size across re-launches of Evernote, as it did in 5.5 and previous. Thanks for fixing this!

  • Like 1

Share this post


Link to post

Good to see regular work on this. Thank you.

Would it be possible to get some of indication whether linking to files is going to be reinstated i.e. creating a link to file on the hard disk & then clicking on that link opens that file e.g. video clip. I don't want to add large files to my Evernote database.

Thanks

Share this post


Link to post

This persists. A fresh 5.6. Beta 4 example: https://www.evernote.com/shard/s3/sh/e292a82b-54dd-4345-8c51-32a540f4bbba/7703276d0bf6f4078142fa82eeb0551b

 

Is this really expected behaviour now?

 

It is completely devastating for any kind of workflow revolving around merging notes. So, if yes: Why?

 

This is still happening for me too.

 

Also most of my photos were resized to almost thumnail size and I can't resize them, I have to create a new note and re-upload the photos for them to display correctly, then they go back to thumbnail size if I re-open the note.

 

It also keeps syncing with every change with manual syncing turned on creating conflincts.

 

(I searched the options but didn't find anything to stop this behaviour)

Share this post


Link to post

alexrs, if you're seeing self-conflicts, please pm me your activity logs

Share this post


Link to post

I've just installed Beta4 and noticed that when I have a document open (Word, PDF) which I'm editing and saving that the note from which the document resides gets extra blank spaces inserted in the note text.

Share this post


Link to post

Hi,

 

Search in the beta is messed up. After just a few minutes using the beta I had the following problems:

 

1. For a while I could not enter text into the search entry field. I could only select an entry from the saved searches drop down. After some time it worked again I don't know why.

2. Searching for tags is not possible by entering e.g tag:Evernote. It just searches for the text "tag:Evernote". I have to use the list at the bottom of the drop down menu.

 

I think I go back to the stable version.

 

Bernd

Share this post


Link to post

alexrs, if you're seeing self-conflicts, please pm me your activity logs

 

Will do, however it seems to have fixed itself :blink: - for the time being at least.

 

An option to stop it syncing every time a note is edited would be good.

 

Regarding the image problem, do you have any insight?

Share this post


Link to post

Auto-updating from Beta 1 I'm getting persistent errors on unpacking. Not sure why. Wonder if others are getting them, too.

Same here from Beta 3

Share this post


Link to post

I can't sign it all with the latest beta. I enter my details, the window closes, and nothing happens. 

Share this post


Link to post

If you see errors unpacking, please update from the link above. Thanks!

Share this post


Link to post

Auto-updating from Beta 1 I'm getting persistent errors on unpacking. Not sure why. Wonder if others are getting them, too.

 

Exactly same issue here, also trying to auto-update from beta 1.

 

Solved: Manualy update works fine (if you don't forget to quit the Evernote helper first)

Edited by kuja

Share this post


Link to post

 

1. For a while I could not enter text into the search entry field. I could only select an entry from the saved searches drop down. After some time it worked again I don't know why.

 

I only noticed this when the cursor is still placed in the title of a note and then I click in the search field, at that moment I can not type anything in the search field, just select from the drop down. Clicking somewhere else in a note or on the note list and then back to the search field makes typing available again. So as long as the last cursor position was not the title of a note, typing in the search field works fine for me.

Share this post


Link to post

Hi,

 

I now switched back to the Mac app store version and have even more problems. I have to sign in on every app start and all my settings are lost. And when the client tries to download files from the Evernote server it always stops. Frustrating.

 

Can anyone help me with that? What files/directories do I need to delete for a complete fresh start? My notes are all there as I can see with the Web client.

 

Until I find a solution I have to use the iPad and Web client.

 

I really would appreciate some help here. I also created a support ticket (674197).

 

Bernd

Share this post


Link to post

If you want to delete everything from your Mac then you'll need to delete evernote.app from applications and then your data.

 

If you downloaded directly it's in user/library/application support/evernote
If you downloaded from the app store it's here ~/Library/Containers/com.evernote.Evernote
And, if you have an iMac with a fusion drive, it might be here
/Library/Containers/com.evernote.Evernote/Data/Library/Application Support/Evernote/account/<your username>/ 
 
You need to remember to export any local notes you have first as these will be deleted.
 
Chris' blog post should help you out - http://www.christopher-mayo.com/?p=135

Share this post


Link to post

I updated to Beta 4 this morning. Now, EN is hanging trying to synch. Blue arrows are rotating but never finish. I have also noticed CPU is pegged with EN at 102.9%.

 

I do not know how to troubleshoot this any further. Clearly, significant impact to my workflow this morning. -- jay

Share this post


Link to post

 

If you want to delete everything from your Mac then you'll need to delete evernote.app from applications and then your data.

 

If you downloaded directly it's in user/library/application support/evernote
If you downloaded from the app store it's here ~/Library/Containers/com.evernote.Evernote
And, if you have an iMac with a fusion drive, it might be here
/Library/Containers/com.evernote.Evernote/Data/Library/Application Support/Evernote/account/<your username>/ 
 
You need to remember to export any local notes you have first as these will be deleted.
 
Chris' blog post should help you out - http://www.christopher-mayo.com/?p=135

 

 

Thanks for your help Metrodon,

 

I'll try it soon, and I hope it will work.

 

Regards from Stuhr, Germany

 

Bernd

Share this post


Link to post

I'm surprised to see that the beta 4 still cannot search in pdf's. I posted this result in beta 3 when I searched for text in a pdf from within a certain tag. Even when I do a regular search I see it only pulls results from photos, evernote text and Word text but no PDF's unless the word I'm searching for is in the evernote note title. Still unusable for me due to this. Bummer! Maybe beta 5?

Share this post


Link to post

I updated to Beta 4 this morning. Now, EN is hanging trying to synch. Blue arrows are rotating but never finish. I have also noticed CPU is pegged with EN at 102.9%.

 

I do not know how to troubleshoot this any further. Clearly, significant impact to my workflow this morning. -- jay

 

It appears there are 2 notes that are causing the sync to fail (assuming I understand the Activity Log). The following messages are flooding the Activity log. How do I find these 2 notes using the internal reference info included in the activity log?

 

2014/08/06 12:13:59:273 I|*   __77-[ENCacheManager fetchNextBatchOfDownloadOperationsUsingBackgroundTransfers:]_block_invoke  | Processing 2 notes
2014/08/06 12:13:59:273 I|*   -[ENCacheManager generateOperationsForResource:usingGenerator:]  | Queueing Reco Data: 9b43a876-2dc0-45e0-a0fc-d21655a8d128
2014/08/06 12:13:59:274 I|*   -[ENCacheManager generateOperationsForResource:usingGenerator:]  | Queueing Reco Data: 0e7c0243-eb31-4e22-8025-abedcbaab4df
 
Interesting that this began with the Beta 4 update, though maybe co-incidence??

Share this post


Link to post

can you export those notes, delete them and then try to sync?

 

then maybe import them one at a time and see if it breaks.

Share this post


Link to post

can you export those notes, delete them and then try to sync?

 

then maybe import them one at a time and see if it breaks.

 

thanks for the quick response. I definitely will try, but don't know how to correlate the internal name (e.g. 9b43a876-2dc0-45e0-a0fc-d21655a8d128) to the note. i.e., how do I find these 2 notes??

Share this post


Link to post

jayelevy:

I don't know of a way to do that in Evernote, but here is a quick and dirty AppleScript to search for that ID. Just change the ID in the first line - select all your notes in Evernote and start the script. Once it found the ID it pops out the title.

Hope this helps.

set searchID to "9b43a876-2dc0-45e0-a0fc-d21655a8d128"tell application "Evernote"set selectedNotes to selectionrepeat with theNote in selectedNotesif note link of theNote contains searchID thendisplay dialog title of theNote as textexit repeatend ifend repeatdisplay dialog "Search Done!"end tell

Share this post


Link to post

The tab order in 5.6 is still messed up.

 

In 5.5 I could edit the title of a note and shift-tab to focus on the tags field to add/edit tags. In 5.6 when I shift-tab in when I'm focused on the note's title the focus moves somewhere unknown. Is that behavior not going to be restored?

Share this post


Link to post

 

jayelevy:

I don't know of a way to do that in Evernote, but here is a quick and dirty AppleScript to search for that ID. Just change the ID in the first line - select all your notes in Evernote and start the script. Once it found the ID it pops out the title.

Hope this helps.

set searchID to "9b43a876-2dc0-45e0-a0fc-d21655a8d128"tell application "Evernote"set selectedNotes to selectionrepeat with theNote in selectedNotesif note link of theNote contains searchID thendisplay dialog title of theNote as textexit repeatend ifend repeatdisplay dialog "Search Done!"end tell

 

Palladion, thank you so much for the script suggestion. Alas, I ran it and it did not find either note.

 

To be sure I hadn't made an AppleScript mistake, I also used a modified version of the script to return the "note link" of an existing note to then validate the script would work for a note in my database. Worked perfectly! So, no problems at all with the AppleScript.

 

Back to square 1...

 

I've submitted an EN Support Request. Perhaps I will get some help through that avenue. 

 

I do welcome other ideas for troubleshooting!

Share this post


Link to post

When editing a link, it's inserting the URL into the middle of the text

 

  1. Create a link from highlighted text
  2. Move the cursor into the middle of the text (don't highlight it)
  3. Press apple + k to edit the link
  4. Press OK

Expected: The link to update and not change the text

Saw: The new link is inserted into the middle of the text

 

If I highlight the link text and then edit it, it doesn't insert the new link into the link text.

Share this post


Link to post

The tab order in 5.6 is still messed up.

 

In 5.5 I could edit the title of a note and shift-tab to focus on the tags field to add/edit tags. In 5.6 when I shift-tab in when I'm focused on the note's title the focus moves somewhere unknown. Is that behavior not going to be restored?

Shift tab from the title now puts focus in the note list. You can tab between search, note list, title and body more easily now. 

Share this post


Link to post

jayelevy:

I don't know of a way to do that in Evernote, but here is a quick and dirty AppleScript to search for that ID. Just change the ID in the first line - select all your notes in Evernote and start the script. Once it found the ID it pops out the title.

Hope this helps.

set searchID to "9b43a876-2dc0-45e0-a0fc-d21655a8d128"tell application "Evernote"set selectedNotes to selectionrepeat with theNote in selectedNotesif note link of theNote contains searchID thendisplay dialog title of theNote as textexit repeatend ifend repeatdisplay dialog "Search Done!"end tell
 

Palladion, thank you so much for the script suggestion. Alas, I ran it and it did not find either note.

 

To be sure I hadn't made an AppleScript mistake, I also used a modified version of the script to return the "note link" of an existing note to then validate the script would work for a note in my database. Worked perfectly! So, no problems at all with the AppleScript.

 

Back to square 1...

 

I've submitted an EN Support Request. Perhaps I will get some help through that avenue. 

 

I do welcome other ideas for troubleshooting!

Maybe the note is a deleted one - Not sure whether the script works there.

Share this post


Link to post

 

Maybe the note is a deleted one - Not sure whether the script works there.

 

 

Great thought. To be sure, I expunged all of my deleted messages. Problem hasn't gone away... still stuck on those two entries

Share this post


Link to post

Anyone have a SSEE and tried it with this beta? Beta 3 would crash on scan import for anything other than documents then hang on restart until the import folder was cleared

Share this post


Link to post

I've been crashing like crazy on this recent beta - just trying to print, mostly - like 5 times in a row. Anyway, I also have the "disappearing shared folder" syndrome that I had on an earlier beta (that I sent files to the Beta team on).

 

- Went to move a folder from one shared folder to another (both shared folders not owned by me)

- When I selected the folder I wanted in the drop down - it gave me a curious pop up "One of the folders you selected doesn't exist are you sure you want to continue" (not 100% sure on the wording now) but I continued. 

- Then I got a sync error, now stating clearly that the destination folder doesn't exist & it's gone from my sidebar. 

- Then the sync went through - and the note's gone. No conflict notebook that I see...and not in the trash either..

- I have the owner un-sharing and re-sharing the disappeared notebook with me...hopefully (weirdly) it'll be there - or maybe in her trash... 

 

EDIT: I found the note - in my default notebook. With a blue sync arrow that persists through sync cycles. Moving the note to different notebooks doesn't seem to help. I'm pretty ecstatic to get the note back, however!  I'm going to create a new note & copy/paste. 

Share this post


Link to post

 

 

Maybe the note is a deleted one - Not sure whether the script works there.

 

 

Great thought. To be sure, I expunged all of my deleted messages. Problem hasn't gone away... still stuck on those two entries

 

 

Sorry, I guess I don't know how to proceed from here.

 

I am not even sure if those notes are on your local machine or in the cloud - and you can only check with applescript on your local copies.

I guess you should contact Jackolicious he is in a better position to help you find those notes.

 

Hope you'll get it sorted out.

 

Oh - one thought still - Do you have or use Business Notebooks or Notebooks you subscribed to? Maybe the problem is in there.

Share this post


Link to post

- Using Side List View, the columns keep resizing

 

- The inbox count does not change after moving notes from the inbox.

Share this post


Link to post

can I view a complete changelog of public 4 in the client of somewhere on the web?

 

I second this. There is usually a changelog located under the "help" menu, but there appears to be none with 5.6 Beta 4.

Share this post


Link to post

I have tried to install four times and get an update error every time:  "An error occurred while extracting the archive. Please try again later."

 

Any suggestions?

Share this post


Link to post

Did you try and update in-app or download using the link? Whichever you're doing, try the other option ;-)

  • Like 1

Share this post


Link to post

Did you try and update in-app or download using the link? Whichever you're doing, try the other option ;-)

 

The direct download worked, the update did not.  

Share this post


Link to post

When I sent in the log there were apparently no footprints in it of the upgrade (from Beta 1) being tried. That might be significant when it comes to the "bad archive" problem. But then again maybe the upgrade needs more log entries to be usefully diagnostic (like any). :-)

Share this post


Link to post

Is anyone having a problem with evernote opening when you start the app?

 

When I open the app I see the toolbar but not anything else. When I quit the app and restart, then it will restart Iike normal.

 

I noticed that this has been a problem for the last two or three revisions. 

 

Thanks

 

Jay Cutler

Share this post


Link to post

×
×
  • Create New...