Jump to content
  • 0
jbignert

firefox Firefox Web Clipper 6.1

Idea

Hi all,

We have submitted version 6.1 to Firefox and are waiting for their approval. 

 

Fixes in 6.1:

- CPU load reduced greatly, should make it smoother to work with in general and especially when you have many tabs open.

- We believe we have fixed most occurrences of the missing toolbar button. 

- Fixed issue that threw error message 'EDAM-USER....' when trying to save a clip.

- % symbols at beginning and end of strings on options page. 

 

6.1 can be installed from here:

https://addons.mozilla.org/en-US/firefox/addon/evernote-web-clipper/versions/

 

Please note that it may take Firefox 3-5 months to review this build and give it final approval after which users will be automatically updated. In the meantime you can still install it from the link above.

 

Feel free to post reports of any issues in the 6.1 build here. Include as much details you can and your FF and OS version. 

  • Like 2

Share this post


Link to post

64 replies to this idea

Recommended Posts

  • 0

I have the same problem as with 6.0.15 and 6.0.17 Beta - the web clipper doesn't appear. Tested on Linux and Windows 7 in Firefox 39.

First I just installed it and did a restart. Then removed it, restart, installed it again, restart. Still no webclipper :/

  • Like 1

Share this post


Link to post
  • 0

Appreciate the update, seems to be on the right track now. But, I really find useful the update all other browsers received, a more cleaner and more useful way to clip, LinkedIn, Youtube etc. Any chance of getting that in Firefox soon? As for Firefox approval period, don't worry about it, just post an update here on on their website and keep us notified. That is all we ask. Thank you.

 

Share this post


Link to post
  • 0

Firefox is most likely going to be a step behind Chrome/Safari that are on the same codebase. I understand that's not what you want to hear and I hope I can make it catch up sooner rather than later. 

Share this post


Link to post
  • 0

Firefox 39, clipping as bookmark still does not save the thumbnail image of the page or the favicon into the new note (just broken image link icons). They show up in the preview, but not in the final note.

 

The toolbar icon is also still too small compared to other firefox icons.

  • Like 1

Share this post


Link to post
  • 0

Hi all,

We have submitted version 6.1 to Firefox and are waiting for their approval. 

 

Thanks for the update.

 

I'm running FireFox 38.0.5 on Mavericks (10.9.5)

 

In the Clipper Preferences, there is an option for:  "Use keyboard shortcuts, Enable global keyboard shortcuts"

 

When I view these in Options, the shortcuts appear in a white text box, giving the appearance that they can be changed.

But I can't seem to make a change.  

Can they be changed?  If so how?

If not, it would be better to show them without the text box so the user is not mislead.

But I would much prefer to change them, so I can have the same shortcut for clipping to Evernote across all my apps.

 

Also, what do you mean by "global"?  From any application (doesn't make sense) OR while FireFox is active app?

 

Thanks.

Share this post


Link to post
  • 0

Yeah I realize that part of the preference page can be confusing. It's better presented on the Web Clippers 'internal' Options page.

 

For now they are not customizable. 

Share this post


Link to post
  • 0

Thanks a lot Niels, we'll investigate and see if there is anything we can do on our side to avoid the conflict. 

Share this post


Link to post
  • 0

Unfortunately, Version 6.1 does not work with Firefox 39.0 if the "send clips to Evernote Desktop" option is selected. After clicking Save, there is no indication anything happens, and the Evernote Desktop doesn't receive the clip. I've tried various Options settings, and they don't appear to make any difference.

  • Like 1

Share this post


Link to post
  • 0

"View without formating" doesn't look nice with the gray box:

 

27927165-5fae-4033-8bdf-7643679f3e67.png

Share this post


Link to post
  • 0

I'm having similar experience to Fearmore  in that everything appears to be working perfectly until Evernote opens, syncs, then just sits there. The saved article, page, bookmark, etc. just never arrive.

Share this post


Link to post
  • 0

still has the same issue it has always had since version 6.x.x.x

 

icon disappears in old versions of firefox.

 

I specificaly use FF28.

 

If you are not going to fix this problem for older versions of Firefox you should put a minimun version requirement in place.

 

Right now your add-on says it works with Firefox 26 and newer.... which is false.

Share this post


Link to post
  • 0

wow! FF28... I hope you don't update it just for appearance concerns (I remember how I hated 29, fortunately fixed 2 days after the release) 'cause you're exposed to security issues.

Share this post


Link to post
  • 0

CTRL-` and SHIFT-CTRL-` still don't work to cycle through Tab Groups. SHIFT-CTRL-E becomes the only way to access them.  This is on Windows 8.1 Pro and FF 39.

Share this post


Link to post
  • 0

With FF39: Web/Cloud = all things okay but native/Desktop = don't show Notebook and Tag listing

Share this post


Link to post
  • 0

Native clipping doesn't support 'in Clipper' notebook and tag selection (it never has supported it) so at the moment that is working as expected. Thanks for the feedback. 

Share this post


Link to post
  • 0

Please make the 'shorcut preference' changable. I cannot use 'Next to previous Group Tab' shortcut in Firefox. I have to disable 'Web Clipper' even though I love this.

  • Like 1

Share this post


Link to post
  • 0

@Chrisd13

You can disable just the keyboard shortcuts on the options page. Let me know if that doesn't resolve the issue. 

 

Customizable shortcuts are coming. 

Share this post


Link to post
  • 0

When keyboard shortcuts are enabled, the clipper responds to CTRL-` and CTRL-SHIFT-` as expected. When keyboard shortcuts are disabled, the clipper does not respond, but neither does FIrefox. Disabling the web clipper, with or without restarting Firefox, allows the keystrokes through to the browser again.  This is with Windows 8.1 and FF 39.0.

Share this post


Link to post
  • 0

Hi @jbignert

 

As @Don R said,  I did the same, didn't work for Yosemite, FF 39.0. And it don't make sense when web clip shortcut is not working, we loose the flexibility. Please bring the customizable shortcuts to FF. Thanks.

Share this post


Link to post
  • 0

Web Clipper 6.1 works well on Firefox Developer Edition 41.0a2 but it still has issues with the DevEdition theme because the dark icon stays dark on the dark toolbar. Other icons usually have an alternative white version which fits better to the darker DevEdition theme.

Can you please add support for the DevEdition theme?

Share this post


Link to post
  • 0

I am never allowed an opportunity to Sign In to Web Clipper 6.1. After installing it, the icon shows a small red circle in the lower left. I assume this means it is not logged in. When I click on the icon, the red circle goes away, and I have a drop down menu. Unfortunately, my notebooks don't show up. This was suspicious. When I click on gear cog "Options", it indicated "Signed Out."

 

Using Firefox 39.0, Windows 8.1 Pro.

 

P.S. I have no other extensions enabled. I have removed and reinstalled Web Clipper 6.1 several times.
 I am using 6.1 because I had the issue of 6.015 not showing up on the tool bar and grayed out in the selection of extensions.

 

Thanks,

 

Scott

Share this post


Link to post
  • 0

When will you add Gmail-Support to Webclipper for Firefox? Missing this feature very hard, but don't want to switch to Chrome ...

Share this post


Link to post
  • 0

Got the same issue (see below)

 

Is there a way to force a login?

 

web-clipper-bug.png

 

 

I am never allowed an opportunity to Sign In to Web Clipper 6.1. After installing it, the icon shows a small red circle in the lower left. I assume this means it is not logged in. When I click on the icon, the red circle goes away, and I have a drop down menu. Unfortunately, my notebooks don't show up. This was suspicious. When I click on gear cog "Options", it indicated "Signed Out."

 

Using Firefox 39.0, Windows 8.1 Pro.

 

P.S. I have no other extensions enabled. I have removed and reinstalled Web Clipper 6.1 several times.
 I am using 6.1 because I had the issue of 6.015 not showing up on the tool bar and grayed out in the selection of extensions.

 

Thanks,

 

Scott

  • Like 1

Share this post


Link to post
  • 0

@nikabc

You have your preference set to send clips to your Evernote desktop client. If you are signed into the desktop client the signed in status line on the options page reflects if you have signed into the Web Clipper for sending clips to web. Clipping should work as normal IF your Evernote desktop client is signed in and running. 

Share this post


Link to post
  • 0

That's weird, it works fine in our testing. 

Can you check what Evernote desktop client version you are running?

What OS version are you running?

Share this post


Link to post
  • 0

@jbignert, thanks for your help to sort this out.  Please see attached. I believe these are all latest versions.

 

 

evernote-OS.png

Share this post


Link to post
  • 0

Doesn't work with firefox 41.0b1 on Mint Linux x64, because the xpi isn't signed. Could you please upload a signed xpi?

 

Thanks.

Share this post


Link to post
  • 0

The signing takes place when Mozilla reviews the xpi file. That can take anywhere form 3-6 months at the current speed Mozilla is reviewing add-ons. 

Share this post


Link to post
  • 0

The signing takes place when Mozilla reviews the xpi file. That can take anywhere form 3-6 months at the current speed Mozilla is reviewing add-ons. 

 

I find it quite hard to accept that you either have to be a couple months behind, or to expose yourself to malicious addons by disabling the signing requirement.

There should be another way.

  • Like 1

Share this post


Link to post
  • 0

Hi,

 

The Options-Dialog of the web clipper (Firefox 40.0, OS X Yosemite 10.10.5) looks quite strange on my system. Please observe the many '%':

 

Bildschirmfoto%202015-08-20%20um%2018.39

Share this post


Link to post
  • 0

Hey all,

 

6.1 - still doesn't work on my iMac with Firefox. I still get the same 'signed out' notification on the options and no way to sign in.

 

Makes using Evernote itself somewhat pointless...

 

Also good to know that previous versions of the clipper can't be installed on the latest version of Firefox (4.0), so no option to go back to a version that actually works.

  • Like 1

Share this post


Link to post
  • 0

Web Clipper has suddenly stopped working, and my one shared notebook does not even appear anymore. Suggestions for this neophyte?

 

Share this post


Link to post
  • 0

so I'm having this problem where the Save button doesn't work on this page (or anything that is just an image).

http://www.starhub.com/content/dam/support/finance-and-billing/resources-forms/business-reply-envelope/bre.jpg

 

I have WC 6.1

Windows 7 SP1

ff 40.0.2

 

I have turned off Adblocker Pro and NoScript is running the page wide open.  I have this same issue when viewing any image and using any method (screenshot, bookmark, image).

  • Like 1

Share this post


Link to post
  • 0

Running into this problem when trying to install.

Windows 8.1, Firefox 40.0.3

6.0.15.1 signed

 

post-270447-0-09451800-1443065924_thumb.

 

It's looking for a missing file that it can't find.

this is 6.1 version

 

post-270447-0-97352300-1443066173_thumb.

 

Essentially the same error. Is it just Firefox's extension system and they would need to go with Chrome/Edge version or what? Thanks.

.

Share this post


Link to post
  • 0

Running into this problem when trying to install.

Windows 8.1, Firefox 40.0.3

6.0.15.1 signed

 

It's looking for a missing file that it can't find.

this is 6.1 version

 

Essentially the same error. Is it just Firefox's extension system and they would need to go with Chrome/Edge version or what? Thanks.

.

To me it looks like a permission problem because the message is "Evernote Web Clipper cannot be installed because Firefox cannot modify the needed file". You possible might need to uninstall a previous version. You also could try to create a new profile for Firefox and try to install the Web Clipper into this profile. If this works there is something wrong with your current profile.

Share this post


Link to post
  • 0

Using FF 43.0a2 (2015-09-26) and it won't let me use 6.1.  6.0.15.1 does not work.  When are you guys going to fix this?  Seems like there are a lot of people on here that want to use FF.  The rating for that plugin is really low and for good reason.  It doesn't work at all from what I can see.  This is one of my top Evernote features and I wish you guys would get it working.

Share this post


Link to post
  • 0

Any news on the updates guys. You Started talking to us in the Evernote Windows forum and Its much appreciated. Can you give us any updates on the new Web clipper for Firefox. Its still technically on 6.0.15.1, while Chrome is on 6.7. At least get us where 6.5 was for Chrome.

Share this post


Link to post
  • 0

Was it ever available from Mozilla? My Firefox is on automatic update but never updated to 6.1. It always stayed in 6.0.15.1. What is happening? 6.1 was announced on July 9th. Chrome is on 6.7. Did Evernote stop working on the Firefox Web Clipper? It seems so.

Share this post


Link to post
  • 0

Was it ever available from Mozilla?

It was, but not through the auto update. 6.1 version was not reviewed by Mozilla, therefore it was available only by manual downloading. But now it's gone.

Share this post


Link to post
  • 0

Actually it does not work well...

 

Even if Mozilla does not update it on their addons.mozilla.org page, I guess users who trust evernote would still benefit from a download if it is only provided by Evernote.com. At least I do not care where I download the addon, as long as it is safe and it works.

 

I went back to some 5.9.x version to get my context menu (right click) back. Without the context menu in Firefox I do not see much value in the web clipper. And without a fully working web clipper, Evernote would be only 50 % useful for my specific workflow.  ... -_-

Share this post


Link to post
  • 0

I had to delete all FF extensions temporarily at work (and reinstall FF at home last weekend), then I didn't find version 6.1 anymore on addons.mozilla.org

 

One essential step that I used frequently is select some text or right click an image, then choose from the context menu to clip the text or image.

Share this post


Link to post
  • 0

I had to delete all FF extensions temporarily at work (and reinstall FF at home last weekend), then I didn't find version 6.1 anymore on addons.mozilla.org

 

One essential step that I used frequently is select some text or right click an image, then choose from the context menu to clip the text or image.

Because it's not there anymore.

And yep, I have exactly that functionality in my 6.1 firefox version, saving images and whatnot.

Share this post


Link to post
  • 0

so, I suggest only to provide this file version 6.1 independently from addons.mozilla.org on another website. for example on evernote.com :-)

Share this post


Link to post
  • 0

so, I suggest only to provide this file version 6.1 independently from addons.mozilla.org on another website. for example on evernote.com :-)

Surprisingly, can't find it there now... Am I getting dumb or something  :blink:  but there's no direct links to install clipper from evernote.com, only the ones that lead to mozilla addons page

Share this post


Link to post
  • 0

Yes, kjaerlige. You are not dumb.

 

It is just a little bit frustrating that they do not provide an essential function like the webclipper on their own website, besides the mozilla website, though it would be technically possible to make it available on their own website - at least for their paying users.

 

Now I use Webclipper "Version 5.9.1.1-signed". And it seems to work for now.

 

Best Regards, Martin

Share this post


Link to post
  • 0

There is a simple way to extract xpi file from mozilla profile, so I did it with my clipper. Here it is, 6.1 version, if anyone is interested.

https://www.evernote.com/shard/s65/sh/49e502dd-3495-4644-8a46-c5df0167e67e/6f4c8bc35e1f30db856b37c526c8c3d6

Though you may want to consider that I may not be trusted as an xpi source :ph34r: and that maybe 6.1 was removed from ff addons for some good reason.
But it works well for me, and my problem with "exception at..." error (while trying to use "Simplified clipping") was resolved by installing 6.1.
And - don't break yours, if it's working ;)

Share this post


Link to post
  • 0

Hi Kjaerlige. That is very kind and I really appreciate that you take your time to help. I would not even know how to extract an XPI.

 

Thanks a lot.

 

I tried it here at home, and unfortunately it does not show the context menu in my FF38.0.5. The icon in the toolbar works as expected.

 

I do not know how to clip a single image or text snippet from a website into my Evernote without the context menu. Maybe I could copy it from the website and paste it into the Evernote desktop or web application, but that is not so convenient and time consuming.

 

I know sometimes there are the weirdest reasons for the weirdest problems... such as a video card driver in combination with a certain audio software produces a bluescreen as soon as I launched the audio software. If the same element (software) behaves differently in different systems, that means for me that some elements in the system must be different and influence its behavior. Hard to guess which element in my PC interferes with my FF or the Evernote addon. Maybe I should better be patient and work with version 5.9.1.1-signed until a newer version is available that fixes this issue for me and my specific system. :)

 

Currently 5.9.1.1-signed seems to work as expected for me.

Share this post


Link to post
  • 0

It appears Mozilla pulled our 6.1 version. We'll report when we hear from them. Thank you for your patience!

Share this post


Link to post
  • 0

It appears Mozilla pulled our 6.1 version. We'll report when we hear from them. Thank you for your patience!

 

I just got an auto-update of my Evernote Web Clipper to version 6.1 this morning. Checked http://addons.mozilla.org and see that v6.1 has a release date of Released November 23, 2015.

 

  • Like 1

Share this post


Link to post
  • 0

Thanks Goggin. That's good news... Last weekend I just uninstalled Firefox and invested some time to move my workflow to some Chrome-based browser (called Iron browser).

 

Actually I miss one particular addon in Chrome, that I used to use in FF (Diigo toolbar). 

 

But, maybe now I will download FF again in the next weekend to try version 6.1 in FF.

 

 

 

 

btw. I just learned to like the Youtube video bookmarking feature in Webclipper for Chrome. Hopefully FF supports that too :)

  • Like 1

Share this post


Link to post
  • 0

Thanks Goggin. That's good news... Last weekend I just uninstalled Firefox and invested some time to move my workflow to some Chrome-based browser (called Iron browser).

 

Actually I miss one particular addon in Chrome, that I used to use in FF (Diigo toolbar). 

 

But, maybe now I will download FF again in the next weekend to try version 6.1 in FF.

 

 

 

 

btw. I just learned to like the Youtube video bookmarking feature in Webclipper for Chrome. Hopefully FF supports that too :)

Thanks for posting this. I had stopped using FF since the web clipper wasn't working while it did so in IE.

Share this post


Link to post
  • 0

I'm still having problems with Web Clipper 6.1 and Firefox current version (now 43). The option does not appear in the 'Tools' menu, nor in the right click menu options.

Back to IE as my default browser where the Clipper works but is PAINFULLY slow and hangs the system sometimes.

Hmm, maybe Web clipper isn't meant to be a useful tool....

Share this post


Link to post
  • 0

The Web Clipper extension in Firefox has always, well, sucked compared to its implementation in Safari and Chrome for OS X. And that's putting it nicely.

Now it doesn't work at all in Firefox. Though the Web Clipper shows as being installed when I look in the Firefox > Tools > Extensions window, the Web Clipper button doesn't even show up in any of the toolbars. I've done multiple removals and reinstalls.I have read through posts on this issue and I see that the disappearing toolbar button issue has reportedly been fixed with v6.1.

Evernote: I'm not seeing any evidence of that fix. In fact, things have gotten worse.

I'm using Firefox 43.0.2, Web Clipper version 6.1, Mac OS X (Yosemite) 10.10.5. I generally use Safari, with occasional use of Chrome and even less use of Firefox. It's not a life-or-death issue for me since Firefox isn't my primary browser. I simply don't understand why the EWC for Firefox has always so sub-par when compared with its siblings for the other browsers. Formatting of captured material has always been unevenly poor and options available in the EWC for Safari and Chrome were Missing In Action in the Firefox version. Clearly EWC for Firefox is problematic for a lot of users—both on OS X and Windows—and it looks like Evernote is working on it. Don't know if I should add to the pile-on with another tech support request/bug report.

 

  • Like 1

Share this post


Link to post
  • 0
2 hours ago, Bear in the Trunk said:

The Web Clipper extension in Firefox has always, well, sucked compared to its implementation in Safari and Chrome for OS X. And that's putting it nicely.

Now it doesn't work at all in Firefox. Though the Web Clipper shows as being installed when I look in the Firefox > Tools > Extensions window, the Web Clipper button doesn't even show up in any of the toolbars. I've done multiple removals and reinstalls.I have read through posts on this issue and I see that the disappearing toolbar button issue has reportedly been fixed with v6.1.

Evernote: I'm not seeing any evidence of that fix. In fact, things have gotten worse.

I'm using Firefox 43.0.2, Web Clipper version 6.1, Mac OS X (Yosemite) 10.10.5. I generally use Safari, with occasional use of Chrome and even less use of Firefox. It's not a life-or-death issue for me since Firefox isn't my primary browser. I simply don't understand why the EWC for Firefox has always so sub-par when compared with its siblings for the other browsers. Formatting of captured material has always been unevenly poor and options available in the EWC for Safari and Chrome were Missing In Action in the Firefox version. Clearly EWC for Firefox is problematic for a lot of users—both on OS X and Windows—and it looks like Evernote is working on it. Don't know if I should add to the pile-on with another tech support request/bug report.

 

I completely uninstalled FF today as it appears that EWC will never work in that browser.  I tried several different things to make sure it wasn't something in my settings: uninstall/reinstall FF and the EWC, ensure FF is updated, change FF settings for less security (went to defaults), turned off ad blocking add-ons, etc. Nothing worked through all of the various re-boots & installations. EN has been very quiet of late on this problem. I feel confident that my Windows 7 64 bit machine is completely up to date as is my anti-virus and firewall.

Since EWC is so slow in IE I have changed my work flow and don't use EN that much anymore. I'm back to bookmarking & printing selections of webpages. In fact my use of EN has become so reduced that there is no value in continuing the paid version  subscription when it comes due. EWC is not the only factor in my reduced usage. I have had several issues with syncing, variation in the number of notes between my computer and the servers, backup and recovery issues that ate an entire week of spare time. It isn't entirely clear what has happened to EN but the quality is no longer there. Programmers are removing popular features to 'enhance work flow' (not sure whose work flow they analyzed) , new versions are being released that cause user's interaction with the program to crash, premium support is very slow to respond and then there are different answers to the same question. The new Company president solicited input a few months back. I gave some but have not heard any acknowledgement that it was received, let alone that the problems are being worked on. EN has become just another company that took a really good product and engineered into something mediocre.  

Edited by betnel
typo

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...