Jump to content
Join the #EverBetterChallenge and finish what you start in 2019. Read more... ×
  • 0
Iriska

Iriska Evernote for Windows 6.17 beta 2

Idea

Today we released Windows 6.17 beta 2. It's available here!  
 
What’s in 6.17 beta 2?

Fixed:

- Client crashes on initial downsync
- Fixed several crashes that prevented users from merging 2 notes in space view from main menu
- Improved Shared with me functionality 
- Cursor jumps to the beginning of note body during sync while editing a note in a shared notebook
- CTRL + N for new note creates a note in default notebook instead of current notebook
- Multi select view automatically appears when using "Screenshot" button and CTRL + V
  • Like 1

Share this post


Link to post

42 replies to this idea

Recommended Posts

  • 0

Minor possible bug: when I upgraded to the previous beta, the note list was showing the Reminder Time header (which I always keep hidden, not needed in a saved search), and sort was set to the same (default is Updated sort, reminder sort is very rare).  Didn't think anything of it until it happened again when upgrading to beta 2. 

Since this only happened right after upgrading (twice), not sure about reproducing it, maybe someone else noticed the same behavior.

Share this post


Link to post
  • 0
7 hours ago, Iriska said:

- Multi select view automatically appears when using "Screenshot" button and CTRL V

I can confirm that this was fixed. Thank you, Evernote.

  • Like 2

Share this post


Link to post
  • 0
12 hours ago, Iriska said:

- CTRL N for new note creates a note in default notebook instead of current notebook

I'd like to clarify this one. This implies that Ctrl+N will always create a new note in the default notebook.

What I'm seeing is this:

  • If the current context contains more than one notebook (e.g. "All Notes", or a search that has results in several notebooks), such that there is no 'current notebook', then Ctrl+N will indeed create a note in the default notebook.
  • On the other hand, if there is a current notebook, then Ctrl+N will create a new note in the current notebook, not the default.

The behavior I see makes the most sense to me: if there is no current notebook, create the note in the default notebook, otherwise use the current notebook. Which raises the question: what's the intent of this item, particularly since it doesn't seem to do what it implies?

Share this post


Link to post
  • 0

Not having much luck with the 6.17 series - just tried to update to this version;  downloaded update and Evernote closed.  Waited for a while,  then restarted.  Evernote came back - still at 6.16.4 (which is where this laptop started off).  Now downloading again...  my bad:  checking for updates got me a "ready to be installed" window this time.  Now extracting...

Share this post


Link to post
  • 0
Just now, gazumped said:

Not having much luck with the 6.17 series

Probably due to all of the Brexit turmoil... :) 

Share this post


Link to post
  • 0

LOL believe me IT problems are a welcome escape from the daily news here,  which is full of speculation, wild rumour and argument - and that's coming from the politicians who were supposed to be sorting this out...

  • Like 1

Share this post


Link to post
  • 0
1 hour ago, jefito said:

The behavior I see makes the most sense to me: if there is no current notebook, create the note in the default notebook, otherwise use the current notebook. Which raises the question: what's the intent of this item, particularly since it doesn't seem to do what it implies?

What you're seeing is correct. I guess the wording on that item could have been better... There were a number of places in the program where you could have a notebook selected but the note would not be created in that notebook. Primarily around the notebook kingdom view I believe.

  • Like 1

Share this post


Link to post
  • 0

Things seem to be working logically for me - was just in All Notes and Ctrl+N gave me a new note in the default notebook.  Switched to a couple of other notebooks and the same command gives me notes in those notebooks.  Pretty much what I'd expect.

Share this post


Link to post
  • 0
3 minutes ago, gazumped said:

Things seem to be working logically for me - was just in All Notes and Ctrl+N gave me a new note in the default notebook.  Switched to a couple of other notebooks and the same command gives me notes in those notebooks.  Pretty much what I'd expect.

When you close the note do you stay in context or go to all notes?  Assuming the note is opened in its own window.

6.16 exhibits this less than friendly behavior. 

Share this post


Link to post
  • 0
38 minutes ago, CalS said:

When you close the note do you stay in context or go to all notes?  Assuming the note is opened in its own window.

6.16 exhibits this less than friendly behavior. 

Nope - went to notebook:  Ctrl+N for new note in that notebook;  saved note... still in that notebook.

Edit:  I say 'saved' - I closed the window and went back to the main window...

Share this post


Link to post
  • 0
1 hour ago, dconnet said:

notebook kingdom view

Hmm, haven't heard that term before is that the panel that appears when you click on the "notebooks" entry in the left panel?

Anyways, thanks for the clarification.

Share this post


Link to post
  • 0
35 minutes ago, jefito said:

Hmm, haven't heard that term before is that the panel that appears when you click on the "notebooks" entry in the left panel?

Internal verbiage slipping out... Yes, that view was created when we brought back the notebooks view (aka NBK). That same notebook list is also used for Spaces and SharedWithMe views.

Share this post


Link to post
  • 0
3 hours ago, gazumped said:

Nope - went to notebook:  Ctrl+N for new note in that notebook;  saved note... still in that notebook.

Edit:  I say 'saved' - I closed the window and went back to the main window...

Thanks.  I sometimes click on a shortcut to get the tags set when I create a new note.  In 6.16 when the note is saved/closed you go to all notes as opposed to returning to the search context.  Hopefully this is now fixed, I'll update my backup later and see.

  • Like 1

Share this post


Link to post
  • 0

Sync Bug -- Still seeing sync issues in the shortcut list that surfaces when I use iOS and Windows.  Can't confirm which platform really 'creates' the problem - but I end up with shortcuts disappearing as I switch between iOS (ipad) and WIndows platforms.

Share this post


Link to post
  • 0
7 minutes ago, ej8899 said:

Still seeing sync issues in the shortcut list that surfaces when I use iOS and Windows.  Can't confirm which platform really 'creates' the problem

The sync process is    Windows  <>  servers  <>  IOS

You can check your data on the servers using the web platform at www.evernote.com
This should help isolate the problem

Share this post


Link to post
  • 0
3 hours ago, ej8899 said:

Sync Bug -- Still seeing sync issues in the shortcut list that surfaces when I use iOS and Windows.  Can't confirm which platform really 'creates' the problem - but I end up with shortcuts disappearing as I switch between iOS (ipad) and WIndows platforms.

Saw that exact bug across all my devices last weekend. 

This weekend I saw something I previously blamed on forgetfulness: yesterday I did several hotsyncs, today I did not see a single update show up in my other devices, till I hotsynced just one more time today (yes, the hotsync dot on Windows EN was clear).

I suspect it maybe a server issue, not a beta issue.

Share this post


Link to post
  • 0
On 12/14/2018 at 12:55 PM, CalS said:

Thanks.  I sometimes click on a shortcut to get the tags set when I create a new note.  In 6.16 when the note is saved/closed you go to all notes as opposed to returning to the search context.  Hopefully this is now fixed, I'll update my backup later and see.

Context is maintained when adding a note.  Thanks.

Share this post


Link to post
  • 0

Is there anything changed concerning indexed pdf search ? I have a Plus subscription and I could search in my indexed PDF's without any problem.

Now, when I create a new note, with a copy of an indexed pdf from an old note that is still searchable, I can't search it. 

So I can't search the same pdf in a new note although it still works in my old notes, weird...

edit: also when I just duplicate an old note with an attached indexed pdf, the clone isn't searchable while the original still is...

Share this post


Link to post
  • 0
4 hours ago, eric99 said:

Is there anything changed concerning indexed pdf search ? I have a Plus subscription and I could search in my indexed PDF's without any problem.

Now, when I create a new note, with a copy of an indexed pdf from an old note that is still searchable, I can't search it. 

So I can't search the same pdf in a new note although it still works in my old notes, weird...

edit: also when I just duplicate an old note with an attached indexed pdf, the clone isn't searchable while the original still is...

I just tried it with a simple PDF, a receipt I scanned in with ScanSnap.  It appeared to work, both notes were found when I searched a word in the PDF.  Though one data point doesn't create a straight line...

Share this post


Link to post
  • 0
9 hours ago, CalS said:

I just tried it with a simple PDF, a receipt I scanned in with ScanSnap.  It appeared to work, both notes were found when I searched a word in the PDF.  Though one data point doesn't create a straight line...

Thanks for testing, but isn't Evernote's OCR  used for premium users (I have a Plus subscription without EN OCR, that's one of the reasons that I use indexed pdfs , the other reason is that I don't want to lock me in)

Share this post


Link to post
  • 0
4 hours ago, eric99 said:

Thanks for testing, but isn't Evernote's OCR  used for premium users (I have a Plus subscription without EN OCR, that's one of the reasons that I use indexed pdfs , the other reason is that I don't want to lock me in)

I OCR all my own PDFs even though I am a premium user.  EN web site only shows PDF search for Premium or business, but unless things have changed user OCRd PDFs are searchable.  

Did another quick test using the web version with my test basic account.  Dragged a PDF from a PDF only note to the desktop, and then added it to a new note.  That new note and the original were both found with a word search.  So whatever PDF index attached to the note seemed to survive moving to the desktop and back.  Not quite a note copy but close.  Sorry I can't be more help.

Share this post


Link to post
  • 0
2 hours ago, CalS said:

I OCR all my own PDFs even though I am a premium user.  EN web site only shows PDF search for Premium or business, but unless things have changed user OCRd PDFs are searchable.  

Did another quick test using the web version with my test basic account.  Dragged a PDF from a PDF only note to the desktop, and then added it to a new note.  That new note and the original were both found with a word search.  So whatever PDF index attached to the note seemed to survive moving to the desktop and back.  Not quite a note copy but close.  Sorry I can't be more help.

Thanks for testing.

The search behaviour is very unpredictable: while duplicating a note, not only a new note is created, but my old note is touched as well. From then on; none of these notes with attached OCR  indexed pdf are searchable anymore.

I opened the attached pdf with adobe acrobat reader and I can still search inside the OCR'ed index. So the pdf file is not corrupted.

Then I did the same query in Evernote For Web, and surprise, I can find all expected notes.

So, my conclusion so far is that this  problem is introduced by this Beta release. I will roll back to the latest release to confirm this.

Question: Is the query always handled by the EN servers or is it cached locally?  Maybe this local cache may be corrupted...

Share this post


Link to post
  • 0
59 minutes ago, eric99 said:

Thanks for testing.

You are welcome,

57 minutes ago, eric99 said:

Question: Is the query always handled by the EN servers or is it cached locally?  Maybe this local cache may be corrupted...

I do not know. 

A quick way to check if a PDF is OCR'd can be to try and copy some text from the PDF in the note window.  Not 100% sure, but it seems if not OCR'd you can't copy.  Could be wrong though....

 

 

Share this post


Link to post
  • 0
57 minutes ago, eric99 said:

Thanks for testing.

The search behaviour is very unpredictable: while duplicating a note, not only a new note is created, but my old note is touched as well. From then on; none of these notes with attached OCR  indexed pdf are searchable anymore.

I opened the attached pdf with adobe acrobat reader and I can still search inside the OCR'ed index. So the pdf file is not corrupted.

Then I did the same query in Evernote For Web, and surprise, I can find all expected notes.

So, my conclusion so far is that this  problem is introduced by this Beta release. I will roll back to the latest release to confirm this.

Question: Is the query always handled by the EN servers or is it cached locally?  Maybe this local cache may be corrupted...

I uninstalled this beta and reinstalled 6.16.4.8094 (308094) Public (CE Build ce-58.1.6897) and synced the complete database from scratch.

However, I still can't search the expected indexed pdf notes, while I can find them via Evernote For Web.

Conclusion: this search bug is in the released version as well !!!

Share this post


Link to post
  • 0
15 minutes ago, CalS said:

You are welcome,

I do not know. 

A quick way to check if a PDF is OCR'd can be to try and copy some text from the PDF in the note window.  Not 100% sure, but it seems if not OCR'd you can't copy.  Could be wrong though....

 

 

I tested this and it is indeed handled as text. I can also search in adobe acrobat reader. The same note is searchable via Evernote For Web. So there is nothing wrong with my data on the servers, everything is searchable but not via Evernote for windows (also not working with the latest release 6.16.4)

Edit: Older notes that aren't changed the last weeks (month?) are not affected, they are still searchable.

Edit: The pdf search does work in Android Evernote as well

Share this post


Link to post
  • 0
55 minutes ago, eric99 said:

I uninstalled this beta and reinstalled 6.16.4.8094 (308094) Public (CE Build ce-58.1.6897) and synced the complete database from scratch.

However, I still can't search the expected indexed pdf notes, while I can find them via Evernote For Web.

Conclusion: this search bug is in the released version as well !!!

Since I went back to 6.16.4 and experienced the same pdf search problem for my newest notes (last weeks), I decided to 'touch' the note by adding some characters  to the title or body. From then on, the pdf is searchable again ! 

What's happening here? I rebuilt my database from scratch, no history whatsoever. Why do I need to touch the note to reactivate the indexed pdf search ?

Is it possible that my newer notes which were created by this beta are in some way different than my older notes? When I edit these notes in 6.16.4, these notes are searchable again ?!?

I could further prove this by re-installing the beta  but I don't dare to further compromise my notes.

Share this post


Link to post
  • 0
11 minutes ago, eric99 said:

Since I went back to 6.16.4 and experienced the same pdf search problem for my newest notes (last weeks), I decided to 'touch' the note by adding some characters  to the title or body. From then on, the pdf is searchable again ! 

What's happening here? I rebuilt my database from scratch, no history whatsoever. Why do I need to touch the note to reactivate the indexed pdf search ?

Is it possible that my newer notes which were created by this beta are in some way different than my older notes? When I edit these notes in 6.16.4, these notes are searchable again ?!?

I could further prove this by re-installing the beta  but I don't dare to further compromise my notes.

Wow.  Maybe a sync opportunity?

Share this post


Link to post
  • 0
20 hours ago, eric99 said:

Since I went back to 6.16.4 and experienced the same pdf search problem for my newest notes (last weeks), I decided to 'touch' the note by adding some characters  to the title or body. From then on, the pdf is searchable again ! 

What's happening here? I rebuilt my database from scratch, no history whatsoever. Why do I need to touch the note to reactivate the indexed pdf search ?

Is it possible that my newer notes which were created by this beta are in some way different than my older notes? When I edit these notes in 6.16.4, these notes are searchable again ?!?

I could further prove this by re-installing the beta  but I don't dare to further compromise my notes.

Now that I downgraded back to 6.14.4, I scanned a document and saved it as an  OCR indexed pdf file in my evernote import folder. The note is created and the indexed pdf is searchable!

When I did that with this Beta release, new notes with indexed pdf were not searchable, at least not in Evernote for windows. They were however searchable in Evernote for Web or Android.

  • Thanks 1

Share this post


Link to post
  • 0

I just realized why searching stopped working. The IFilter plugin we're using was causing a lot of crashes (when sycning) so it was removed (certain PDFs caused total memory corruption - no exception handling could catch it). Turns out that was how the pdf text was being indexed in the database. Which means I am now working on putting back this filter - which _will_ causes crashes for some people. But we'll add a registry switch to turn it off also. In the meantime, we're investigating an upgrade for the filter (I remember many years ago being told we had decided not to upgrade because of cost - hopefully that's changed!)

(FYI: OCR has nothing to do with this)

  • Like 1

Share this post


Link to post
  • 0
50 minutes ago, dconnet said:

I just realized why searching stopped working. The IFilter plugin we're using was causing a lot of crashes (when sycning) so it was removed (certain PDFs caused total memory corruption - no exception handling could catch it). Turns out that was how the pdf text was being indexed in the database. Which means I am now working on putting back this filter - which _will_ causes crashes for some people. But we'll add a registry switch to turn it off also. In the meantime, we're investigating an upgrade for the filter (I remember many years ago being told we had decided not to upgrade because of cost - hopefully that's changed!)

(FYI: OCR has nothing to do with this)

Thanks for the diagnosis. My scanner OCR'ed my document to generate the indexed PDF. It has nothing to do with evernotes OCR, I agree.

Was the IFilter plugin still activated in the 6.16.4 release? Because in that version the search is OK...

Share this post


Link to post
  • 0
59 minutes ago, dconnet said:

I just realized why searching stopped working. The IFilter plugin we're using was causing a lot of crashes (when sycning) so it was removed (certain PDFs caused total memory corruption - no exception handling could catch it). Turns out that was how the pdf text was being indexed in the database. Which means I am now working on putting back this filter - which _will_ causes crashes for some people. But we'll add a registry switch to turn it off also. In the meantime, we're investigating an upgrade for the filter (I remember many years ago being told we had decided not to upgrade because of cost - hopefully that's changed!)

(FYI: OCR has nothing to do with this)

Does this mean some PDFs that are in one's data base but not indexed?  and how to catch those if so?

Share this post


Link to post
  • 0
3 hours ago, CalS said:

Does this mean some PDFs that are in one's data base but not indexed?  and how to catch those if so?

Simply viewing the note will index them. What I need to test still is what happens to the others. (It also indexes when the note is updated on another machine and synced) It's still very early in testing (I mean I literally figured out the issue just before lunch time today!) - I still need to add some UI to turn this off for users who have "bad" pdfs that crash the filter. (I have some better ideas for blacklisting bad pdfs, that that will take at least a week to prototype and we're trying to get a beta3 out "real soon now".)

  • Like 1

Share this post


Link to post
  • 0
12 hours ago, dconnet said:

What I need to test still is what happens to the others. (It also indexes when the note is updated on another machine and synced)

So temp tagging all PDFs on one machine should sync and force an index on the other, remove the tag on machine 2 will then sync to the first and fix any issues there?  I know tag changes don't update the updated field but they do force a sync.  Once the fix is in, anyways.  I'm interested because a chunk of the notes I add each week are PDFs.  Thanks.

Share this post


Link to post
  • 0

OK - bug (I think)...  moving the database location from within Evernote is a bad idea...

Short version - I changed the location of my database from C to D drive (on the same volume) which is where I have my documentation stored anyways.  I used the Tools Options General menu,  and got messages that files were being copied (the numbers were changing impressively quickly since the database is 18GB or so) until:  several files could not be copied because they were 'in use'.  By Evernote.  Which was open and copying the files from one location to the other. 

I shut Evernote down and now see that some files were left in the old location,  but files with the same name and an earlier time stamp were created in the new location.  I'm going to move the files in the original folder to a backup folder on D:\ until I find out how well or badly Evernote behaves from now on...

Probably just confusing messages and no issue - but in terms of not upsetting users,  it would be good to clarify that maybe the folder should be moved with Evernote closed,  and then open Evernote offline to redirect it to where the folders are now...  a helpful warning message in the Tools Options window perhaps?  Or build in a 'skip files' flag for the ones that are open with Evernote running.

The background -

It's the day after Christmas and I'm reasonably sober and coherent (Happy Holidays,  by the way...) - what should I do but try to fix my 'backup' laptop which has a problem with Windows updates. Again. 😠

Amongst the many errors I'm fixing is a generalised lack of space issue on C:\ drive - there's 25% space left on a 300GB drive - around 80GB  - though I do have a spare D:\ drive (part of the same volume) with another 200GB lying around.  Of all the apps I have installed,  the easiest target for a quick gain is probably Evernote which is an 18GB lump.  I should be easily able to move the database from one place to another on the same hard drive - there's even that 'change database location' button in Tools....

 

Share this post


Link to post
  • 0
1 hour ago, gazumped said:

OK - bug (I think)...  moving the database location from within Evernote is a bad idea...

Short version - I changed the location of my database from C to D drive (on the same volume) which is where I have my documentation stored anyways.  I used the Tools Options General menu,  and got messages that files were being copied (the numbers were changing impressively quickly since the database is 18GB or so) until:  several files could not be copied because they were 'in use'.  By Evernote.  Which was open and copying the files from one location to the other. 

I shut Evernote down and now see that some files were left in the old location,  but files with the same name and an earlier time stamp were created in the new location.  I'm going to move the files in the original folder to a backup folder on D:\ until I find out how well or badly Evernote behaves from now on... 

Probably just confusing messages and no issue - but in terms of not upsetting users,  it would be good to clarify that maybe the folder should be moved with Evernote closed,  and then open Evernote offline to redirect it to where the folders are now...  a helpful warning message in the Tools Options window perhaps?  Or build in a 'skip files' flag for the ones that are open with Evernote running. 

 

 

I don't think that would work. Evernote would open after the move and get confused. The old way was to:

  • Shut down evernote.
  • move the files
  • edit the registry to show it in the new location
  • start evernote.

The new way is supposed to make it easy. But you should probably close evernote first, then open it and do it so it doesn't have a bunch of open links to files. This is how stuff never gets removed from the Attachments folder, which should be empty when you close evernote.

I'd want to really test your method above on an install that I didn't care about before recommending it. Given what you said happened, I'd do the registry thing, but I honestly never partition my drives anymore. I just have a 1TB drive here and it is all C:\

  • Thanks 1

Share this post


Link to post
  • 0
9 hours ago, EdH said:

The new way is supposed to make it easy. But you should probably close evernote first, then open it and do it so it doesn't have a bunch of open links to files.

Absolutely agree - maybe Evernote could script it so there's a warning that "Evernote will sync and shut down to move files",  files are flagged to be moved,  and the new location is updated in the registry - all of which then happens when Evernote has synced and closed - and the app then restarts.

Happy to report that things seem back to normal on my other machine.  There's a big note on the screen "IF IT WORKS..."

Share this post


Link to post
  • 0

OK - another oddity.  I'm running Evernote for Windows 6.17.2.8206 (Premium) and decided that one way to work around some occasional freezes I'm experiencing would be to start using a second (Basic) account for new notes,  sharing one or more notebooks with my main account to transfer notes across.  It's essentially a separate Inbox account.  (I'm keeping an eye on the upload allowance.)

I've known for a while that my Premium account window has a File menu option to open another account ("add another user") but didn't realise until now that this opened a second Evernote window which has interesting possibilities for moving notes around.

Haven't tried anything ambitious yet but was happily adding new notes to my new account via template (clicking on an ENEX file to open a new template) when my second window suddenly closed - it looked like a 'normal' crash - of which I've had a few - except that my Premium account kept running.  The File menu still showed a tick against the basic account as though it was still open,  but there was no active window.  There was no way to re-open the second window,  so I eventually restarted Evernote anyways,  and got back to my 2-window-open situation.  But it was odd that one instance should (apparently) crash while another would not.

System stats at the time were single-digits for CPU and Disk and about 70% memory.  I'm currently back to using Firefox which is the main part of that.

The note that I had been working on for the crashed account got saved back into the premium account,  so there was no loss of data.

Just weird.

Share this post


Link to post
  • 0
16 hours ago, gazumped said:

But it was odd that one instance should (apparently) crash while another would not.

Maybe it is one instance with two data bases.  Got lost in the second data base somehow?

Share this post


Link to post
  • 0
6 hours ago, CalS said:

Maybe it is one instance with two data bases.  Got lost in the second data base somehow?

Thanks,  but I don't think so - haven't shared notebooks between the two accounts yet,  and they're completely different users - signed in via Bitwarden so it's not me mixing up logins either...  There are two databases in the folder.  Just odd.

Share this post


Link to post
  • 0
3 hours ago, gazumped said:

Thanks,  but I don't think so - haven't shared notebooks between the two accounts yet,  and they're completely different users - signed in via Bitwarden so it's not me mixing up logins either...  There are two databases in the folder.  Just odd.

Odd indeed.  I used this capability for a while a ways back, cleaning up my wife's EN data.  Worked fine best I can remember.  Didn't care for it long term since one can't designate by user name as ODS or not.  I don't use ODS for my main account, but is fine for the occasional test or backup account access.  Really didn't need her DB stored on my PC for what I was doing.  So I'm back to using the browser for that.  🤷‍♂️

Share this post


Link to post
  • 0
On 1/1/2019 at 4:51 AM, gazumped said:

But it was odd that one instance should (apparently) crash while another would not.

They are 2 completely separate instances running. With some coordination via the tray icon program. Program robustness for detecting that other instances have crashed could (um, yeah) use a little work...

  • Haha 1

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×