• Announcements

    • Shane D.

      Evernote Business Beta - Spaces   12/20/2017

      We're very excited to announce the public beta of an upcoming rework for Evernote Business! To learn more, go Here
    • Shane D.

      2018 Evernote Webinars   01/04/2018

      To kick off the new year, we're excited to announce our  updated schedule for our series of webinars! Please check the events calendar to see which one works best for you!
Andrew R

Safari Mac Safari Webclipper - nothing happens

Recommended Posts

I thought the previous version of clipper was fun enough (constantly being asked to sign in, suggestions to "why not clip this PDF" on every single PDF opened) but it's now not working at all.

When I click the evernote button a new tabs opens and ends up at URL www.evernote.com/ClipperSuccess.action?canClose=true&login=true    This quickly closes leaving me back on the page I wanted to clip but nothing else happens.

I've already tried reinstalling the extension (now on 6.11), restarting browser, clearing all evernote cookies/local storage.

 

Screen_Shot_2017-03-08_at_12_06_49.jpg

 

Update: This was resolved as follows: 

  • Uninstall the Evernote Web Clipper in Safari by navigating to Safari > Preferences > Extensions > Evernote Web Clipper and choose Uninstall
  • From the menubar, choose Safari > Clear History and choose All History > **Clear History
  • On your keyboard, press ⌘ command + ⌥ option + esc simultaneously, then select Safari and choose Force Quit
  • Restart your Mac
  • Open Safari and install the Evernote Web Clipper from www.evernote.com/webclipper
  • If prompted to choose between installing the extension from the Safari Extensions Gallery or directly from the developer choose Install from Developer.
  • Navigate to Safari > Preferences > Extensions > Updates to ensure you have the latest version of the extension installed
Edited by Andrew R
Updated with resolution

Share this post


Link to post

Followed solution steps as described above. Clicking on the web clipper still does nothing. Not sure what happened within the past few weeks but it used to work flawlessly. Now, nothing!

Share this post


Link to post

Manually cleaning EN local cache files stored in ~/Library/Safari/LocalStorage/ did the trick for me, check this post with entire workaround:

 

  • Like 1

Share this post


Link to post

Ah I'd tried that beforehand and it hadn't helped so perhaps in some cases it's a combination of both the above AND clearing LocalStorage that's needed to get things working again.

Share this post


Link to post

Folks have done a lot of good work to come up with ways to fix this. The problem is, and Evernote is not acknowledging it, these solutions require USERS to uninstall potentially many things, clear out low-level (relatively speaking) files, then execute various restarts and reinstalls until finally - hopefully - the Evernote Web Clipper works. (And those results seem a little mixed as to success.) Casual users who just expect products to work likely will not do this, or worse, end up breaking something they can't fix. While I am a fairly experienced user, this is too much of a pain when I can just use the One Note clipper to do the same thing for the relatively few items (in the big scheme of things) that I actually clip. Sure, it means I have to use a separate app to view them. But that is less intrusive (for me) than trying to fix something that is not designed well. A better approach, if Evernote would think of users first, would be to provide an update that replaces the (obviously) defective version of the Web Clipper and as part of the installation process clears out the files no longer needed by the extension. There is just something wrong with a solution that requires me to uninstall extensions from companies A-E in order to reinstall a malfunctioning version of an extension from company F.

  • Like 1

Share this post


Link to post

Does not work for me. Tried the first method. Clean the LocalStorage too. What a shame ! The only solution now for me is to open the website on my iPhone and use the iOS Evernote extension... 

Share this post


Link to post

You have to set Safari's privacy preferences to allow cookies from websites I visit, otherwise clipper won't work.

  • Like 1
  • Thanks 1

Share this post


Link to post

I already have Safari's preferences set that way, so that's not the issue. As I said earlier, the web clipper was working fine for months then just stopped. I can't wait on Evernote so I've been using the OneNote web clipper instead. It actually works.

Share this post


Link to post

I am having issues with this as well. I have tried everything suggested above but alas it doesn't work. I sign it. It flashes "success" and then nothing. So darn frustrated.

Share this post


Link to post

Seems like Evernote doesn't give a hood. Shameful that they are not replying after many months of complaints. I had one out of 4 working Macs left. I had to do a clean install and after that web clipper is a bit like Donald Trump. It finds itself a big succes and says even so overtime when clicking the icon. Nothing happens of course. 

I am getting fed up. Need to see if an alternative service is working.

Share this post


Link to post
6 hours ago, The Barbarian said:

Shameful that they are not replying after many months of complaints

In the nearly 10 years of this forum,  Evernote have never replied to complaints or requests except very very occasionally if they needed more information from the poster. 

The way to get a direct response is to contact Support directly if you're a paying customer on https://help.evernote.com/hc/requests/new or tweet them if not via https://twitter.com/evernotehelps

  • Like 1

Share this post


Link to post
On 8/9/2017 at 11:41 AM, adcbc said:

You have to set Safari's privacy preferences to allow cookies from websites I visit, otherwise clipper won't work.

*** This worked for me! Thank you so much! ***

This is the solution folks. Just wanted everyone to know. :)

Share this post


Link to post
On 02/09/2017 at 5:02 PM, pbubblegum said:

Has a true fix ever been developed? I've tried everything here but nothing works.

There seems to be a fix which works for lots of users - see above.  If all else fails,  contact Support.  You can contact them directly if you're a paying customer on https://help.evernote.com/hc/requests/new or tweet them if not via https://twitter.com/evernotehelps

Share this post


Link to post

adcdc solution noted above worked!  

On 8/8/2017 at 8:41 PM, adcbc said:

You have to set Safari's privacy preferences to allow cookies from websites I visit, otherwise clipper won't work.

 

Share this post


Link to post

Just stumbled upon this same symptom in September 28, 2017 after installing WebClipper for the first time. Lost a browser session full of open tabs while trying to resolve it. Simply by restarting my browser, for some reason Safari did not restore the opened tabs. Nothing that can not be googled again but a pain in the 455.

I'd recommend to not use WebClipper and just try plain copy and paste.

Share this post


Link to post

The webclipper is the only reason to stay with evernote, but this has happened to me before and it's happening again now. None of the above solutions work for me, and I've had enough now—I can't be bothered to waste more time on this shoddy product. I'm a premium customer, but I won't be renewing. It's DEVONthink all the way from now on.

Share this post


Link to post

I have now read through several threads on this topic.

I am having the same issue on Safari Version 11.0 (12604.1.38.1.7), and Webclipper 6.12.4

I have tried all the proposed solutions:

- Enabling all cookies (really?  this is a thing? in 2017?)

- Uninstalling, Clearing history, forcing quit, rebooting, re-installing

- Uninstalling, clearing Safari history, forcing quite, going into Library/Safari/Localfiles and clearing it all out, re-installing

- Logging into Evernote web version

- Shouting very loudly at the screen

Nothing has fixed the unable to log in to Evernote on Safari problem (the "dot" is still on the extension icon, and I get the open tab, login, logout cycle when I try to use it)

The only solution appears to be either (a) Use a different product, (b) Use Chrome

I am an Evernote premium customer - have been for 4+ years - but am now seriously reconsidering.  This is ridiculous.

Share this post


Link to post

Yes, I am having the same problem as well. When I click on the clipper button it only reloads the website again. Have tried the whole reboot, clear cache, reinstall clipper. nothin works.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now