Jump to content

Recommended Posts

  • Level 5

We had a similar thread on the Mac client. It stopped cold after a few posts when the thread owner followed this procedure (adapted for a PC):

  1. Go to File > Sign Out [name] from the menu bar.
  2. Select the "Remove my Evernote data from this device" option, then click Sign out.
  3. Restart your computer.
  4. Sign back in to Evernote

It seems a „stuck“ note in the local database caused all the trouble, by trying (and failing) to save a single corrupted note over and over.

Except of this it is a very bad idea to run an unsupported OS these days, when even supported software has a hard time to keep up with threats. IMHO there is NO reason to stick with an unsupported OS. If you believe you need it for some exotic reason, get an actual OS, install a VM and install the old OS and the dead old, bad, outdated software inside of the VM. This way you can simply delete the VM install if it gets corrupted. And the VM will shield it from taking over the whole computer.

Link to comment
  • 1 month later...

As a windows user getting  >7 GB written to SSD daily by EN while being idle and doing nothing, I asked support when this issue will be resolved. They confirmed the bug and know the forum thread. They said they are still investigating it but have no ETA for a fix (ticket# 3558257). They suggest switching to legacy in the meantime. I will monitor this with future versions and quit EN for windows if not needed (menu - quit).

  • Like 2
Link to comment
  • 2 weeks later...
  • Level 5
3 hours ago, Alxa said:

Update for the new EN 10.45.18 released today: issue not resolved, so the newly built-in option to start EN with windows unluckily is no reasonable choice for affected users. Will go on monitoring this.

Thanks for keeping this updated. I haven't checked, frankly, so I don't know if I'm getting this activity on my Evernote 10 installation. But truly out of ignorance, I want to ask what damage this constant "disk" activity might do? With an SSD, as I understand it, there is no disk, so there is no mechanism to be given extra wear and tear, but just a matter of writing and rewriting to flash memory. Still, I can see that it would be a problem if all that writing were slowing down the computer overall. Is that what you're experiencing?

Link to comment
  • Level 5
On 11/2/2021 at 9:28 PM, PinkElephant said:

On the other hand, what is going on is far below the guaranteed lifetime cycles of a modern SSD. When I take this SSD SDSSDXPM2-1T00 SanDisk Extreme Pro M.2 NVMe 3D SSD 1TB (a typical Laptop Consumer SSD, priced at appr. 140€/$), it has a TBW of 600TB. This means you could make a complete (!) rewrite of 1 Terrabyte every day for nearly 2 years to reach the lifetime expectancy.

If you take the above posted 17GB of „unnecessary“ data written (over several days, as I read it), such an SSD could sustain it for nearly 100 years if it happens daily, every day during these 100 years. Yes, it is OK to ask EN what is going on here. But it is not really worth to be overly alarmist neither.

I have made this calculation already. Taking the TBW of a normal consumer grade SSD, and the volume of data written that was reported in the thread, it could go on for appr. 100 years until an SSD is stressed out. Sure there are other uses for an SSD than to tolerate background writing - it just means there is no imminent damage done to the hardware.

If it is OK or not I can't find out - the number of users posting here has not been growing, so I doubt it is a general problem. Maybe related to either a specific configuration of some systems, or an hardware issue (like a driver going wild).

A seemingly similar issue on the Mac side could be resolved by reinstalling the database. This does not seem to help on Windows systems.

  • Thanks 1
Link to comment
  • 7 months later...
  • Level 5

What does it tell you that above of your post, there is a box telling "7 month later" ?!

The problem went as it came: Unannounced. Probably an update solved it for the few, that ever had the problem.

Link to comment
35 minutes ago, galaktor said:

... did anyone notice that this bug is solved ? ... thx

I did not notice the bug being resolved, Evernote for Windows is still constantly writing at 0,1 MB/s on my hard drive when being idle. No change.

Link to comment
  • Level 5

And sure THIS must be a problem. 0,1 MB/s ... a program that is constantly syncing will always write something, even if it is just to the log. On my Mac EN is at position 18 in the disk use ranking - hardly an issue with an actively used app.

You better install your MS-DOS to make 0,1MB a measurable unit again.

Link to comment

@PinkElephantI think we got your point! So no need of commenting on every post that you see this as a no brainer.  Would make finding new information throughout this thread much easier. Thank you.

I investigated for other apps showing the same foot print of permanent writing to disk. On my installation UpNote for windows does this permanent writing as well. Both apps are using the Electron framework. Maybe the chosen framework is to blame here. 🤷🏼‍♂️

  • Like 1
Link to comment

@Alxa Have you tried doing a full reinstall? My EN has been idle for around 5 mins and disk writing is at 0 and was the same for the few minutes I watched. 

I'm on Win 10 with 10.55.2 installed.

Have you contacted support?

Link to comment
  • Level 5

When you go to the location of the local install, you can (usually) see per folder and file when it was last written.

I had EN open and idle now for a few hours. I can see the last access was right now, but it was in the folder called "Cache". The file contains some gibberish, that looks to me as being a log entry. This was without me going to the client that is silently parked in an open window on my Mac, while I'm using other apps. The last entry in the local storage was today 10.18h, which was a note shared with me at around this time.

It takes some effort, but you can come close to what's going on. The white noise in disk access is the typical overhead of an app logging that nothing has happened. This is not surprising - it even happens when you run your own servers, they are logging away all of the time either. I wouldn't call it "disk trashing" - it is a few KB each file, cached away. Usually if you encounter a problem later, these files are used to build a history to allow support a reconstruction of what happened last.

Link to comment
  • 4 months later...

I am running version 10.60.4-win-ddl-public, and this has just started happening to me. Disk is being thrashed as described by other users. I have changed nothing recently, and am not runing any additonal anti-virus or similar software. Disappointing to come to the forum and find this appears to be such a well-known and long-standing issue. It clearly effects some users some of the time, but that is no excuse for inactiona s is documented here.

Link to comment
  • Level 5

You see, that’s what happens when the local database is corrupted. You call it „disk trashing“, a misleading term another user has minted.

It simple means that the app tries to save a piece of data, fails and tries again. Can happen, and all the scandal about it created in this thread is completely beside the point.

Replace the local database with a fresh copy from the server. Use a specialized app to do so (Revo Uninstaller for PC, AppCleaner for Mac), after that restart the computer. Reinstall from the EN website.

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...