Jump to content

Cancel Search box and get returned some previous point in the text.. not point of search result


Recommended Posts

Something got borked in recent update.  (methinks)

When you search for text in your note, it moves to that text and highlights it.. but if you then hit Esc, or click the X, to close the Search box, it will return you to some previous position in the note, when it should leave you at the location of the search result.  What up with dat?

Link to comment
  • Level 5*

Hi.  On a quick test "dat" seems to be how other apps behave too.  If I search for something and find something that looks like the right area,  I normally (I think) click somewhere nearby to copy / paste / spellcheck / insert - or do whatever it was I was searching for.  If you click and then 'esc',  you are left in the right place.  Starting a search but then cancelling it (correctly) returns you to wherever you were at the start.

Link to comment
  • Level 5

Hmm. On v. 10.38.1 (Windows app) and 10.38.2 (Web), I find that Esc out of a search does leave me at the located search term--which is also how it works in my Web browser and maybe other software as well.

Link to comment

Really?  Oh, I'm on v10.37.3.  Maybe they fixed it in new version.  I checked for an update and found none.  Did you update via Evernote app, or download fresh install?

Link to comment
  • Level 5

The Web client updates automatically, I think. I actually got an update notice in the Windows app, but I tried this in v. 37 and it worked as it should, and continued to do so after I updated to v. 38. IAC, as @agsteele says, you can always go to evernote.com and download the current version if it hasn't rolled out to you. They do sometimes accidentally introduce little boo-boos into an update and fix it in the next one.

Link to comment
  • Level 5

The web client updates automatically, the user can’t enforce it. EN rolls out updates in waves, so not every user gets updated at the same time.

For the installed clients it is possible to get around this by downloading from the EN website - there it is always the latest version. But not so for the web client - sometimes it takes some days until it finally shows the ultimate edition.

Link to comment

My Evernote did update today, finally... 

10.38.1-win-ddl-public (3408)
Editor: v149.0.18202
Service: v1.53.0

and, the issue appears to be fixed, but now I'm having trouble recollecting whether I had tried this particular sequence before, and if so, what the behavior was...

If I go to some random spot in my note and click to place the cursor there, and then click Ctrl+F to get the search box, then type something that takes me elsewhere... I swear just hitting Esc at that point would return me back to the previous spot, which seemed to be annoying and was thwarting my attempts to properly automate something via autohotkey (separate macro prog).

However, now, after this update... hitting Esc doesn't seem like it's forcing page to return to previous spot anymore (woot), so that's good. 
And after hitting Esc, if I then try to use the arrow keys to move around, it WILL return me to that previous spot (where the cursor still is)... which I guess is understandable and fine.  After all, I hadn't yet clicked anywhere near my search results spot, so EN wouldn't really know where to place a cursor (unless right before the found text, I suppose).

To make it work right, I just need to click somewhere on the page, after hitting Esc, and before attempting to move via arrow keys... and I'll be good, I guess.

So, problem solved, it would appear.  

The only thing I'm not clear on, is whether somehow this was the same behavior before the update, and after, but I just misinterpreted what it was supposed to be doing...  However, I feel pretty confident it wasn't staying in the new location, even after a click on page.. and that as soon as I canceled (or Esc'd) the search box, it would always return me back to the old spot elsewhere in the note.  Imma go with that.. Evernote goofed, and then fixed it.  Yeah.

  • Like 1
Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...