Jump to content

Randomly cannot "annotate image" in a note


Recommended Posts

Just more garbage from this ever increasingly terrible app...

Today I have a note in the mac application with a bunch of screenshot images and now I am finding that "annotate image" no longer appears when right clicking on half of the images in this note file — but if I close the note, come back to it SOMETIMES I can select annotate and then I can right-click again and that option is no longer available.

So I guess the ability to draw a friggin arrow on a screenshot is something I have to once again do in Photoshop?

Combined with the fact the web application keeps deleting updates to notes without auto-saving them as I work this is crippling me right now.

I am very actively looking at replacing this app. I've been a paid customer for years but Evernote is on the VERY TOP of my list when I give user experience presentations as a UX architect as one of the most broken piece of garbage apps I've ever used which continues getting worse by the week. There are a few more but Evernote is the #1 buggiest piece of software I use and it would take me a week to document everything I find broken in the app if I were to create a forum thread for each.

The facts are that most of the bugs I find have forum threads going back 10+ years of people complaining about the same broken feature.

I assume the developers at this company hate their jobs.

  • Like 1
Link to post

I captured and pasted every image in this note exactly the same way. On half of them there's no possible way to see "annotate image" — it just doesn't show up in any menus.

On the other half of the images, you can right-click on them and annotate them just like you're supposed to be able to.

Figured I'd open a thread so people can complain for 10 years while it doesn't get fixed.

Link to post

I might have found the possible cause of this problem => images can only be annotated after they are uploaded to Evernote server?

After my note finish syncing, I can annotate those  images in it again.

  • Like 1
Link to post
  • 1 month later...

I had encountered this problem on a number of occasions as well, but kept putting off investigating it further.  I also thought maybe I had just clicked incorrectly - which would be odd after being a Mac tech for 25 years…but it's possible.

I will give this "feature" more attention & testing because I too use that feature a fair bit - not as extensively as the OP, but as a long-time subscriber, it's one of the features that was making me reconsider my renewal.  

 

Link to post
  • 1 month later...

I am pretty sure you file it here, and then sit back and wait as they ignore everyone who has the same problem for the next 10 years.

That seems to be the case any time I am having an Evernote issue.

You are pretty much stuck having to find a workaround yourself.

Link to post
  • 2 months later...

I am also having the exact same same problem as DrunkenCyclist. It is intermittent, but driving me crazy.

If I click on another note then back onto the note with the .jpg I am trying to annotate, it sometimes works.

Screen Shot 2019-06-24 at 12.49.37 pm.jpg

Link to post
  • 2 months later...

I had exactly the same problem and found a fix !!

I noticed that this problem was only occurring when I was running the evernote app on my Mac AND was connected to a VPN.  The problem was further obscured by the fact that some VPN connections did not produce this problem.  However, when the problem did occur and I switched the VPN off or moved to a less 'conspicuous" VPN server :) , the problem went away instantly and I could annotate all previous images that I couldn't before.

Hope this helps!!

Link to post
  • 5 months later...

This is really bad. Having the exact same problem. Was able to annotate my old images, but not the new ones.

Seems like you cannot annotate until your image is synced to all your devices. This is a very bad bug

Link to post
  • Level 5

On my Mac it works, old and new pictures alike. Right click, and on top of the menu list are the „annotate“ and the „annotate copy“ options.

One thought: Do you have the Skitch app installed ? The window that opens to annotate the picture shows the same tools that Skitch is using. If not, maybe the issue can be solved by installing.

Link to post
  • 11 months later...

I am using 7.14 and it still exists. It has existed for YEARS and still gives me problems.

I am sure it will exist in version 234922.344432 because they never fix ANYTHING with this app.

I have random notes all the time where you can no longer right-click and "annotate this image" anymore.
It won't show up in the menu.

But then I can start a new note or go to another note and it works just fine.

Link to post
  • Level 5

They will not fix anything in 7.14 any more. Not a single bit.

You can still use it, you can still get fresh ulcers over old bugs, but it is practically frozen.

If you ask support, they will tell you to upgrade to v10. Which you may, or may not do, depending on your use cases and your wish to actively support the further development of that client. Personally I run my work through legacy (7.14), and am testing the waters with a v10 tester installed alongside to it.

With 7.14 you are  practically on your own. 

Link to post

LMFAO...

Maybe they can fix the "check for updates" button which always brings this up...

image.png.552a0a6660a3bedccd8ca46ff8960520.png

I was wondering why the windows version is so much different.

I am almost afraid to try the newest one but I will.

Even my newest macbook that's less than a year old is running the same version.

So I am adding "letting users know there's a new version out there" as a bug.

Link to post

That button set doesn't exist at all in the version of the app I am using.

I have way too many demos going on this week to go switch version  numbers right now.

And now I know why I hate the Windows version so much that I've been using — assuming the Windows is now on version 10 and is a lot different.

After my current deadlines wrap up and I have some breathing room I am going to try out the newest mac version and probably come back here to complain about something new.

Link to post
  • Level 5

That button is on v10.

@Frustrated-with-v10.x.x Assuming you want to do something about your frustration, I a sure you have reported this bug to support already.

Because no, choosing the menu option does not do much. On my Mac v10.8.4 it just enables a zoom-in-tool, that enlarges the picture with each click. Which of course is not annotating. And which can't be reversed, unless I hit <esc>.

Link to post

I'm not sure whether it is relevant, but I sometimes run into similar problems. I'm using Windows, the Legacy App (6.25.1.9091 (309091) Public (CE Build ce-62.6.10954))

I'm having the problem that sometimes clipping / copying / pasting or whatever I did to get a note has not copied the image into the note as an attachment/resource or whatever it is. Instead, it is a hyperlink. I'm not sure under which circumstances this happens, as I usually see it only when I'm offline and some pictures are shown as "broken" in a note I took ages ago.  Sometimes it happened only for a few images. I have no clue whether it was due to the web clipper, copy / paste or drag-and-drop actions to get the image into the note.

You will see in the "Note Resources" that there are fewer images in there than there should be.

Also, the "Open" and "Annotate" right-click menu entries will be missing.

When the image is just a link, not a part of a note, it will be shown just fine as long as you're online. Touch luck when you're offline, want to annotate it, or worse, the image disappeared from the URL that was referenced.

There's AFAIK no easy way to tell in a note whether a particular image is "included" or not.

It would be nice if there was an easy bulk/batch way to find and fix those notes.

 

Edit: Here some info I put into an older thread

Unable to Annotate images copied from the Web - Evernote for Windows Requests (Versions 10.0 and above) - Evernote User Forum

Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...