Jump to content
Alien Glow

Copy / Paste deletes space between domain names

Recommended Posts

When you paste 2 domain names separated by space, Evernote removes the space. Looks like a bug with the hyperlinking function. Regular words work fine.

e.g.

Type this is notepad
domain1.com domain2.com

Now copy it and paste it in Evernote

the text becomes hyperlinks without a space between them

domain1.comdomain2.com

Share this post


Link to post

Hi.  If you paste each domain separately it does not create an issue.  Paste the two together and the second domain actually takes over the link.  It's always better to post bug reports for new versions in the release thread for that version.  Which are you??

https://discussion.evernote.com/topic/112693-evernote-for-windows-611-ga/

https://discussion.evernote.com/topic/112599-evernote-for-windows-611-beta-1/

https://discussion.evernote.com/topic/112298-evernote-for-windows-610-ga/

 

Share this post


Link to post

1. on my case when I post a URL it doesn't include some few part on the beginning.  (look at the screen shot below.. that's how it looks)
when you click it ... you get an error on the browser.. coz it really didn't include those part on the address bar. 

Captureaa.PNG.f8e319de6b9522ea2b280f51c5961115.PNG



2.  I have a bookmark notebook that contains almost 600 bookmark notes...    and when ever I click that notebook it's TOO DAMN LAG it is hard to scroll down.   all alignment inside that notebook were all messed up (not just on that notebook but literally all note that are bookmarked input by evernote clipper extension are all messed up)...   

usually the link and description is right aligned.  (if you look at the image below ... the link and description went below)   

the remarks were also removed from the evernote clipper. 

Capture.PNG.0a707b6090e5368946ff6a09ddb586d1.PNG
 

Share this post


Link to post
On 11/04/2018 at 5:08 AM, keruchan said:

when I post a URL it doesn't include some few part on the beginning.

Hi.  So basically something completely different from the original post.  And you still didn't say what Evernote version you're using...

Share this post


Link to post
3 hours ago, keruchan said:

I'm sorry,  I'm using the latest one 6.11.2.7027

Hmmn.  That version is not the world's favourite update -

You could consider stepping back to a previous stable version,  or hold on for the next GA (6.12 Beta is out already...)

 

 

Share this post


Link to post

Thanks.  I guess I'll go back to 6.9 then.   
I also have the old version of the clipper.  

 

Share this post


Link to post

This issue seems to be still there in 6.13.14. Will this be fixed anytime soon? I was using the old version 6.5 all this while, but now looks like because of the security issue, we'll be forced to upgrade.

 

Share this post


Link to post
On 4/3/2018 at 6:06 PM, Alien Glow said:

When you paste 2 domain names separated by space, Evernote removes the space. Looks like a bug with the hyperlinking function. Regular words work fine.

e.g.

Type this is notepad
domain1.com domain2.com

Now copy it and paste it in Evernote

the text becomes hyperlinks without a space between them

domain1.comdomain2.com

Just tried the new beta Evernote_6.15.1.7690. Guys this issue is still not fixed. If you can't fix the issue, atleast give us the option to disable automatic hyperlinking. This has been asked enough number of times. Please. Pretty please with a cherry on top.

And congrats on the "Brand refresh". "Notice anything different?". Yes we do. The rate at which Evernote is adding features and breaking old ones, soon it will be able to do your laundry, cook your food, mow your lawn and a number of other things, but stop doing what it was originally meant to do, which it did so well, "Note-taking".

Share this post


Link to post
10 hours ago, xanadu said:

Type this is notepad
domain1.com domain2.com

Now copy it and paste it in Evernote

I agree it's still broke.  However if you paste with Shift+Ctrl+V so it comes up initially as plain text,  then add a space between the two so the first URL is autoformated,  and add a space at the end so the second one has the same treatment,  they are at least usable links.  I don't agree however that auto hyperlinking should be disabled - I imagine a fair number of note-takers (besides me) like it available.  As an option... maybe...

Share this post


Link to post
11 hours ago, gazumped said:

I agree it's still broke.  However if you paste with Shift+Ctrl+V so it comes up initially as plain text,  then add a space between the two so the first URL is autoformated,  and add a space at the end so the second one has the same treatment,  they are at least usable links.  I don't agree however that auto hyperlinking should be disabled - I imagine a fair number of note-takers (besides me) like it available.  As an option... maybe...

Thanks gazumped.

I agree, automatic hyperlinking should not be disabled as many users will need this. I just suggested that we should be given an option to disable this, as I feel that may be causing the issue. I don't have an issue with automatic hyperlinking as such, its the space between domain names which Evernote swallows which is the problem. The Ctrl+Shift+V workaround is not an option, as sometimes when you are copying large amount of text, you may not notice the problem, and end up with a broken note.

Take for example below block taken from https://serverfault.com/questions/167575/apache2-multiple-hostnames-redirected-to-one

<VirtualHost *:80>
    ServerName example.com
    ServerAlias foo.example.com bar.example.com others.example.com
    DocumentRoot /www/redirect_folder 
</virtualhost>

 

This is how it appears in Evernote. Check the ServerAlias line.

Ctrl+V
<VirtualHost *:80>
ServerName example.com
DocumentRoot /www/redirect_folder
</virtualhost>
 
Ctrl+Shift+V
<VirtualHost *:80>
    ServerName example.com
    ServerAlias foo.example.combar.example.comothers.example.com
    DocumentRoot /www/redirect_folder
</virtualhost>

 

  • Like 1

Share this post


Link to post

This has been around longer, but I wonder whether it's in any way connected to the bug reported here:

@Marky D. is reporting that pasting over selected text deletes a preceding space that was not selected.

Share this post


Link to post
1 hour ago, xanadu said:
<VirtualHost *:80>
ServerName example.com
DocumentRoot /www/redirect_folder
</virtualhost>

 

I was going to say that in a note you should be able to use Ctrl-K to see the text version of the link,  and copy/ respaste or insert the necessary spaces.  In fact,  trying it out myself it seems they are separate links,  it's just the spacing that's messed up...  but adding a spaces messes up the auto linking.  Which may be a good thing,  or not...

I agree Evernote SHOULD FIX THIS!!  ?

Share this post


Link to post

Thanks for the input folks. I can reproduce this exactly as you all describe and have filed a report with the development team.

  • Like 3

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...