Jump to content

Sync issues. Deleted notebooks remain


Recommended Posts

I don’t know what’s going on with this app. Notes I create on my iPhone never sync to e cloud or my windows 10 desktop. I deleted several notebooks from my desktop, they are deleted from the web portal, but they remain on my iPhone. It’s like the sync is broken or something ?  Anyone else having similar issue?

Link to comment

yes, same story. When I am log in via browser it shows my notes and notebook structure properly. when I log into Apps (both iPad and iPhone) with the SAME CREDENTIALS, the apps show my  old structure I have deleted months ago! And not showing my newest notebooks. I am paying for pro membership, what to do?

Link to comment

Yes - I am having the same issue.  iPhone 11 has stored my old notebook structure. Web and windows 10 are new structure but iPhone 11 has old structure. 
 

interestingly... if I create a new note on iPhone it uploads to the web and windows 10 app but not vice versa. 
 

very frustrating... ! 

Link to comment
  • Administrator

Hi All,

Thanks for reaching out.

Just to clarify, is this the first time you're running the new version/syncing?

The reason I ask is that you may see these types of issues due to the initial first sync taking some time.

Or, are you saying that you've been on the new version for awhile, and the notebook simply won't go away?

  • Like 1
Link to comment

Hi Shane

for me - I was using the new version of Evernote on iOS and it worked with a few minor issues of notes not saving but generally the iOS synced with windows app, it was just a bit buggy.... but now iOS on iPhone is just stuck with old data / notebook structure and won’t sync with new data created on the windows app. And every time I delete the trash on iOS / iPhone it says ‘trash deleted’ but then when I sync again all the trash just appears again! 

Windows and Webb app sync together fine... it’s just the iOS on iPhones 11 that is not syncing  

I don’t know if it is relevant but I deleted quite a lot of data on windows app renamed the notebook structure and emptied trash just before this non-syncing issue started on iOS. 

thanks for your help 

Alex 

Link to comment

Hi Shane,

I am having the same issue - I have been trying to sync for several days now. The web app and the desktop (Windows 10) app are in sync. Everything there works.

Unfortunately, however, the iOS app has my old structure and apps from years ago and will not update. Nothing I can do will update it. I’ve tried sign in/out, going through the logs, but it seems to be an issue with the sync master. Specifically, the logs mention an issue with an indexingtree or something like that. 

 

I am frustrated because I just rejoined Evernote after years of not using the service and was excited to see what’s new. Instead, I find this really, really buggy mess and I am struggling to find the value I am paying for. 

 

I know its not your fault Shane but I hope the development team are aware of the issues and the gravity of the issues. 

Thank you. 

  • Like 1
Link to comment

While it took me a long time to actually find a thread on this topic, I'm glad I finally did.

I am having the same problem as others have mentioned. In my case, the sync took forever (and after multiple tries) on my iPhone and iPad but deleted notebooks continue to show up in the desktop application on my PC. I've deleted the notebooks via the Admin Console and tried syncing many times- but the deleted notebooks (8 in total) continue to show up. There's nothing I can do in the actual application as well- I'm not able to "Leave Notebook" or anything else.

Link to comment

Having similar issues. Web and iOS are correct. Mac desktop is now correct but was not until I removed the app and deleted all files labeled Evernote in the file system.

Now having issue on iPadOS where it’s showing old notebooks and notes that have been deleted and not showing new notes.

Link to comment

It’s been weeks. The only response I got was that they have no idea what’s causing it, but they’re working on it  

Honestly, not sure why I’m being punished by Evernote - there is no progress or communication here. No idea why things are broken. No work arounds. No access to a legacy application either. 
 

I’m regretting purchasing premium for a full year. 

Link to comment
  • Level 5

To solve issues with syncing, bad notes, etc. on iOS (this is the radical solution, all local data will be erased):

  1. Uninstall the app, dump all data when asked
  2. Switch OFF the iOS-device, completely. This will clean out the RAM memory. Wait - switch on again. If it was completely off, it will now reboot, showing the Apple symbol. If it doesn’t appear, you have not switched it completely off ...
  3. Go to iOS settings, Display & Brightness, and turn Autolockscreen to Never. This avoids the app to be send to sleep by iOS later.
  4. Reinstall the app from the App Store.
  5. Log into your account, and when the download starts, let it run actively, in the foreground. Don’t use the iOS-device for anything else. Normally this would not be necessary, but I treat EN v10 with respect to data integrity. It will now download all necessary content (notes titles, previews, metadata). 
  6. Once this is done, reset the autolockscreen to your liking. You can now use EN normally.

This worked for me when I had a corrupted note, blocking things.

Link to comment

Thanks PinkElephant - I tried that but my old delete notes instantly synced. The titles synced but the notes themselves were corrupted or something. 
 

I was really hopeful your approach would work but alas. There is something much bigger wrong with the app it seems. 

Link to comment
  • Level 5

With my corrupted notes it was necessary to make the uninstall on the very device where the corrupted notes were located.

Only then they disappeared via sync from the other devices as well. Before they were as undeletable on my Mac and in the web as on iPhone and iPad. When the corrupted local copy was removed, the syncing stopped. The first version where this worked was iOS v10.0.3, and it is still ok with iOS v10.1.

Link to comment

So, I tried to do what you suggested - and I assumed that the issue was on my desktop. So I tried to install evernote from the website rather than the windows store. When I launched it, it had all my old, corrupted notes. I tried to delete them but they instantly reappear. Impossible to delete.

 

You know the worst part? The web version has now synced with that old view on the desktop. I've lost the hundreds of new notes I had added over the last month. I might actually cry.

 

I'm so sad and angry that I am at a loss for words. Mean while, Evernote support keeps telling me boiler plate "uninstall, reinstall" solutions. I am so, so hurt and frustrated.

  • Sad 1
Link to comment

This is going to sound insane but I think I finally figured out how to fix it.

 

Make a new notebook on your iOS or iPadOS device. It for some reason caused all my recently erased notes (from my previous post) to reappear AND fixed the sync issues! No idea why it works.

  • Thanks 3
Link to comment

You also can’t do the reloading of Evernote without auto lock if your phone is a BYOD and has security feature that you cannot shutoff auto lock. These steps were what tech supper told me a few days ago and they told me another way to send the data they needed. I told them I was not able to leave my phone auto locked because of work and sent them the report and not one word back. 

Link to comment
8 hours ago, TheExalted said:

This is going to sound insane but I think I finally figured out how to fix it.

 

Make a new notebook on your iOS or iPadOS device. It for some reason caused all my recently erased notes (from my previous post) to reappear AND fixed the sync issues! No idea why it works.

Holy cow it works!

Edited by High Voltage
  • Thanks 1
Link to comment
  • 8 months later...
On 11/18/2020 at 6:18 AM, High Voltage said:

Holy cow it works!

I had something similar. I couldn't delete an empty notebook. I had to put a dummy note into it and then the notebook could be deleted.

How dumb is that??

Link to comment

The main issue I had after upgrading from v6 to v10 was that in the iOS app (not showing in the Windows app) the personal account had stale notebook references to every one of the business notebooks. I had to click on each one-by-one and wait for it to timeout before it was deleted. This took a couple of hours yesterday.

Then after that, I still had stacks from the old business account. When I removed the stacks, the contained business notebook references all came back again. So I had to go all through the same procedure again removing one-by-one.

At last I have got rid of these phantoms but now I am still having trouble with deleting a notebook in the iOS app I just created as a test. I get the message that it has been deleted but when the app is re-started it comes back and the notebook name now has "(970981)" appended to it. It never syncs to the Windows or Web apps.

The iOS app is really dragging and is hard to navigate. Sometime when it opens it get stuck on "Just a few moments.. we're setting up your new app." and does not open. I have to kill it and try again.

I think I should find a way to wipe out the local database and re-sync from scratch. I'll try PinkElephant's procedure.

Link to comment
  • Level 5

Which procedure ? 

As I understand it from one of your other posts, you are on Business. I have no experience with it - may work or may cause further havoc.

Problems on a Business Account should be sorted out by the admin, maybe together with support.

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...