Jump to content
  • 2

Pasting raw text removes empty lines???


cacotigon

Idea

I just tried pasting some raw text from Notepad and Evernote inexplicably removed all the blank lines, squashing the entire block...

Steps to reproduce:

  1. Type a line of text, hit enter twice, type a second line of text
  2. Select All Copy
  3. Paste into Evernote (Normal Paste or Paste and Match Style both reproduce the issue)
  4. Evernote removes the blank line between Line One and Line Three.

Current Version: 6.7.5.5825 (305825)

 

This does not occur in v6.4.2.3788 (303788)

notepad_2017-09-29_16-38-45.png

Link to post

10 replies to this idea

Recommended Posts

  • 0
4 hours ago, cacotigon said:

I just tried pasting some raw text from Notepad and Evernote inexplicably removed all the blank lines, squashing the entire block...

Steps to reproduce:

  1. Type a line of text, hit enter twice, type a second line of text
  2. Select All Copy
  3. Paste into Evernote (Normal Paste or Paste and Match Style both reproduce the issue)
  4. Evernote removes the blank line between Line One and Line Three.

Current Version: 6.7.5.5825 (305825)

I believe this is the same issue.
Bad news. For 6.8.1 beta, it's still there. :angry:

Link to post
  • 0
19 hours ago, jefito said:

It's been reported already. Several times.

In that case here's hoping that it gets the attention it needs and gets fixed soon, because right now it basically makes pasting in content from external sources (particularly from IDEs) borderline useless.

Link to post
  • 0

"I don't see this problem in v. 6.13...": 

Oups - I'm running the same version - and I can see the problem. Even when pasting "normal" (formatted) text (i.e. source code from an IDE), blank lines will be removed. Pasting into a code block doesn't help. :-(

Link to post
  • 0

THIS PROBLEM IS STILL HAPPENING AS OF Evernote v6.20.8626 (308626). Doesn't matter whether you Paste (Ctrl-V) or Paste and Match Style (Ctrl-Shift-V) - empty lines are inexplicably getting stripped out before pasting.

 

Repro Video:

 

Every program that I've tested from has this issue (Visual Studio, Linqpad, even Microsoft Wordpad). If I were to take a guess, it would seem like Evernote is struggling to properly parse RTF clipboard data.

 

Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...