Jump to content
GrumpyMonkey

mac Evernote for Mac 5.5 Beta 5

Recommended Posts

1. A new popup in the search bar

- No thank you. I especially don't like the fact that there is only a button to "learn more." Grrr...umpy about this stuff.

2. New notes

- When creating a new note, sometimes the title is deleted when I press enter.

- This has been a problem for some time, but I always thought it was me or my large database. So, I have emptied out my account. There are currently no notes in it. Three notebooks. No tags.

- My theory is that the Evernote app is doing "stuff" in the background and falling behind. I can reliably reproduce the bug every time if I delete a note, create a new one, type in a title, and press enter. It always deletes the title I just typed.

  • Like 1

Share this post


Link to post

Thanks for posting this topic, GM.

I agree with both of your concerns.

  • Like 2

Share this post


Link to post

3. Invisible cursor

- Still happening.

4. Margins wrong

- Text will not show because it seems to be hidden behind a margin of some kind. It happens in a lot of my notes. This is one of the reasons I usually use plain text, but in this particular case, I am sharing it with others, and I need the formatting.

https://www.evernote.com/shard/s74/sh/95f9a82d-8218-465d-b3da-43167365d365/61531eec88b9d2cb946e0d71dbaa9a5e

  • Like 1

Share this post


Link to post

#4: Try simplifying formatting. See if that helps. CMD-Shift-F.

Of course! But, I shouldn't have to format, un-format, and re-format the entire note, should I? Just saying...

Share this post


Link to post

Are you pasting things in from external sources? If you have a note that exhibits that behavior, send me an ENEX. I'd love to have a look.

Share this post


Link to post

Are you pasting things in from external sources? If you have a note that exhibits that behavior, send me an ENEX. I'd love to have a look.

I was going to write and say the content was not pasted, but it is possible that the top section was copy/pasted from an html version of a text file (markdown) that had the data. Or, it could be copied from a Word file. I don't remember... The rest of the note all the way down to the sample bit of messed up text was all created in Evernote, as far as I recall. On my Mac, this note also has the ability to hide my cursor from me.

https://www.evernote.com/shard/s74/sh/95f9a82d-8218-465d-b3da-43167365d365/61531eec88b9d2cb946e0d71dbaa9a5e

Share this post


Link to post

Yep, there's some funky HTML in there from someplace else: "text-indent: -9pt"

Share this post


Link to post

Yep, there's some funky HTML in there from someplace else: "text-indent: -9pt"

Great... I've got that in over one hundred shared notes then! Ugh. I'll try and track down the culprit. I'm think it is Word, but I'll have to rummage around for it. Ideally, I'd be able to simplify the formatting in one section instead of having to change everything in a note. That would at least enable me to fix the part where I need to make edits. Ideally+infiniti we'd have markdown support and I wouldn't be pasting into Evernote in the first place :)

You're off the hook for this one! But, not for the invisible cursor, because that guy is hiding all over the place.

Share this post


Link to post

 

Yep, there's some funky HTML in there from someplace else: "text-indent: -9pt"

Great... I've got that in over one hundred shared notes then! Ugh. I'll try and track down the culprit. I'm think it is Word, but I'll have to rummage around for it.

 

 

GM, if you haven't already, you might find it enlightening to export a Word file to HTML.  It's awful -- huge HTML bloat and some of the worst HTML I've seen.

Share this post


Link to post

Yep, there's some funky HTML in there from someplace else: "text-indent: -9pt"

Great... I've got that in over one hundred shared notes then! Ugh. I'll try and track down the culprit. I'm think it is Word, but I'll have to rummage around for it.

 

GM, if you haven't already, you might find it enlightening to export a Word file to HTML.  It's awful -- huge HTML bloat and some of the worst HTML I've seen.

I've done that in the past, when I thought it might be handy to make a web page in Word and export it (it is not handy at all). I think this is where those advanced capabilities (rulers, show invisibles, etc.) come in handy, because now the notes are just a mess, and short of a bulk search and replace, I don't see a quick way to solve the problem. Again, this time it's cool, and I'll work around it, but from a user's perspective, getting trapped by stuff you cannot see isn't fun; hence, my affinity for plain text solutions.

This isn't Evernote's problem, as Jack has shown, but I think it would be nice if Evernote had a solution (such as simplified formatting for selected text). I could imagine a function that would stick in some <div>s, clear the formatting, and allow this to work within a note while not destroying all of the other formatting, but I am not sure how formatting below the selected text would be retained, so maybe my request is difficult or impossible to fulfill.

Share this post


Link to post

AppleScripting 'create note' and 'assign tag' no longer works

 

'assign tag' now responds with "Expected end of line but found identifier", highlighting 'tag'.

'unassign tag' does the same thing.

 

'create note' now responds with "Expected end of line but found application constant or consideration" with the highlight on the 'note' keyword.

 

Not being able to use these commands in AppleScript is a complete show-stopper, and I've had to switch to another client until this is fixed.

 

 

 

  • Like 1

Share this post


Link to post

AppleScripting 'create note' and 'assign tag' no longer works

 

'assign tag' now responds with "Expected end of line but found identifier", highlighting 'tag'.

'unassign tag' does the same thing.

 

'create note' now responds with "Expected end of line but found application constant or consideration" with the highlight on the 'note' keyword.

 

Not being able to use these commands in AppleScript is a complete show-stopper, and I've had to switch to another client until this is fixed.

 

Evernote Team:  Please fix this ASAP.  Since EN Mac does NOT have a native import file function, many of us rely on Applescript to do imports.

 

Thanks.

Share this post


Link to post

 

AppleScripting 'create note' and 'assign tag' no longer works

 

'assign tag' now responds with "Expected end of line but found identifier", highlighting 'tag'.

'unassign tag' does the same thing.

 

'create note' now responds with "Expected end of line but found application constant or consideration" with the highlight on the 'note' keyword.

 

Not being able to use these commands in AppleScript is a complete show-stopper, and I've had to switch to another client until this is fixed.

 

Evernote Team:  Please fix this ASAP.  Since EN Mac does NOT have a native import file function, many of us rely on Applescript to do imports.

 

Thanks.

 

 

Hmm.

I'll have to check that.  I thought I dropped something in my watched folder after the update and it loaded fine.

Might have been before the update.

 

Are you using a workflow or folder action or something else?

Share this post


Link to post

5. Processing...

Lots and lots of processing. I've mentioned this before, but it just drags down the entire app. Frankly, I have no idea why it is happening. What is there to re-index? The only changes I made today were: three notebooks deleted (only one note in there) and a copy/paste of text into one note.

Version: Evernote Mac 5.5 Beta 5 (402453)

OS: 10.9.1

WebKit: 537.73.11

WebCore: 537.73.13

Mac Model: MacBookAir6,1

CPU Type: Intel

CPU Count: 4

CPU Speed: 1.300000 GHz

RAM: 4.000000 GB

Date: 2014-01-27 18:28:00 +0000

2014-01-27 12:27:48 [ENNoteReIndexOperation] INFO: Reindexing note: 'Tue, Apr 1: The Origins of the Event and its Legend' [3b2aa820-eb13-4920-a853-1f0ff8a0f65b]

2014-01-27 12:27:48 [ENNoteReIndexOperation] INFO: Reindexing note: 'morris-suzuki tessa 2013 east asia beyond history wars remembering unfinished conflict' [76ddbdb7-19a7-490f-a93c-ba079d6eba15]

2014-01-27 12:27:48 [ENLuceneNoteIndex] DEBUG: Indexing PDF 'morris-suzuki tessa 2013 east asia beyond history wars remembering unfinished conflict.pdf' [67be9f84-d327-4efa-b16d-f2031a8767a2]

2014-01-27 12:27:49 [ENNoteReIndexOperation] INFO: Reindexing note: 'mclaughlin levi 2011 tokyo governor fukushima' [4d8c0834-9669-4d09-bcba-52bd041453a0]

Share this post


Link to post

When notebooks get deleted, there are cascading implications on notes and tags. Same thing for when you delete a tag. Both of those things could have long processing implications.

  • Like 1

Share this post


Link to post

AppleScripting 'create note' and 'assign tag' no longer works

 

'assign tag' now responds with "Expected end of line but found identifier", highlighting 'tag'.

'unassign tag' does the same thing.

 

'create note' now responds with "Expected end of line but found application constant or consideration" with the highlight on the 'note' keyword.

 

Not being able to use these commands in AppleScript is a complete show-stopper, and I've had to switch to another client until this is fixed.

 

I fixed my own problem: changed tell application "Evernote"  to tell application id "com.evernote.Evernote" and it now works fine. AppleScript is confusing "Evernote" with "EvernoteHelper", so you must be more specific as to which application you are scripting.

Share this post


Link to post

When notebooks get deleted, there are cascading implications on notes and tags. Same thing for when you delete a tag. Both of those things could have long processing implications.

Grumble, grumble. Well, yes, I gathered that much. But, that is the problem, because when you have tens of thousands of notes, a few minor changes (like to a tag name) can cause considerable trouble. Is there no way to deal with this in a more efficient manner? For example, none of the notebooks had any tags. The note inside the three notebooks (two of them empty) had no connection to the other notes. I don't know why all of the PDFs in my account (apparently) need to be re-indexed for it. Anyhow, the long and short of it is that this is one of the things that makes it difficult to use Evernote with large databases.

Share this post


Link to post

 

AppleScripting 'create note' and 'assign tag' no longer works

 

'assign tag' now responds with "Expected end of line but found identifier", highlighting 'tag'.

'unassign tag' does the same thing.

 

'create note' now responds with "Expected end of line but found application constant or consideration" with the highlight on the 'note' keyword.

 

Not being able to use these commands in AppleScript is a complete show-stopper, and I've had to switch to another client until this is fixed.

 

I fixed my own problem: changed tell application "Evernote"  to tell application id "com.evernote.Evernote" and it now works fine. AppleScript is confusing "Evernote" with "EvernoteHelper", so you must be more specific as to which application you are scripting.

 

 

 

Thanks for sharing your solution.

 

Jack, why would this change with the Beta?

  • Like 1

Share this post


Link to post

The reason for the change is that we didn't want "Evernote Helper" asking for permission to users' locations (we wanted the request to come from "Evernote"). We tried to change the display name of EvernoteHelper and ended up changing the bundle name. Good catch. We'll fix it.

  • Like 2

Share this post


Link to post

Version 5.5 Beta 5 (01/24/2014) build 402453

Various bug and stability improvements:

 I'm still on Beta 4. Got a link for 5? 

Share this post


Link to post

Version 5.5 Beta 5 (01/24/2014) build 402453

Various bug and stability improvements:

 I'm still on Beta 4. Got a link for 5?

Evernote -> Check for Updates ought to do it.

Share this post


Link to post

The reason for the change is that we didn't want "Evernote Helper" asking for permission to users' locations (we wanted the request to come from "Evernote"). We tried to change the display name of EvernoteHelper and ended up changing the bundle name. Good catch. We'll fix it.

 

Hopefully you will also fix this bug which is going on for ages:

 

http://astralbodies.net/blog/2013/12/27/scansnap-on-mac-not-opening-evernote-properly/

Share this post


Link to post

3. Invisible cursor

- Still happening.

 

This happened to me for the first time with beta 5. Maybe a Mavericks / dual monitor thing?

Share this post


Link to post

3. Invisible cursor

- Still happening.

 

This happened to me for the first time with beta 5. Maybe a Mavericks / dual monitor thing?

Not a dual monitor thing. I only have one. As for Mavericks, I'd have to look back through my notes (no time right now), but I think this has been happening since the summer or so.

[Edit:] Maybe Mavericks. I seem to have started encountering this in October...

Share this post


Link to post

×
×
  • Create New...