Jump to content
QTI

mac (Archived) Search function not working properly

Recommended Posts

I have Evernote on a Mac Pro and a Macbook Pro.

I created a note on the Mac Pro, which was then sync'ed to the Macbook Pro.

When I search for the words say "full ratchet", the relevant note will show up on Mac Pro. However, doing the same search on Macbook Pro, Evernote will not be able to find the note even though I can manually select and see the note there.

I have no problem searching and locating the note with the same word search on Evernote on the web.

Any idea why this may be happening and how to fix this?

Many thanks in advance.

QTI

Share this post


Link to post

I'm having some problems with searching, too.

I have three notes tagged "eBook." When I type "tag:eBook" into the search box (with all notebooks selected), only one note shows. The same query on the web version or on the iPhone returns all three notes.

If I look at the list of tags, it says "eBook (3)" but selecting it only shows the same note as when I type the query into the search box.

I'm not sure if this has been happening with other searches - it was just particularly obvious in this case because there were so few results.

I'm using Version 2.2 Beta 2 (149798)

Share this post


Link to post

I had the same (or a very similar) issue. I'm running Version 2.1.1 (146398) on my MacBook Pro. I also have the iPad and iPhone apps.

One of my notes was tagged with multiple common tags. On the Mac those tags include said note in their total of matching notes (i.e. in the parentheses next to the tag names in the tag column they report X number of matching notes). However when I filtered by any of those tags, that particular note never showed up (and the search results bar at the top of the screen shows X-1 results found, clearly different from the tags reported number).

I had no problem whatsoever finding said note via tag search on the iPad or iPhone or web app. Only the Mac app seemed to have the problem.

I eventually fixed the issue by syncing from the Mac, adding another random tag to said note from the Mac, then syncing again. After that the note showed up for any of the tags (and I was able to delete the random tag I'd added with no problems). Not sure if the issue was caused by a version upgrade or other such issue, but I was at least able to find a workaround. Quickest way to check if you have a similar issue is click to filter by a tag (in the column) and then compare the column's reported number of notes to the search results reported number of notes and see if there's a difference.

Share this post


Link to post

Today I entered a search on my iPhone that brought up two results. Since one of them was a long file, I waited until I was at my computer to look at it. On the Mac, the same search only found one result (the shorter one). When I dug out the other note and searched within it, I found three instances of the word I'd been searching for originally.

Share this post


Link to post

I'm still having this problem, even with v2.2.1.

It's very annoying to not be able to trust the search results in EN.

Share this post


Link to post

Same problem here on my Mac, I cannot trust search results. I use tags to implement my GTD system, e.g. the tag "ph" to indicate "priority high". But sometimes not all notes having this tag will be shown when searching for it. This is obviously scary, since it may mean that I forget handling high priority tasks! :?

I herewith explicitly dedicate my premium fee towards fixing this problem... :)

Share this post


Link to post

Hardly an ideal solution, but I had this same issue and resolved it (temporarily at least) by rebuilding my Evernote index.

- Quit Evernote

- Go to your personal mac home folder

- Go to Library > Application Support

- Grab the Evernote folder and move it to the desktop

- Launch Evernote and wait a good while for the index download/rebuild

Share this post


Link to post

I'm running Evernote 2.2.2 Beta 1 and Using Lion DP4 Update 1.

Phrase search appears to be treating all words in the phrase as if they are not surrounded by quotes. i.e. if I search for "Hello World" (with the quotes) the words Hello and World are highlighted even when they don't appear next to each other.

Share this post


Link to post
Hardly an ideal solution, but I had this same issue and resolved it (temporarily at least) by rebuilding my Evernote index.

- Quit Evernote

- Go to your personal mac home folder

- Go to Library > Application Support

- Grab the Evernote folder and move it to the desktop

- Launch Evernote and wait a good while for the index download/rebuild

This is much more than just rebuilding database indexes.

This is re-downloading your entire Evernote database.

Share this post


Link to post
Guest
This topic is now closed to further replies.

×
×
  • Create New...