Jump to content
  • 0

Encrypted note corrupt



I have an encrypted note in Evernote.  When I tried to read it yesterday  (version 5.6.1 on my Mac), I entered the password and the hidden text became visible.  When I then clicked on the text it simply disappeared. 


At that point I set Sync to manual to prevent it saving any changes and tried re-opening the note (many times!) - it seemed though to have lost all my encrypted text.


Looking at this note now on a PC (version I can decrypt it and see the text properly.  I've just synced it again from the PC, hoping that this might de-corrupt it. 


Looking now at the web version of Evernote:

(a) in the old version, I can put in the password and view the text.   When I click anywhere to edit the text, it disappears.

(b ) in the web beta version (both FireFox and IE), it never asks for a password - there is no way to see the text  The padlock strip just seems to be an image.  When I click on it I get get a fonts etc tool strip.


Fortunately I've now managed to backup the note content - but I find it very worrying that a note can just lose its contents like this.  I'm thinking as there were problems with the Mac version and both web versions that the note is probably corrupt in a way that affects web and Mac versions but not the Windows Evernote.   Eeek!


How can I avoid this happening again?



Link to comment

9 replies to this idea

Recommended Posts

  • Level 5*

Well - discount the web beta;  it's not fully featured yet so might be lacking something essential to making encryption work.  You're saying this feature works on your Windows PC,  but not on the Mac or on the old web version.  So it doesn't sound as if it's a problem with the note itself - it at least works with one client.  However the way to check this is -

  1. Exit Evernote on the Windows client.
  2. Backup your database as is. 
  3. Export that note contents to an ENEX file
  4. Restart Evernote.
  5. Delete the original note completely.  Sync.
  6. Sync the Mac and make sure the note is gone.
  7. Back to Windows and re-import the ENEX version and sync again.
  8. Sync the Mac and check the encryption.

Exporting and re-importing should ensure that the note contents are free of any errors.


If encryption is still misbehaving on the Mac,  you could try uninstalling and reinstalling the latest version.


..and on the web version - clear your browser cache and restart the browser to recheck.


Since we don't really know where the problem lies here,  it's difficult to suggest a guaranteed alternative to encryption,  but if you have another way to encrypt contents - like 'printing' to an encrypted PDF requiring a password to open the file - you might like to try that out just in case...

Link to comment

I am having the same issue with encrypted text disappearing when I click on it on my macBook. I had just upgraded Evernote when I noticed it, and then stopped using it on my laptop because of that (and how quickly it synce'd).


I then saw a new version for the mac OS just last week (around the 6th of Nov), so installed that, but the same thing happens. I can't use Evernote on my laptop because of this (I have not switched to the beta web version and this is one of the rare times I even log in online).

Link to comment

Did this solution work for anyone?  I'm having the same issue with encrypted notes contents showing up as blank.  I can view the content on my PC version but not my Mac version.


Any other suggestion?  I've reinstalled the latest version of EN on my mac and still same issue.  I even deleted the note and created a new one but still have the same issue.  

Link to comment
  • Level 5*

This certainly seems to qualify as a bug - I can only recommend raising a support request (see below),  choosing the 'bug report' option from the dropdown.  This won't necessarily get you an individual response,  but it will show Evernote there's a problem here that needs attention.

Link to comment


This topic is now archived and is closed to further replies.

  • Create New...