Jump to content

(Archived) Feature Request: Make it easier to delete attachments

Recommended Posts

Please make it easier to delete attachments from Evernote notes. It's annoying to manually drag the cursor just to highlight the attachment in order to delete it. I suggest that the attachment should be highlighted when it's clicked on so I can delete it that way instead.

Please consider this feature, and thanks for taking the time read this suggestion.

Link to comment
  • Level 5*

If you have a question about a specific client, then it's better to ask it in the forum for that client. In the Windows client, you can right-click on an attachment, and select Cut to delete it.

Link to comment
  • 1 year later...

If you have a question about a specific client, then it's better to ask it in the forum for that client. In the Windows client, you can right-click on an attachment, and select Cut to delete it.

That strategy does not work in Evernote for Mac. Any suggestions for how to delete attachments on a Mac?

Link to comment

If you make an attachment highlight on click, you can't make it be a link on click any more.

I guess the only way around this would be to have a menu popup on highlight to ask you if you want to go to the link or delete the attachment. But that would be silly.

I only see the "set cursor behind attachment, then hit delete key" option that Bankrobber mentioned.

Link to comment

The attachment I want to delete is inside a table inside a note. So far, none of the suggested actions has worked. I submitted a request for tech support. If/when I hear from them, I will update my progress. Thank you for all attempts to help!

Link to comment

The cursor does move to the left of the 16 page attachment. However, neither "delete" nor "command + X" effect any change. I've tried this on both the app and the web version. Are you guys saying you are able to delete attachments in Evernote for Mac?

Link to comment

lschmam: have you tried deleting the whole table, then reinserting the attachment into a brand new cell of a brand new table in a brand new note?

Maybe there was a a hiccup when you inserted that attachment.

This reminds me of a 'mini bug' I've discovered in the Mac desktop client: when you have an image and you make it into a link, sometimes when it is set right after another element on the note, it won't bring up the 'add link' dialog. What I learned I have to do is move the cursor in front of the image, hit return to make a regular line break and move the image to a new line. Then the 'add link' dialog appears just fine and I can turn it into a link. Then, I move the cursor in front of the image and delete the line break to move it back to where it was.

In your case, maybe what it could also be is maybe also some kind of bug involving something related to line breaks or empty spaces.

Like for example you could try this with the existing attachment in the current table: move the cursor in front of it, hit return to move the attachment to a new line, then use the arrow key to move the cursor behind the attachment, then hit delete.

Link to comment
  • 3 weeks later...

Environment: Enote Build 268178 on Windows 7 Pro i7 w/8Gb RAM

The attachment, once added, is invisible. It's invisible in the Web client using Chrome as a browser. The only ways to know it's there is by the size of the note and filtering by attributes. Based on this thread, I had an idea of what to look for. On the first couple notes, there was a space or other invisible character at the end of the note. Using the Windows client, open the note in a new window and delete the invisible/space character at the end of the note.

But in at least two notes, the invisible character/space was at the end of a paragraph. So I had to go to every EOL checking for invisible characters/spaces in most cases it's a space.

I suppose I could export the note to an HTML file and then examine the source, but puleeze that can't be the intended solution.

And why won't PDF attachments show up when using the "attachment" attribute? They only show up using the PDF attribute. That's counter-intuitive to me. YMMV.

Link to comment


This topic is now archived and is closed to further replies.

This topic is now closed to further replies.
  • Create New...