Jump to content
mlans

firefox (Archived) Clipper not capturing embedded images

Recommended Posts

Windows 7 Home Premium 64-bit

Firefox 17.0

Evernote Web Clipper 5.4

Evernote 4.5.10.7472 (267980) Public

When clipping, using either the selected text or clipping the entire page, embedded images do not get captured in a note. It also seems a bit inconsistant: some pages/selections clip fine, others don't.

I have seen similar items posted here, but they are either old and do not have replies or the configuration doesn't match (Chrome instead of Firefox, etc.)

Known bug or installation issue? Need any additional info?

  • Like 1

Share this post


Link to post

Same thing happens to me. Here's an example where I selected the image and asked it to clip the selection:

http://24.media.tumb...2o1_r1_1280.jpg

It claims that the image was captured. If I switch to thumbnail view, I can even see a thumbnail of the image. The note says it's 99.1kb. However, I cannot get the actual image to appear in the note.

I have the exact same specs as mlans.

UPDATE: Hmm, if I select the image in the above link and ask it to clip the selection, the image won't show up in the note. However, if I clip the whole article without selecting the image, it DOES show up in the note.

It WOULD be nice if were consistent.

Share this post


Link to post

Similar/Same problem.

When I clip full page

http://lcamtuf.coredump.cx/electronics/

the note does not display the embedded images. It does save the images and lets me view them with the Image Gallery button, but that does no good since there is no indication where in the text each image should go.

Win7 Home Premium 64

Firefox 17.0

Webclipper 5.4

Webclient version of evernote

Share this post


Link to post

Just not consistant at all... Most times getting NO images, sometimes getting SOME.

I can tell you that by installing Skitch, nothing changed.

A sample URL would be http://lifehacker.co...ff-this-weekend

I selected the top image and the body of the article through the line "Have a happy sun-filled weekend (even if it's winter time)!" and pressed the Evernote button on the toolbar

When doing so, the note that got captured had the top image http://img.gawkerass...pg/original.jpg but did not have the two smaller images in the article http://img.gawkerass...qjpg/medium.jpg and http://img.gawkerass...mjpg/medium.jpg

Now, I have no idea if this would help or not, but the page source for the image that did get copied is:

<div class="Add Solar Power to All Your Stuff This Weekend"> <img src="http://img.gawkerass...jpg"width="360" title="Add Solar Power to All Your Stuff This Weekend" class="http://img.gawkerass...jpg/medium.jpg" width="image_0 v10_medium" alt="Add Solar Power to All Your Stuff This Weekend" />

The images that didn't get copied into the note are:

<img src="http://img.gawkerass...jpg/medium.jpg" width="image_1 right v10_medium" alt="Add Solar Power to All Your Stuff This Weekend" />

and

<img src="http://img.gawkerass...jpg/medium.jpg" width="image_2 right v10_medium" alt="Add Solar Power to All Your Stuff This Weekend" />

Share this post


Link to post

Same issue here, article or full page clips. No images are showing in the note, oddly though, the image shows in the note thumbnail.

Also, I'd like to point out the differences between the clipper in Firefox and the one in Safari. The latter is much better and allows you to pick the notebook and tags before saving. I hope this will be updated in the Firefox version soon!

Evernote 5.0.1

Evernote Web Clipper for Firefox 5.4

Firefox for Mac 17

Share this post


Link to post

Oo0Bailey0oO:

Check Tools -> Clipping Preferences and the box labeled Do not show "New Clip" dialog should be unchecked to give you that dialog box that allows you to pick the notebook and tags.

Share this post


Link to post

I am on an iMac using Mountain Lion 10.8.2.

I have Evernote for Mac 5.02.

I have Evernote Web Clipper 5.4

I have Firefox 17.0.1

I have found when I clip something the first time on most web pages, the clipping itself only shows the text, no pictures. This will happen with any type of clipping: whole web page, article, or highlighted text. It shows up as an open note when Evernote opens.

When I close the note and look at it in the Mac Evernote app, there is nothing in the note. There is only a note title and a url, the note body disappears.

Doing a sync does not change this.

If I then delete the note and immediately clip again (exactly the same thing) I will get all the data and the note is fine.

I generally close Evernote between clippings, so it could be this oddity only happens the first time I do a web clipping and would not happen on subsequent clips if I kept the application open. I don't know because I run into other problems with my desktop if I have too many things open so I haven't tried it.

This has been going on for several weeks. I thought the update to Evernote and/or Firefox today would fix it, but it just happened again so I thought I would post it here. Mildly annoying but not the end of the world.

Share this post


Link to post

Hi

When will this problem be fixed????

So inconsistent this used to work perfectly come on Evernote sort it out I always dread updating because I know something will go wrong or be incompatable.

GREAT PROGRAM BUT REALLY FRUSTRATING !!!!!

Share this post


Link to post

Oo0Bailey0oO:

Check Tools -> Clipping Preferences and the box labeled Do not show "New Clip" dialog should be unchecked to give you that dialog box that allows you to pick the notebook and tags.

Thanks. I don't see where Tools is located though. The clipper add-on preferences don't show anything related to New Clip dialog. Just "send clips to", "default action", "article selection", and "simul. search".

Share this post


Link to post

Hi

Same, very annoying, problem here. FF 18.0, Clipper 5.4.

When clipping this page, the thumpnail preview shows (ironically) a very fine picture of

jbignert

but the note itself contains no graphics/pictures.

When clipping via Chrome (23.0.1271.95, Clipper 5.9.3) the page is captured perfectly...

Any kind of indication as to wether this is a know bug and/or when it'll be solved??

Rgds

Kenneth

Share this post


Link to post

Seems to be working now :)

If Evernote team fixed it thanks :)

Gives me faith a great bit of software :)

Now back to work :huh:

Share this post


Link to post

Am I expecting too much from the Firefox version of Clipper? It captures graphics perfectly in IE. However, I get nothing but text and text links in FF, with a bunch of thumbnails at the bottom of the page... with every clip...making this extension just about useless to me. Does this work for anyone?

FF: 17.0.1

Clipper: 5.4

Share this post


Link to post

Hello, I have the same problem. In the thumbnails I can see the images, and the note information says that I have (i.e) 2 images, but I cannot see them, though I can download them. How have you solved the problem? If it has no solution, I'd like to remove the images attached and not visibles. Could you help me to remove them, please?

Thanks.

Share this post


Link to post

Hi all, we're aware of these issues and are working on fixing them. This problem was introduced with Firefox 17. I will post an updated version back here as soon as the fix is stable.

Share this post


Link to post

So... in the meantime...jbignert no ETA on how quickly this can get resolved? It's a bad time of year for bugs 'n' fixes (holidays and all)... so, should we see something in 2012... or wait until sometime next year in 2013?

Let me throw a monkey wrench into this as well.... I have this issue with Firefox 17.0.1 .... my work-around is to use IE <shudder> ... but now, THAT occasionally fails (occassionally works, too), so I can't come up with consistantcy between what I'm attempting to clip. It's now just "let's see what we get THIS time".... a bit frustrating. Hope you understnd the frustration.

Share this post


Link to post

I have the same issue.

I think the solution that's worked for me so far is to go into the options and un tick "preserve style".

Unfortunately evernotes basic style is very ugly.

I'd love to see Evernotes bookmark option work much more like "pocket", unfortunately pocket is very much just for reading articles later, not also for bookmarking them permanently.

Share this post


Link to post

unfortunately pocket is very much just for reading articles later, not also for bookmarking them permanently.

I use pocket exactly like that: a portable journal that I can add to and edit over time. There's no limit to how many articles I can clip, they don't get auto archived or auto deleted and I can tag articles to group them and/or find them again later. I also find that Pocket is usually quite good at preserving formatting, including pictures. Critical articles I convert to PDF.

Share this post


Link to post

Same issue upon first use for me! I am trying to clip an e-mail with embedded images - in Evernote al images show up like tiny blue squares with white question marks.

To be honest this is a show stopper for me; any indication when the defect will be fixed?

Share this post


Link to post

In general Web Clipper is not supporting email clients today. It's a complex environment to clip from but we are working on improving that.

Share this post


Link to post

- Get the image element

- Create a canvas element

- Get a context from it

- Draw the image to the canvas context

- Call canvas.toDataURL() on the canvas

- Send the DataURI (like data:image/png;<lots of base64 data>) to your servers

- Decode it

- Shove it in S3 or wherever you do these things.

 

Something like:

$(document).ready(function(){   var canvas = document.createElement('canvas');   var ctx = can.getContext('2d');    var img = $('#image_id')   canvas.width = img.width;    canvas.height = img.height;   ctx.drawImage(img, 0, 0, img.width, img.height);   var canvasData = canvas.toDataURL("image/png"); }

Then post the canvasData to your servers.

Not sure about the restrictions on stuff the browser does to your extensions though.

Share this post


Link to post
Guest
This topic is now closed to further replies.

×
×
  • Create New...