Jump to content

Insert table irretrievably overwrites selected text


Recommended Posts

I have just tried to move some text in a (very important) note in to a table. So I selected the text and then clicked on insert table, expecting it to behave like Word, LibreOffice etc would. It didn't. It just overwrote it. To make matter worse, for reasons I don't understand, I couldn't restore the text by ctrl-z. This is very bad.

Fortunately I have a premium subscription so was able to restore the note from an old version, so no harm done. But please make this feature a bit less nasty. (If it deleted the text it's a feature. If it deletes it irretrievably then it's a bug IMHO)

Link to post
  • Level 5*

I'll go with your definitions here - I haven't attempted to insert any large tables lately,  but I would be... disconcerted...  loudly...  if a block of text were a casualty.  Seems to me though that it's also standard Windows behaviour that if you select a block of text and then do - something - like hit the space bar,  or the Tables key,  the text will be deleted.  If I'm copying text into a table,  I tend to create the table first,  then move (or copy) the text.  Thanks for the reminder though that bad things can happen,,,

Link to post

@TimGreeningJackson

Have you tried just pressing CTRL+Z a whole bunch of times? I started a thread and support ticket about undoing things with tables taking a dozen or so attempts.

I got the standard "We're aware of the issue and maybe we'll fix it in the future, but we don't offer timelines." Given that these issues are many years old, I'd say they're like to endure.

If you use a lot of tables, use MS Excel or Google Docs or something like that.

Link to post

Yes. Of course I did. Probably a couple of dozen times. With mounting disbelief and horror. But it didn't work.

I subsequently tried reproducing the problem (with some unimportant data) but couldn't. However, I assure you that when I discovered the problem the text was most definitely lost and that Ctrl-Z didn't work.

I had hoped to be able to keep all such data in one place. But I think that in this particular case, given its importance, Google Docs may be the way forward. Which is disappointing as it rather defeats the point of using Evernote.

Link to post

That sucks.

When I filed a support ticket with Evernote, they told me that they're aware of a "greater issue" with tables and that they might fix it one day. 

I hope they actually do fix it and that "one day" comes soon!

Until then, I'd stick with my suggestion: If you need a lot of tables, migrate away from Evernote.

Does any Evernote employee have a different suggestion?

Link to post
  • Level 5*

Anybody mention the Evernote/ Google Drive integration here yet?  Doesn't show the content of a GDoc document as a note attachment,  but it makes it more convenient to edit one containing a table..  just sayin.

Link to post
  • 2 weeks later...

I wonder if this is related: In the cell of a table, when I highlight the text and "cut" it and then "paste" it, the text in the cell to the right is cut, and joins the pasted text. Might this be one of the "greater issues" that are being worked on?

Link to post

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...