Jump to content

Crash when running in Yosemite


Recommended Posts

Got the Yosemite beta today and launched Skitch to get a screencap of something I was working on and it crashes.


When I select re-launch it comes up with a blank canvas but every time I try to take a new capture it crashes.


Anyone else running Yosemite that is running well?



Link to comment

Same problem on my MacBook Air running Yosemite.

I would expect that there should already be a Beta of the next Skitch somewhere around.

Skitch is an essential app for me, so hope this is getting sorted out soon.



I downloaded some older versions of Skitch.

The one I found working is 1.0.9


The 2.0.2 does work as well but doesn't display portrait screenshots or photos properly.

Landscape is however working fine.

Link to comment

Jeez yes. Never install a beta as your only OS. Use a separate partition or a different device. Years of testing these sorts of things has shown me all the ways things can go catastrophically wrong... thankfully I never had a problem because I always tested with care! 


It is very normal for software to not immediately support a beta OS. I'm sure they'll have something ready as Yosemite launch approaches in the fall. 

Link to comment
  • 2 weeks later...

In the meantime, if you're using Skitch to mark-up an image specifically for emailing, you may not be aware that Mail.app (in Yosemite only) now has mark-up features built-in.


After dragging an image into an email message, an arrow button will appear, superimposed over the dragged-in image, at the upper-right. Clicking that button reveals the mark-up tools. After completing the mark-up, you can control-click to save the modified image, without having to actually email it. (Dragging it to the desktop doesn't seem to work, yet — although it should.)

Link to comment
  • 2 weeks later...

Yesterday I installed the Yosemite public-beta update, and today — on a whim — I launched Skitch and discovered, to my surprise, that it worked. I was able to successfully annotate and export an image.


It seems, anecdotally, that Apple may have fixed the problem. But of course, YMMV.   :)

Link to comment
  • 2 months later...

Skitch *was* working for me in Yosemite (not the beta), and everything has been going well. Suddenly, however, it has stopped working. It launches, but when I try and do a crosshair snapshot, it crashes out. Now I can't get it to do anything. I've tried restarts etc but nothing working.  Any ideas, folks?



Link to comment


This topic is now archived and is closed to further replies.

  • Create New...