Jump to content

Some snippets don's show any text

Recommended Posts

I just changed from an iPhone to an Android phone, and I'm getting to know the EN app for Android. I have version 4.1.3, which must be the latest since I downloaded it from the Play Store yesterday.

I have selected snippet view, but many of my snippets are empty except for the date. If I choose an empty snippet, view that note, and then return to look at its snippet, the snippet text appears.

It's been a day, and no further snippet data appears to be filling in automatically. I could view each note in turn to fill in the missing snippet data, but I have a lot of notes and there are probably a couple thousand empty snippets.

Any ideas on how I can get the rest of my snippet data to download?

Link to comment
  • Level 5*

I think we've had similar issues before - is your database a large one? Have you set your main notebook for 'offline searches'? Downloading a database is a s-l-o-w process at best, and it seems like you're jumping the queue on some notes by opening them individually, so their content downloads in full. The information then exists in cache for the snippets to be created.

Best suggestion for the present - leave your phone syncing via wi-fi for as long a period as you can, then see whether any more details has been downloaded. You should have a full snippets file after a while, but be patient.

You could try setting the notebook to offline storage, which will download all the notes to the phone and do what you were doing with individual notes in one go. That's going to take a similarly l-o-n-g time to complete.

Link to comment

Thanks Gazumped.

The size of my database is about 1.2 GB, spread over about 6,000 notes. I don't know... is that large?

I don't want to do the offline storage, because I don't need it. I'm happy to download the notes I need on an as-needed basis. I'd just like to be able to see a snippet of each note's contents when scrolling through the snippets. :-)

It seemed as though the snippets that have content in them filled in within just a few minutes (or maybe an hour; I wasn't paying close attention), and nothing has happened since then. But I'm not 100% sure.

Your advice is to be patient a while longer. I will do so and report back in a day or three.

Link to comment
  • 1 month later...

At this late date, one month later, I'm sorry to report that the snippets of some of my notes still do not show any text. I'd say it's about half of the notes, and which snippets do and don't show text appears to be completely random. Sometime in mid-August I had to restore my phone to factory settings (an issue unrelated to EN) and start over, so I gave it two tries with the same random-snippets-without-any-text result.

Link to comment
  • Level 5*

Hi again - lets start over. Please make sure you back up the database files on your desktop machine just in case something goes horribly wrong. Here's a few 'top of the head' questions..

Have you raised a support ticket? (see below for link) The gremlins in the support desk may be able to suggest something you haven't tried yet.

Does your snippet view work correctly on your desktop machine? If so we're talking mobile issues as regards the missing information.

How much spare storage do you have on your 'phone? Do you have an external SD card for extra space? I've recently had some issues related to Android storage management which seems firmly split between internal phone storage / USB storage / external SD storage. Evernote doesn't appear able to use or recognise the external card.

If your desktop snippet view is incomplete, and when you have a spare hour or three, try starting your desktop Evernote with the /DebugMenu startup switch - it gives you an extra menu (exactly what is says on the can) that includes options to optimise your database and rebuild thumbnails. It may help. But see paragraph one above...

Let us know how you get on.

Link to comment
  • 9 months later...

I know this thread is old, but I'm the OP so I can update it. Besides, this new post is definitely on topic.


It's been 9 months since I originally reported this problem, and the problem persists. Here's what I've tried since the original report.

- I had an unrelated-to-Evernote issue with my Android phone that forced me to reset it to factory settings and start over. Upon installing EN, the same issue with about half of the snippets not showing any note content was present.

- A week ago I changed from a Samsung Galaxy S3 to a Samsung Galaxy S4. After installing EN, same issue.

- I realized that my beloved spouse has a Galaxy S3 and uses EN. Unlike me, she is an EN Free user. Unlike me, she has only 414 notes. (I have about 7,000.) She has the same issue on her phone.

- My spouse just got a Nook HD+ tablet. She installed EN, and the same issue is there too.


So I have tested for this problem on 5 installs, over 4 different Android devices, on 2 different note databases, and over 9 months worth of EN-for-Android versions, and the problem appears in all cases.


At this point I have trouble believing that anyone doesn't have this problem on Android. Maybe we should revisit my original problem statement. What I mean is, the affected snippets display only the note title and date. If I view the note and then back out to snippet view, the snippet displays the title, date, and the first few lines of text. This displaying-some-of-the-text is what I expect all of the snippets to do. The problem affects about half of the snippets, seemingly on a random basis, in all the cases I have observed.


And hello, gazumped. I didn't see your last post, from 10 September 2012, until just now when I returned to this thread. (Sorry I took so long, but sometimes I get busy.  :o ) Thanks for taking an interest in my issue; I will try to answer your questions.

- I have not contacted support. My previous contacts with EN support have been, let's say, less than satisfying, so I would use them only as a last resort. Actually I'm hoping an EN employee reads this thread and takes an interest.

- Snippets work fine on all of my PCs. (I use EN on 4 different PCs.) Snippets are also fine on my wife's PC.

- There are many GB (10 or more) of empty storage on each of the Android devices. This space is on the devices' internal storage. There are no 'external' SD cards installed.


[Edited 16 Sep 2013 to correct the exaggerated number of notes I said I have. Not 10,000; 7,000.]

Link to comment
  • Level 5*

Hi - sorry to hear the problem continues,  but it's not universal - I've run a Galaxy S2 and an S3 and - except for the notes that are just pictures - I've never noticed that any of my snippets are blank or appear to have text missing.  And you would have expected a few more comments here if it was a general issue.


Can't offer any brilliant (or otherwise) suggestions I'm afraid,  but I do urge you to submit a support ticket if only to get the fault on record.  I know the endless questions can be a pain,  but you can post the ticket number back here when you have one,  and the developers can have a look at the fault record and any tests they do if they need more information.


Good luck!

Link to comment

Well, I'll think about contacting support. It's not that I mind a lot of questions; it's that they'll be stupid questions. I bet the response will be a bunch of boilerplate that doesn't apply. For example, I'll say in my note to support that I tried 5 installs on 4 Android devices, but part of the boilerplate will say I need to uninstall and reinstall. That will just make me mad.


Anyway, this morning I scrolled to a group of snippets that were missing the note text. The screen capture at the left below has just one snippet with note text. Then I viewed each note and observed that the text had been added. The end result of viewing all the notes is in the second screen capture, to the right. I'm showing this here because... well, I don't know. Hoping for a miracle, maybe. Perhaps they contain a clue that I'm missing.


before1.png  after1.png



Link to comment
  • 5 months later...

This problem seems to have just started for me as well on my s4. In my case it may have started after the recent android update. My notebook is an offline one.

Will report more when I can.


Link to comment

I'm still here, and still having the issue, on all my and my spouse's Android devices, on our two EN databases, just as before and always.


BTW, I did report this to Evernote support, on June 27. There was back and forth about it for a while; I sent screenshots, answered questions, sent a log when requested. I was "supported" by three different individuals along the way. For some reason there were two different ticket numbers, 70723, 159799. My last contact was in October, after I sent the log. The ball's in their court. I will ping them again now.

Link to comment
  • 1 month later...

Well, I did ping EN support in December. (As has happened frequently while going back and forth on this issue, I got two more ticket numbers. Actually I've had six ticket numbers since I started on this issue in June 2013: 70723, 72498, 159799, 195601, 273266, 295701.)


First, I got a boilerplate request for the log from my phone. I sent it. A week or so later I received "We will be happy to help; however, we will need more information. Can you please explain your issue in more detail?" This, despite the fact that I had already done so, back in June 2013. I can play the boilerplate game too, so I copied-and-pasted my detailed, clear explanation from June. In response, more boilerplate, exactly as I had received previously: a request to sign out of EN, reboot, and sign back in. And, if that didn't work, a request to uninstall EN, reboot, reinstall. These things didn't help, just as they hadn't before.


Finally, a few days ago, "support" did some actual work, although their result is dubious: "After further testing we where able to reproduce this issue and determined that the notes the that have not snippet preview is due to the note content not been downloaded to your device yet, thus resulting in no possible preview. The way Evernote works on android devices is quite different from the way the desktop client works. Unless you have the Offline Notebooks feature enabled on your device, all request to view a note are delivered at the moment (notes are not kept on your device but in the server). This means that even though you might only have created a few notes to sync, every time you make a request to view any of those notes again, the application will download them from the server as they are being requested. This is why you are able to see the snippet preview after you open the note, since the note content has now downloaded to your device and the app is now able to create the preview. Unfortunately this is a design limitation and the only possible workaround will be to enable to Offline Notebooks feature on your device which will download all if your Evernote account content to it."


If one believes this message, then every Android user has this issue. Who knew? I don't believe it though, because about half of my notes do show snippet previews, which load gradually over a period of a few hours after every new install, new device, etc. Then, the loading stops for some reason. Perhaps I'll try Offline Notebooks to see what happens.

Link to comment
  • Level 5*

I don't totally agree with Support on this,  unless it's device - specific.  I have a load of notes that aren't 'offline' but my screen still shows the title and text,  though the pictures are slow in coming through.  That said I'm on my home wi-fi,  so it should be a happy phone.  I do have one setting you might check - as well as 'offline notebooks' there's an 'offline searching' setting which makes sure the index for searches is downloaded to your phone.  It's not obvious that this is relevant,  but have a look at Evernote > Settings > Search and Storage > Offline Search and make sure that box is checked..


Having said which I have one note on my desktop which is waiting to sync but confusingly the title shows up in my phone display though without any content...


I do have one notebook with offline storage - just watch out that you don't exceed your device's available memory;  bad things can happen then..

Link to comment
  • Level 5*

Just to clarify: Designating a notebook as offline (a device-specific designation) guarantees (within device storage limits) that all notes in that notebook will be downloaded to the mobile device. That downloading process may take some time. This bit is clear and appears to work fine, but is not at issue in this case.

On the other hand, notes that are not in an offline notebook *may* be cached on the device after downloading. The nature/behavior of the caching is fairly opaque; I don't know of any documentation on how long notes are cached, or the criteria for their being removed from the cache, or the effect on snippets (as whether snippet information can be cached separately from note content; per the support comment, it cannot) etc., and I haven't dug in deeply enough to have any intuitions about it. It'd be nice to have official documentation on this, but I don't know of any. The best I can say is that note content not in offline notebooks are not guaranteed to be present on the device when it's in an offline mode.

Given that, the practical approach would be to have some small number of notebooks that contain often-used notes that you can designate as offline. For example, I don't need my entire note database of software development articles / documents available on my phone. So that's a separate notebook, and I just don't mark it as offline. My to-do list, and supporting information? You bet it's a separate notebook, marked as offline.

Link to comment
To review, in my case the process of filling snippets with the first couple lines of each note's text either skips some notes randomly or stops before it is finished. And it happens with several Android devices and two independent note databases. And Evernote "support" apparently believes that note snippet text only gets filled in when a note is viewed on the device, for all Android users.


I did try setting one of my notebooks to offline mode. (And, as an aside, figuring out how to do that was impossible for me without Googling. For reference: Go to the notebooks list and tap the download icon at the bottom of the screen. Tap the download icon next to the notebook that you want to set offline. Now, to make the selected notebook available offline, select the checkbox icon at the top left side of the screen. Another Android UI puzzle. But I digress.) After the offlining process was complete, all of my snippets had text. So, this is indeed a solution, but one that doesn't work for me. I don't have room on my phone to offline my entire EN database. If I wanted to offline just the "important" notes that I might want to see snippet text for, I don't know how I'd decide in the present which notes I will want snippet text for in the future. Trying to do that would not only require another level of sorting, but it goes against the EN "remember everything" purpose and philosophy.


Apparently EN support has seen this thread, because I received this email a few days ago: "I'm sorry about all the trouble and stock replies. I went back and looked up the original issue and found the bug that was filed. The issue is still under review with the engineering team. I don't have an ETA for a fix at the moment. I will make a note in the case to get its visibility raised and to remind them that it is still an active issue. I wish I could do more. Unfortunately, once something becomes a bug there isn't much more support can do." So, a glimmer of hope.


Link to comment
  • 1 month later...

Snippets blank?  My guess is that it's something to do with Samsung android devices. 


I have a Samsung Galaxy Note 8 and the snippets are all blank except for titles and dates.


But snippets work seamlessly on all of  my other android devices, - a Nexus 5, a sony experia Ray, 

Asus Memopads 7 and 10.1


I've noticed that graphic rendering is a bit buggy on the Samsung (there' seems to be an interplay

between fast but fuzzy rendering, and pixdel precise rendering of photos and scans.)


Is there hope, or must I ditch my samsung ?







Link to comment
  • 7 months later...

It's me, the OP again, with an update. In September I ditched my Android phone and went running back to iPhone with my tail between my legs. (Everything's better now, not only EN; the Android experiment was, for me, a big mistake.) When I last used my Android phone in September, note snippet text was still randomly missing, and I had heard nothing from "support."


On iPhone, all snippet text displays, although for some notes, not instantly. Most snippet text is there instantly, but for some notes, the snippet text loads dynamically when the snippet slides into view. The dynamic loading takes about one second, so it's not a problem.

Link to comment


This topic is now archived and is closed to further replies.

  • Create New...