Jump to content

Impossible to find existing text with the search function, why? How can I fix it?

Go to solution Solved by Gabriele Beccacece,

Recommended Posts

When I use Evernote's general search function to find specific notes more quickly, I have noticed that it does not work for all notes and I do not understand why. It seems that some notes are completely invisible to the application. I can search for example for the word 'present' and find it in some notes but not in others. Then, trying to search for any other word contained in these 'invisible' notes, I encounter the same problem. So it is not a problem with the chosen words per se, since it finds them in other notes, but with some specific notes in their entirety. I don't understand why, I have recently created an account and I am creating different notes from time to time but all with the same method. How can I solve it? It's really annoying and I'm thinking of changing apps if it can't be solved

Link to comment

Sure, here is an example. While searching the word "works" it doesn't return me Presentation tips as a result, while the word is clearly there. It is also the case with every other word present in this note. I do not know if it is because the "invisible" note is shared with someone else, but happened also with personal notes that I never shared and even if it wasn't a bug, this certainly would not incentivise me me to share my work with others. Something that I clearly want to do.




Link to comment

Both notes were updated on 31 August so it wouldn't appear to be a delay in indexing. What happens if you try it on the web version of EN? If you get better resutls there you may just need to refresh your local database. Log out of EN and choose "remove my EN data from this device". You can then log in again and EN will download the data again. This will take a while but EN is usable while it does it in the background.

Link to comment
  • Solution


I disabled the shared link and it now appears in my search function, so everything works fine. I later enabled the shared link again and, luckily, it is still working as every other note. I do not know why there was the "invisible search note" bug before, but maybe this could be helpful to somebody else.

  • Like 1
Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...