Jump to content

Can't create new notes or edit them

Recommended Posts

In the past two days I have been unable to create new notes or edit old ones.  I get an error message that says "Note failed to update. There's been an error syncing your note. Please reload to resume editing." and then I am prompted to Reload.  However, reloading does not help and after doing this several times I the application appears to lock up.  The app works fine on my phone but it is the application on my Mac (OS 10.12.6) that is the problem.

Link to comment
  • Level 5

Maybe in both cases the local database got corrupted.

OK, since we are in the Mac subforum, Mac will go first:

  1. Go to the Evernote menu, Preferences, and uncheck „Keep data when leaving“
  2. Log out of EN (File menu), quit EN (cmd-q). When asked confirm "Remove Data from This Device".
  3. If you want to be very sure, restart the Mac
  4. Open EN, log back in, wait for it to run an initial sync. 
Link to comment
  • Level 5

Windows is in general the same, but the menus are a bit different:

  1. Go to File > Sign Out [name] from the menu bar.
  2. Select the "Remove my Evernote data from this device" option, then click Sign out.
  3. Restart your computer.
  4. Sign back in to Evernote
Link to comment
  • 1 month later...

I tried the solution you posted for mac and it didn't work.  I tried both with and without restarting my computer. 

My desktop app is showing additional strange behavior.  Despite logging out and explicitly checking to delete my data from the device on logout and then confirming that I was logged out of the app, my computer automatically logged me back in after restart with all of my data there.  

I use Evernote every day as part of my productivity workflow, so any solution would be highly appreciated!


Link to comment
  • Level 5

2 more options:

This is the same (should be ...) but you nuke the data folder yourself:

  1. Quit Evernote (cmd-Q, not only closing the app)
  2. Open Finder
  3. From the menu bar select Go > Go To Folder...
  4. Paste ~/Library/Application Support/ and press Go. If you don't find this directory, try ~/Library/Containers/com.evernote.Evernote/Data/Library/Application Support/ and press Go.
  5. Locate the folder titled Evernote and rename it to Evernote.old.
  6. Restart the Mac
  7. Launch Evernote and try signing in.
Link to comment
  • Level 5

If nothing works, get the app AppCleaner.

Run it with admin credentials. Draw the EN icon from the apps folder on to the AppCleaner window. When a list of items shows, make sure every position (scroll down the list !) is checked to uninstall. Only then EN will be completely removed from your Mac.

Restart, install again, use the direct download from the EN web site (not the AppStore version). Log in.

Link to comment
  • 10 months later...
  • 4 months later...

I had the huge default notebook (20K notes). Following Reddit Reddit I created an empty folder and make it the default one. It fixed the problem.

Old big folder still is not shown properly - saying it has 46 (!) notes only.

All other actions, including reinstalling (phone reset), clearing storage, etc didn't help.

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...