Jump to content

EN helper not clipping and saving within EN helper

Recommended Posts

EN Helper

I used to be able to clip, clip, clip in succession and build up a collection of clips in a single EN helper note and then save.  That's  missing....I'd like to see a return of that.  Any kind of clip results in the clip being saved directly into Evernote. In the past I would be able to make several clips, take notes and then be able to save to Evernote manually. This was incredibly useful in my work. Please help!!!

What is going on?

OS 10.15.7
EN 10.27.5 for mac

Link to comment
  • Level 5

It has changed …

Option 1: Clip to individual notes. Later merge them together.
Hint: Merging in v10 is better than in legacy - among other features you can now select the sequence in which the content will show in the unified note.

Option 2: Install the legacy client. Clip as you are used to clip.

Link to comment

OK. Not a good solution. Too. much trouble clip and merge. Also these clips need to belong in one note with added notes to each clip. It is now very time consuming- unless there is a way that I am recognizing.

I installed legacy Evernote but was not able to get the EN helper to work.

How do I install just the legacy EN helper, without the the legacy EN?

PS: Tried to install the legacy EN but neither the EN nor the helper was working correctly.

Link to comment

What is EN client?

I had my system noted above in the original post.

Mac OS 10.15.7 
EN 10.27.5 for mac is installed right now with a new version of EN helper that is not very helpful.

I would like the legacy EN helper.

Link to comment

I tried to do this yesterday. I installed the legacy version but the EN helper kept asking me to sign into Evernote even though I was signed in. Ugh!!

So frustrating. I wish I could just go back to the old version and have it work like it did without all this trouble with the new version.


Link to comment
  • Evernote Expert

The Legacy and the v10 applications work indepdently of each.  You have to sign in to each separately and they count as two devices if you are on the Free program.

If you find the old version better then uninstall v10 and just stick with Legacy - accepting you won't have access to any of the new features which may not necessary for your use.

Link to comment
  • Level 5

On my MacBook Pro, Monterey 12.1, EN 10.27 I run both clients side by side. Each keeps its own database, no problem with both.

With the helpers, you need to know which is which. If you run both apps, you have both helper icons in the menu bar - 2 slightly different elephant icons ! The old helper has an audio option, that does not exist in the new one - it makes it easier to tell them apart on first view.

The new helper will only run once the v10 app is active - which can be in the background. In legacy settings you can define to open the old helper when the Mac is started, or with the apps start.

Link to comment
  • Level 5

There is one web clipper for each of the major 3 browsers: Chrome and Chromium, Firefox / Mozilla and Safari. You don’t notice, because you get the right version from the browser extensions store.

Because the browsers permanently add new functions - often breaking old ones - EN is permanently updating the WebClipper as well.

There may have been an issue with the latest version for Chrome (broken external links). And there are websites (for example behind paywalls) that won’t allow you to clip.

In question use an alternative browser - but not in the same „engine“ family, one of the above mentioned alternatives. If Chrome is your main browser, get Firefox. Safari only works on Macs and iOS.

Link to comment

I am not clear from your explanation why the clipper is not working now, whilst it was working a couple of days ago. I have used EN and clipper for over a decade so I generally know how it functions. 

What should I do? I have Mac-Chrome, so download a Safari EN web clipper?

Thanks for your help


Link to comment
  • Level 5

Every extension can be crippled when the browser itself updates.

I always keep at least 2 independent browsers installed, in my case it is Safari and Firefox. On both I keep my usual extensions, and both I keep updated.

If one does not work, I try on the other. With some pages, using another browser helps. With others, both do not work.

In your case, and because every Mac has Safari installed, I would get the WebClipper for Safari, and try. Safari extensions will only install from the AppStore, there is no direct install.

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...