Jump to content
  • 0

Search utterly broken


Koandco

Idea

Not sure if anyone else noticed, but I can't find a note I've just added. I see it in all my notes but if I search for it with keywords of the title, nothing. If I search by tags, nothing. But I KNOW IT'S THERE. The whole idea of Evernote for me is its search engine, both in all notes and inside the note. 

It's ridiculous. I've named my note KO invoice template. I've tagged it with these 3 words. I search with all 3 words = nothing, with each word, nothing, by tags, nothing. I wonder if I don't need to re-index all my notes? 

At this point, Note on Mac is better. Legacy version is frankly better. What has happened with this latest update?

Link to comment

15 replies to this idea

Recommended Posts

  • 1

OH, BTW, in my lovely old legacy version, the note gets found in 1 second. So, I've retired the new version. I'm sticking to Legacy. 

Link to comment
  • 0
  • Level 5*
12 minutes ago, Koandco said:

OH, BTW, in my lovely old legacy version, the note gets found in 1 second. So, I've retired the new version. I'm sticking to Legacy. 

I confirmed your results - Search utterly broken in v10

I'm also sticking with the Legacy product

Link to comment
  • 0

I'm here because I was looking for known search bugs. I'm on Evernote webapp, latest version. Not the first time I can't find something WHILE I KNOW IT'S THERE (I love how OP capitalized this). It happened today again. Unfortunately, the bug is not reproductible. Because after I catch EN red-handed (I found my note by other means), the search is then mysteriously fixed (as if I had told the algorithm, hey look, it was right there!). Why, idk. Maybe because the target note is now cached? For me, it was a 16 days old note. (but older false positives had appeared in search results, so...)

Here is how I manually found the note : search had found another note which gave me a hint as to *when* I had written down what I needed to find. So I used the "note history" tool, and after several trial and error atempts, I squared down the time interval to 2 days.  Then I sorted all my notes by date, and could start manually searching everything from those 2 days (as if looking in a paper notebook of the past).

And what I was sure was in my notes somewhere, was there, indeed. And no, the exact words I was looking for were not absent, they were there. When I did the search again, as mentioned above, search was fixed (a bit too late...). I was, not the first time, FURIOUS. Why spend dozens of hours building a huge personal database, if the app lies to me and tells me "no, your memory fools you, you think you have worked on this subject in the past, but you actually did not". So I wanted to use that frustration to take the leap to OneNote or Google Keep.

Thanks to this thread, I'm giving EN another, other chance... I saw that even on the webapp, there's a checkbox one can untick to refuse the v+10 version. @DTLow you seem to say that search worked correctly before v10 (I hope so, been using EN since 2017 and I'm not sure search worked 100%)

I think I have about 4000 notes. (which is under the 10k threshold mentioned in the "personals settings" page, but still a lot.

Link to comment
  • 0

Thanks @Koandco

I unticked "enable V10+" in "personal settings", but now I see a different menu when I click my name, saying (I translate) "revert to previous version of Evernote". I'm not sure if I'm already on "legacy", or didn't go back far enough? I don't even know where to find the version number on the webapp... Or is "legacy" only refering to the old Windows native app?

Link to comment
  • 0
1 hour ago, StéphaneDeFrance said:

I contacted support and they say there's no way to display version number on Evernote Web.

Well support are wrong! Click "Need a little help?" at the bottom of the sidebar and then release notes. The version number is at the top of the release notes pop up. In the old version of EN Web I think you got it fromthe drop down next to your user name at the top left of the sidebar.

  • Like 1
Link to comment
  • 0

@Mike P Thanks for the tip. I'm on EN web (legacy) now, my user name is at the bottom and "help" only takes me to https://help.evernote.com/hc/fr  No release notes in that menu, maybe they removed it. I still wonder if search works well in the web version between v10+ and legacy (when you untick the v10+ checkbox but don't choose "take me back to the old version").

Sorry I'm pretty cautious so I'm not changing my version again to publish here the exact version of what I called "middle version" thanks to your tip. But I did notice differences from both v10+ and legacy.

Link to comment
  • 0

So it's lame, even Support admits it's a "known limitation". Limitation??? Huge flaw, bug, break...Huge!!! The hugest issue in my opinion. If the search doesn't work in a note software, might as well not have that software. 

Here's the response:

Hello Katherine,

Thank you for contacting Evernote Customer Support. I'm Camila, and I'll be assisting you today.

I'm sorry to hear that the note you just added is cannot be searched on Evernote for Mac. I understand that you want your changes to be reflected immediately in your search results.

Thanks for reporting this issue to us. Please know that this is one of the known limitation that we are currently working on, and hope to be resolved soon.

We appreciate your extended patience as we work on improving the new Evernote app.

If you have any other concern or inquiry, don't hesitate to contact us again.

Best regards,

Camila S.
Customer Support Representative

Link to comment
  • 0

@Koandco Oh nice, you had a reply. Well at least they acknowledge the issue, and they are working on it... I understand when you talk about "huge bug" treated as a little glitch. I didn't want to start a new thread, my problem is similar but not exactly the same. My note that wasn't found on Evernote web v10+ was 2 weeks old. I wonder if it's related. It would be nice if they would publish their roadmap for fixing search, so we know when we can switch back from legacy to v10+. A thorough search tool is indeed of paramount importance for a note taking app. If I want to forget a few things, old and new, I already have my brain.

Good job opening a ticket about your problem and publishing the result. Interesting.

Link to comment
  • 0

I am finding that if you add a NEW note, it can take as long as 15 minutes before it can be searched successfully  (Im using the desktop app for Windows).

This tells me that all searches take place in the cloud, not locally, and therefore this is likely to be either a server or network issue.

Also, the fact that the app does not tell you that all of your notes are being placed on a hard drive somewhere that's not on your own computer is a real security issue.

Evernote should be making this fact very clear, so the customer can make allowances for the type and content of their notes accordingly, and also they should be giving us the choice of whether we want all notes stored only locally to our own machines (and therefore searched that way).

I'd like an official response about this. With so many online companies getting hacked these days our notes may end up in the wrong hands easily enough, I'm afraid.

I want an option built in for LOCAL note storage & search capability with Evernote. Also a good idea to be able to make the note storage possible in any folder we choose for easy backup/restore.

Thank you

 

**EDIT - well no, the search function is more broken than I had thought...I just put a new note in 1 full hour ago and it still not being found by the search function...guess this was $57 down the toilet now? I mean come on guys/gals...a robust and accurate search function is the only thing that could ever make a note tracking system such as this a viable and useful tool.

Without a solid working search function it's time to issue refunds because the software becomes useless. I just purchased 1 day ago and would like a refund until such a time that this gets fixed, and then I'll reconsider a repurchase at that point in time.

Edited by DaveNY
app is broken requesting refund
Link to comment
  • 0

I am new to evernote - and am already stuck searching for help. Seems others are having similar problems.

I just installed Mac version (and iPhone) and created first 20 simple notes (no PDF, no tagging, nothing special - just text notes). When I try to search for some of them, search results are empty, even though the note is obviously there and I'm searching by the actual title of the note. It's been over 24h since the notes have been created, so it's not the timing issue.

Interesting part is that search works for some notes and not for others. Very random. 

Does anyone have any suggestions other than "uninstall Evernote and find alternative solution"?

 

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...