Jump to content
  • 0

Unable to get Webclipper working on Firefox - Mac




I am running Firefox 712.0 (64 bit) on Mojave on a MacBookPro and recently swapped from defaulting to Chrome to defaulting to FF. But WebClipper seems to be the last thing that I can't get working.

The WC Icon shows a red dot image.png.38b54afb0c81701d3cbf6989c4cd7c3a.png

I think this means I have not linked the plugin to my EN account.

If I hover over it it says " Sign in to WebClipper"

If I click on the button I get 2 popups in sequence, the first of which I cant read or screenshot as it disappears very quickly.

The 2nd one is a Firefox notification


But I can't expand it to see the full meesage.

Can anyone help?





Link to comment

5 replies to this idea

Recommended Posts

  • 0
  • Level 5

Since I am on Catalina, I can’t compare 1:1. But even with the stricter rules under Catalina, I have it working with FF and Safari. When the Safari extension had problems, I even used FF as my primary browser for about 5 weeks, with WC and all.

Are cookies allowed in the FF settings ?

When I had a similar problem with WC for Safari, I did unlock the browser settings once (open it up as far as possible), then installed WC and put the settings back to a high level of privacy. It worked, obviously WC needed the security gap only once to install.

Link to comment
  • 0
  • Level 5*

Not a Mac user,  but last time I dropped into Firefox clipper worked fine on Windows...  to keep you logged in it will want to drop a cookie on your system,  so like @PinkElephant I'd suggest changing the level of security on the browser,  or maybe exempting Evernote domains.

Link to comment
  • 0
  • Level 5

Hello, sorry for the delay, but I was iPad-only for a few days.

Evernote WebClipper Ver. 6.13.3., MacOS Catalina 10.15.2, FireFox 71.0, 64bit

FF Preferences:

Privacy: Strict (Maybe you have to change this to install WebClipper)

Permissions: All on "Block", except the last one (will change this, but it requires a FF restart ...)

Security: All on Block

Extensions & Themes: My WebClipper Permissions (this page I could not clip with WC because of browser restrictions, although I can clip other pages fine. So I used the screenshot function of my Mac to grab it)


It may be that you have to reduce the security & privacy settings to install WebClipper. But once this is done, you can return to a strict setting. At least this is what prevented WebClipper on my Mac to install in Safari. Not sure exactly how I did it for FF, but if I had any trouble I would remember.

Probably it is important to do a new, clean install. This would mean uninstall FF using AppCleaner, and really check ALL options to remove anything. Hint: This means your bookmarks, website passwords, history, cookies etc. will be gone as well ! So this is the last resort, if you really need to install.

Then reinstall FF, set the security low and install WebClipper through the Extensions menu of FF. If you use the download WC-Button on the EN website from FF, it will take you there automatically.


Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...