Jump to content
  • 0

Note content (still) not showing up



Updated to 6.0.3 (on Yosemite), rebooted, logged out, logged back in, rinse and repeat... Whatever I do the content of my notes doesn't show up in the content area nor can I edit/create new notes.


It's kinda getting old at this point. I thought 6.0.1, .2 and .3 were all supposed to fix that problem. Any ideas to I can do or should try apart from the aforementioned routine?


Edit: actually the content *will* show up eventually. It just takes the editor about a minute for each note. The activity log shows the following exception:


2014/12/09 17:50:15:236 I|*   -[ENCommonEditorWebView updateViewFromNoteContent] main | loading note content, dirty=0 usn=6000 ... 'Title'2014/12/09 17:51:15:301 E|*** -[ENCommonEditorWebView callJavascriptENMethod:args:] main | Calling EN.setup((    "{\"active\":true,\"shared\":{\"visible\":false},\"find\":{\"limit\":5000,\"selector\":\"#en-note\"},\"context-upsell\":{},\"title\":{\"value\":\"Title\",\"placeholder\":\"Untitled\",\"active\":true},\"env\":{\"selectionColor\":\"rgb(178,215,255)\"},\"context\":{\"shareButtonLabel\":\"Share\",\"hideIndicatorLabelWhenCollapsed\":\"Show All (0)\",\"contextSectionLabel\":\"Context\",\"visible\":false,\"expanded\":true,\"toastNotificationHeaderLabel\":\"\",\"toastNotificationFooterLabel\":\"See all Context\",\"items\":[],\"chatButtonLabel\":\"Chat\",\"hideIndicatorLabelWhenExpanded\":\"Hide\"},\"rte\":{\"behavior\":true,\"placeholder\":\"Drag files here or just start typing\",\"editable\":true,\"trackStateChanges\":[\"bold\",\"italic\",\"underline\",\"highlight\"],\"keyCommands\":false,\"trackEnabledChanges\":[\"inserttable\",\"inserthorizontalrule\",\"justifyleft\"],\"trackValueChanges\":[\"justifyleft\",\"fontsize\",\"fontname\",\"forecolor\",\"insertunorderedlist\"]}}")) failed with exception: [<DOMAbstractView 0x610000233bc0> valueForUndefinedKey:]: this class is not key value coding-compliant for the key EN.
Link to comment

9 replies to this idea

Recommended Posts

  • Level 5

Yes (and if possible I'd really like to keep using the app store version and not switch back to the direct download).

I understand but this seems to be the problem. In my view the direct download version has an advantage over the App Store version: in case of serious bugs you will get a fix much faster. Even if a fix is available it might take weeks until it is released on the App Store. And in this case it seems that Evernote does not know the cause of this problem yet. But it is your choice.

Link to comment

We just released a Beta version of 6.0.4 that we think fixes this issue for most cases but we need your help in testing it out.  If you continue to see the blank note issue in 6.0.3 and you're open to trying out our beta release (download only), please check out my forum post about the beta release to learn what else is in it and how to download it.  https://discussion.evernote.com/topic/78913-evernote-for-mac-604-beta-1-released/.

Link to comment

Even if a fix is available it might take weeks until it is released on the App Store. And in this case it seems that Evernote does not know the cause of this problem 


Yeah.... but no. I'm a developer myself and I've had my share of fights with both the mac and the iOS app store. And while both have their problems it's obvious that all the issues with Evernote 6 aren't rooted in the app store but in really bad QA on Evernote's side. Evernote has promised for at least 3 versions now that the next release will definitely-really-this-time-for-sure fix the very bad data corruption and data loss problems. Once you've really *fixed* your problems you can easily get an (or even multiple) expedited review for your urgent bug-fix releases.


That said I'd like to not derail this thread too much, so let's stick to the topic of possible solutions for the problem. And as many other people here I'd like to close with the fact that I really like Evernote the product and that I'm usually really passionate about it. That's why I've been a paying customer for years :) 

Link to comment
  • Level 5*

You can try the just released Ver 6.0.4 Beta, but it is a BETA release, so there can be (and usually are) new bugs in the Beta.


Even though EN Mac 6.0.3 Mac App Store has been released that is supposed to fix many of the Ver 6.0 issues, it appears that many issues remain.


At this point I have lost confidence in all EN Mac App Store versions, and recommend that users switch to the Direct Download version.  The latest is Evernote Mac v6.0.3.


Many of us have long preferred the Direct Download version as its benefits seem to far outweigh the delays and issues associated with the Mac App Store versions.


Jackolicious, on 07 Dec 2014 - 9:52 PM, said:


Sandboxing (in the Mac App Store) is currently causing some very strange note-loading errors. As far as we can tell, these don't exist in the direct download version. 

The code-base between the two binary types is the same if the version numbers match (currently 6.0.3 is in both direct download and app store).



Link to comment

I am a long-time overall happy premium user experiencing this problem for the first time on my brand-new mac.  I have an App Store version.  Restarting computer each time worked but was getting old.   Using disk utility to repair permissions seems to have fixed it, but we will see.  


Not to deviate the forum, but agree with previous reviewers about company deviating from mission.  The whole point of Evernote is that your data is always there and always accessible and usable.   If you fail at this, who cares if you can work chat?   And why is it exponentially harder to e-mail a note then share with work chat?  Please prioritize core functionality over gimmicky new features!

Link to comment


This topic is now archived and is closed to further replies.

  • Create New...