Jump to content
  • 0

Annotate PDF in Evernote with Integral skitch, finish, annotations lost.



I am annotating legal papers. Was really happy using evernote to do this, with my mac, until it started to lose all my annotations when exiting back to evernote.


There doesn't seem to be a manual save, so it's all or nothing.


I had planned to get a multipage scanner to start really digitising my workflow, but if I'm going to lose chunks of work I can't do it.


anyone any idea why evernote is occasionally losing all the annotations?

Link to comment

26 replies to this idea

Recommended Posts

Thanks hugocbp. It seems the exact same scenario led to the problem on my end as well.


I've lost hours of annotations. I only noticed this on my most recent annotation session, but I'm going back through my old notes and am noticing missing annotations everywhere! :( :( :(


Please do us a favour and warn users about this bug, if you can't fix it right away. I'd happily make my annotations with the Mac Preview (which I prefer anyway, since text boxes can actually be resized and have the content inside flow as opposed to scaling like an image) app, had I known about this bug.

Link to comment


Looking at Evernote today, I see that of the 7 attempts to annotate a particular image, 4 had annotations added, 3 did not.  Just now I took another snapshot in Skitch and annotated it successfully in Evernote.  Maybe Evernote was a little flaky, maybe I committed some pilot error.  In any case, I'd chalk this up to no trouble found or not repeatable, and leave it be.


For what it's worth, I'm running Mac OS X 10.10.1, Evernote 6.0, Skitch 2.7.6.  I think this is all up-to-date. 


Thanks anyway for following up.

Link to comment


Can I get more information, namely detailed steps about the Skitch PNG problem?


I am running the same mix of OS, EN and Skitch, and able to take a note that is in EN (originally created in Skitch, and annotate it (added stamps for me test) clicked the "x" to kill the annotation screen and the file was updated in EN


BTW - which version of Skitch do you have, i have 2.7.6



Link to comment

I am running Evernote 6.0 on Mac OS X 10.10.1 (Yosemite).  I have tried to annotate a .png captured in Skitch and saved in as a note in Evernote.  I can mark it up.  When I do, in the Mac notification system I get a notice that the .png has been updated.  When I close it, marks are not preserved.  Tried the sequence suggested above by MagiCubes re: pdfs.  Could not follow instructions exactly - perhaps a difference from .pdfs.


It appears to me that this feature remains broken.

Link to comment

This is fixed in EN 5.6 which has been released, is anyone still running into the problem (with 5.6)?  And if you aren't on 5.6 can you update to 5.6?



I'm running EN 5.6.2 on Yosemite (10.10).  While I haven't completely lost annotations to PDFs (thanks for fixing most of the bug!), moving from the full-screen annotation space to the main app screen or to another space on my Mac is quite abrupt and results in closing the annotation view.  It takes a few minutes before the annotate icon/button reappears on the PDF in the note, which appears to be the only way to return to the annotation view.  EN appears to be save the annotations made to the PDFs during this time (the annotation overviews refresh with new data each time), but the transition process feels clunky and wastes time by halting workflow.


Is this the current solution found to losing annotations--to force closure of the annotation space and thus automatic saving and syncing?  If so, I would encourage it to become more streamlined in the future, hopefully without having to close the annotation view.  It becomes very hard to simultaneously take notes and annotate a document at the same time.





Link to comment

I am extremely frustrated and disappointed. I just lost over an hours of work because I was annotating in full screen mode, clicked the X and lost all of my work.


The most frustrating part is that Evernote is always open in the background and did not notify me that the update to the newest version (5.6?) was available and would have resolved this bug.

How can there not be a check that annotations have been saved before closing the window and losing all the changes?


I adopted Evernote exclusively as my new note saving platform and was using this feature for the first time today - Planning on upgrading to Premium given the value I was getting out of Evernote.


Incredibly disappointed, and a lot of trust lost in the platform.


Link to comment

I'm having the same problem. My work around is - 


Do NOT Close the PDF with the X close button, instead


1/ First click the Full Screen Button to enlarge, then click again to reduce, (this step seems to be key).

2/ Then Click The Annotate Icon in main Nav to save and close. Its a little hassle as the annotated PDF is on top of the Annotate Icon, but that seems to have worked to save the annotations.  Hope this helps for you. 

Link to comment

This just happened to me too. A full night of annotation lost.


Initially I had the problem that on mac with v5.5.2 where I was running evernote fullscreen and I didn't realize that annotation window opened a new full screen area. I went to look up some information and back to annotating it. Then realized I had two full screen annotation sessions going. I closed the old one and continued with the new one. This morning almost all annotations are lost, only the first few that I made are still there :-(

Link to comment

Yep, I posted in here months ago about this bug. And they were "working on it" I think evernote is confused, this is not some free app we have downloaded from the app store. I pay 40$ a month for this service. If you can't fix the bug remove that feature. You're just wasting everyones time leaving it in and not fixing it. 

Link to comment

Are there any news to this topic? I just lost annotations from a two hour webinar :( It's a bit annoying, I must tell. And it's not the first time, my annotations weren't saved. As I see, the problem has been known for a long while now, so I'm really wondering, why is it still happening? Especially, when we concern Evernote as a paid service...

Evernote, you'd better block this function for a while, until you're able to solve the problem, because loosing a few hours of ones job may be really annoying, as it was for me today.


I'm using the newest version of Evernote available on Desktop under Mac OS 10.9, in case you need to know.


I'd be happy to hear from Evernote's Support, what are you going to do about this bug? Maybe you should add the possibility to manualy save the annotations as long as it's not possible to save them automagically?

Link to comment

This happens to me as well, but I know exactely why is happening. These are the steps to reproduce:


1. Open Evernote in full screen mode.


2. Open a note in annotate mode, also in full screen mode.


3. Change spaces from the note with anotations to the main Evernote space.


When you do this, Evernote will save the annotations made that far and update the note. After that, any other annotation I make won't be saved.


The workaround I found is that, whenever I need to switch spaces when annotating a PDF, I close and reopen the note.

This has been happening for several versions and happened to me a bunch of times before I could sort of identify the problem and work around it.


I'm no expert, but I think that when you go back to the main Evernote window, the app tries to update the note with the annotations made, but then it "forgets" about the note that is still opened in another space.


This only happens when I change spaces BACK to Evernote's main window. If I don't go back do Evernote, it won't partially save the note.

Link to comment

Ok, so I have just marked up an electrical drawing with this and I'm trying to figure out how to save because I can see its not syncing to my evernote. And now I have lost my entire page of work. I see this was first asked about in January with a response from you guys in March. How the hell is this not figured out ? 


I gotta say, I'm choked right now. I pay a lot of money to have my company hooked up to this service and this is the last thing I need at 7pm tonight. 


Fuxking brutal. 

Link to comment


Does it happen more often when you leave the Annotation window open for a long time? Is it more reliable if you complete your annotations within a short timeframe perhaps (maybe 3 minutes)?

Thanks again,


Link to comment

Thank you for looking at this Lester


This has happened to all the PDF´s I´ve tried. It saves some annotations. Some of the time it has helped to change tools after an anotation. Then it popes up on the right side when you mark of or showing only the annotated pages. Other times that didn´t work.


The problem is the same for pdf´s generated by Evernote. I used the the evernote clipping-tool for chorome, and tryed to anotate that. Same problem. My first anotation is saved. The rest is gone. Here is the PDF with that one annotation: https://www.dropbox.com/s/34yzzs9zj80td84/HERNIATED%20DISC%20AND%20YOGA%20%7C%20Prema%20Yoga.pdf

Link to comment

Whoever is still having this problem, could you let me know if this happens to all PDFs or just certain ones? Does it save some annotations or no annotations at all? If possible, would you be able to PM it to me. We can take a look at the PDF and see if there is something in the properties of the PDF that is preventing us from writing to it.



Link to comment

Has there bin a fix to this? I have the same problem. I finish, then it isn´t saved. Frustrating with not being able to save with cmd+s. Annotating was the main reason for using Evernote. No not so sure anymore :( I¨m on Evernote 5.5 (402491 Direct) OsX 10.9.2.

Link to comment


This topic is now archived and is closed to further replies.

  • Create New...