Jump to content

(Archived) Content of notes not displaying

Recommended Posts

I have just updated to the new version of Evernote for the Iphone. I can see thumbnails of the contents of each note, but when I click on the note, all that is displayed is the title of the note -- none of the content is shown.

Does anyone have an idea of what the problem is?

Link to comment

Any chance you gents are on iPhone 3.0, like I am? If so, that's the problem, Evernote for the iPhone states it requires the 2.0 firmware.

Bummer too because with Zenbe and OmniFocus now working with 3.0, this is the last piece of my workflow that doesn't, but hey, thats what happens when you install beta operating systems.

Link to comment

Couple more questions for you...

Have you ever had the iPhone SDK installed? A lot of people downloaded the free version, and it's had a few weird effects if you haven't kept it up to date.

Second question, have you tried restoring the iPhone OS from scratch and not restoring the backup file? Sometimes setting the phone up as a brand new install can clean up preference files that can cause graphical bugs.

If you can post a screenshot of the problem, it might help too.

Link to comment

Ok, this is REALLY weird. I got back home and tried it again, you know, "just for the heck of it" and everything is now appearing! I have no idea what the difference is other than the fact that I was on 3G and then got home on my wireless connection. Any thoughts?

Link to comment

I have a hunch, but first...

Did you reboot in between the time it didn't work and the time it did? Did you sync again? Anything physically you can think of?

If not, then my guess would be that your 3G connection wasn't working quite correctly. It's very possible that you weren't getting a good connection off of 3G to Evernote's servers. In which case, you couldn't display any information because it couldn't pull that information down from the servers.

I don't live in a 3G zone (which makes me cry myself to sleep every night) but when I travel into the bigger cities that do, it's happened to me with a few apps. Pandora Radio does it to me in Tucson, AZ all the time.

I find the best fix is to turn the phone on Airplane Mode, wait 30 seconds, and turn it back on normal. That allows the 3G adapter to communicate again with the cell towers and often cleans up my connection for me.

What can I say? The iPhone is one heck of a powerful tool, but the we live in a less than perfect world where bugs and glitches still happen. And thank goodness too, I'm an IT Manager. If not for that fact, I'd be out of work.

Link to comment

I've got exactly the same problem

- Doesn't matter whether i'm on 3G or wifi

- Restarting the phone doesn't work

- Uninstalling and reinstalling Evernote doesn't work

- Syncing with itunes doesn't work

By the sounds of it it's not firmware dependant, but can I ask if the problem started for everyone after upgrading to Evernote 2.0? Because it did for me.

I'm on firmware 2.2.1 (jailbroken) and Evernote 2.0

Any help would be much appreciated!

Link to comment

If people are having this problem, could you please clarify whether you are just using the standard iPhone software, or whether you have ever done any of the following on your device:

Installed the iPhone 3.0

Installed the iPhone SDK

Performed a "jail break" on your device

Also, please try rebooting your device if you are seeing the problem to see whether that fixes it.

We're trying to determine whether anyone is consistently seeing this with a device that has never been modified in one of these non-standard ways.


Link to comment

I'm having the exact same problem. Multiple reboots, wifi (encrypted and non-encrypted), 3g, edge, no go.

Can see my full list, and thumbnails, but no note details, including precached favorites.

I'm using the 3.0 beta 2 firmward, no SDK. I have 80+ apps on the phone, so far evernote is the only app that's not working with 3.0b2, but I'll keep testing and post if I find others.


Link to comment

Thanks to everyone for providing details about their errors.

The current version of our client does not run correctly on the beta release of the 3.0 firmware. We plan to release a 3.0-compatible version of our client when the full 3.0 release is available, or shortly after.

If anyone else is having this particular error on a non-3.0 phone without the SDK, please let us know your configuration.


Link to comment

I seem to have the same problem.

I'm using a 3G iPhone running 2.2.1. the phone is jailbroken. I have never used any beta firmware & haven't had any SDK installed

Everything worked fine until the latest evernote update.

Link to comment

I'm also having issues. 2.2.1, jailbroken, iPhone 3G. Worked just fine until the latest update. Sometimes rebooting the phone works, and sometimes it doesn't. Either way, it's unfortunate. I'm using the web interface for now, but it doesn't compare.

Thanks in advance for your help!

Link to comment

Thanks for the tip. 2.2.1 Jailbroken iPhone3G. Rebooting fixes the problem. Nothing else does.

Please fix, Evernote.

Did not realize how much I am dependent on Evernote on iPhone until today when I noticed the bug.

Will have to carry my laptop with me from now on.

Link to comment

I'm having the same problem. The contents of my notes are not showing up on my iphone. My phone has 2.2.1 and is jailbroken. I've reset the phone and uninstalled and reinstalled Evernote -- and still the contents of the notes do not show up.


Link to comment

Same problem here too.

Iphone OS 2.2.0 + jailbreak.

Worked great until the new Evernote update.

Even creating a note on the phone, sync, try to read note I just made, and its blank on the iphone, but fine on evernote web.

Unistall/Reinstall, reboot, nothing helps.

Link to comment

Ok, it seems that there are issues with the 3.0 beta OS release, and with jailbroken phones.

Is anyone seeing this with a normal, released, non-jailbreak iPhone? I.e. using the released, unbroken OS from Apple?


Link to comment

This is exactly my problem. 3.0 Beta 2 software. Everything seems to work including thumbnails, but the separate notes content page tries to load the text of any individual text note (for some time) without success and then goes to that note's page with the contents blank.

By the way, if you don't already do so, highlighting names in the addressbook, email addresses, phone numbers and URLs in text notes, with click on launch the appropriate application (address card, mailer, phone dialer or browser (Apple's notes app already does all that) would be an excellent addition to Evernote.

Link to comment
Ok, it seems that there are issues with the 3.0 beta OS release, and with jailbroken phones.

Is anyone seeing this with a normal, released, non-jailbreak iPhone? I.e. using the released, unbroken OS from Apple?


Uh oh... I don't suppose there's going to be any effort to fix this problem for an unsupported hacked iPhone. I wish the iTunes store would let you downgrade versions of apps, as the prior version worked just fine. I LOVE Evernote, but I don't think I can give up the Cydia apps I use jailbroken.

Link to comment

Hey - don't think that at all.

We are well aware that you have a choice in your cellular service provider and may choose to unlock your phone.

We're also aware that there multiple ways of doing this.

For example, if you use QuickPWN, and haven't updated to the latest version of the iPhone firmware (I think 2.0.1 works?) then this problem doesn't display at all. However, if you have upgraded past that using iTunes, it seems to break, even though all the other apps are working properly.

Link to comment

Thanks for the reply, and the tip, heather.

I did you QuickPWN to jailbreak the phone, but I'm already on firmware 2.2.1. I might still have some firmware versions downloaded in my iTunes system files...

The reason I updated the firmware to 2.2.1 in the first place was because a number of OTHER apps refused to even run on 2.2.0 anymore.

I guess I'm in a bit of a no man's land right now. Hopefully we can figure out something – the iPhone app spoiled me and using the mobile web interface is nowhere near as fast.


Link to comment

Hi -

I am having the same problem, but my iPod touch is NOT jailbroken. Running v2.2.1. Any help would be appreciated - I can't access anything when I'm away from my home wi-fi, even the notes designated favorites.



Link to comment

I found a workaround for those using jailbroken 2.2.1:

Install OpenSSH if you haven't already.

Use an FTP client to SSH into your phone.

Go to /private/var/mobile/Applications and find the folder that contains Evernote.app (you have to go into each folder to find it).

Backup this folder (in case anything goes wrong) by dragging it to your hard drive.

Once you've backed up the folder, erase it. If you have any pending notes, erasing the folder will delete these as well.

Restart your iPhone and download the Evernote application again from the AppStore app on your iPhone.

If all goes well you should be able to re-sign in and download your notes.

Link to comment

@travtufts Is your Evernote installation still working, now that it's been a few day since following the steps proposed by johnny5w? I completed the steps and it worked for about an hour before I couldn't download any more notes. I'm still able to access notes that I've downloaded before (maybe they are cached on the device?).

I've been trying to pinpoint what it is that prevents me from downloading new notes, but I usually find that rebooting the iPhone remedies the problem temporarily. A mate has an iPod touch that is also jailbroken 2.2.1, and Evernote works fine. It's a very strange problem. Looking forward to some guidance here! Thanks!

Link to comment

No it's not a foolproof fix longterm. I could download notes for the first day or two, but then it stopped working. A power reset fixed the issue (something that wasn't always true before replacing the app) and I FEEL like the notes will download for a longer period than before. I only reset every day or two instead of every 8 hours.

I wonder what background (or foreground) processes are happening in that period to conflict with Evernote. I do have ilocalis installed via cydia, which has a daemon running so it will update their server every 30 minutes, but I doubt that's it.

I thought it could be an available memory issue, but if that were the case a respring should fix the problem (which it often doesn't).

Any ideas out there?

Link to comment

So far, I've definitely noticed an improvement with how long I can go between restarts with the notes still displaying. Before yesterday when I rebooted, I had gone a full four days being able to view notes.

Link to comment


This topic is now archived and is closed to further replies.

  • Create New...