Jump to content

Skitch bug shares JPG instead of PNG when sharing an image

Alan Houser

Recommended Posts


I've always tried to use the best possible quality file for all screenshots, in-case I need to edit images later, etc.

I've notice though that there's differences in file-formats, depending on which "sharing option" is selected.


1. I want to use PNG, and to post the image to Basecamp, so by default I'm working with a PNG:


2. If I select SHARE & COPY URL, the image that's uploaded is a PNG file (the screenshot below in-fact), but it's ONLY a PNG if the option is set to "NOTE URL"


3. If under the Options, if the selection is DIRECT IMAGE URL, the output is JPG— NOT PNG.


I thought maybe this was done to save bandwidth in the end (by using a compressed JPG instead of a PNG), but the file-size is exactly the same for both versions of the image.


OSX 10.8.2

Chrome: Version 24.0.1312.52

Skitch: Version 2.0.4 (262476)
Link to comment
  • 5 months later...

I have different problem. Opposite one. For me it is always shared as png when I am using my own FTP


Steps to reproduce:


  1. Define own FTP server for uploads
  2. Define base url, enable unique timestamp
  3. I have made screen of this post
  4. I have selected Jpeg and Share to FTP
  5. Format of the picture is PNG

Expected behavior would be to have it uploaded as jpeg. 


It would be nice when it would be possible to set the Quality of the jpeg in preferences 

Link to comment
  • 4 months later...
  • 10 months later...

Confirmed that this is still a bug under Skitch Version 2.7.2.


I have the format set to PNG, but it always uploads to my SFTP "sharing account" server as a JPG. The same thing happens if I try to share with the default Evernote servers. Very frustrating. (Yes, I use a Retina MacBook Pro, but I have an external non-retina display hooked up to it too)


This bug is almost two years old now. How is it not fixed yet?

Link to comment
  • 2 weeks later...

I am having the same issue on my 2013 15" RetinaMacbook Pro. When I use Shift-Command-M to email an image, it is shared as a PNG regardless of the other settings. Further, my recipients can't open and view the resulting file. My workaround is to manually create the email (I'm using Apple Mail and an IMAP account) and then drag from Skitch to the body of the email. That generates a JPEG with seems to open just fine. Sure would be nice if the shortcut actually worked.


If anyone has a fix for this I would love to hear about it. 

Link to comment


This topic is now archived and is closed to further replies.

  • Create New...