Jump to content

Upgrading Evernote from version

Go to solution Solved by agsteele,

Recommended Posts

I am trying to upgrade my Evernote from version but I just get an error when trying to open the latest version of Evernote.

"Something went wrong on our end, sorry about that. Please try restarting Evernote."

Everything works on the legacy version. What can I do?

Link to comment

I'm on a Dell XPS 15. I'm running Windows 11 Home. I downloaded the latest version from the official website (version 10.62.5). I downloaded the setup file and installed it manually. I did not use the upgrade option in my old version. I've tried to uninstall the old version but I get the same result with or without the old version installed.

Link to comment
  • Evernote Expert
  • Solution

Best off to use Revo Uninstaller to get rid of the old version, if that is what you want. Then reinstall from the latest download from evernote.com

10.63.2 is the latest release.

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...