Jump to content

Cannot login to Evernote to see my profile or change password

Recommended Posts

I am using Evernote 10.5.95-mac-mas-public (5236).  When I try to Evernote > Settings > Login & Security, I get a prompt with a link marked "Go to your profile".  When I click on that I get this: 


There is no option here but to hit continue with Google.  This is a problem since my email address mark.cornwell@me.com is an Apple address not a Google address.  When I try continue with Google, I get...


And now there is no way to proceed.

According to my reading, I might be able to fix this by changing something in my profile... but since I can't get to my profile, I can't fix it.  Catch-22.  That's some catch.

Is there some other way I can get to my profile?   I am not able to get to Evernote through any of the Web interfaces because they prompt me for my Apple or Google ID.  I can only use the Desktop or phone App.  At this point, I am afraid to logout of my Desktop app for fear of not being able to get back in.

I also tried the web interface that offered two options, an Apple ID and a Google ID.  I tried logging in with my Google ID, but Google asks me to create a new account.  If I don't create an account, this method does not connect me to my data.  I am getting very nervous about the safety of my data and my ability to access it.

Please tell me now I can access profile, and how I might be able to set my password.

Link to comment

I have the exact same problem. I think the reason may be that I used a Gmail address to sign up, but I did not do it via Google sign-in, rather using the classic email + password method. (This was ages ago)

In any case, I'm now stuck: I need to update my two-factor method as per Evernote's "ACTION REQUIRED" email, but I'm unable to get to the security page of my profile to do so. Catch 22. 🤷‍♂️

Any ideas much appreciated! Otherwise, I think it will be time for me to bid adieu to Evernote. 😢

Link to comment

Unfortunately, I'm a free user and can't even log a request without paying 😅

If I can't resolve this, I think my only move is to migrate somewhere else before I get locked out of my own account due to not being able to change the 2FA 😳 🤷‍♂️

I would much prefer to stay a loyal (but free 😉) user, so if you can hear me, Evernote Support Team, I would appreciate a few minutes of your time.

[Activates bat-signal] 


Link to comment
  • Level 5*
1 hour ago, Boomshak said:

if you can hear me, Evernote Support Team

Hi.  They can't - we're mostly other users here.  You're using a free service where the rules are pretty tight on connected devices,  which is part of your issue.  Use the link quoted by @agsteele above to raise a ticket on this - or if you can,  try subscribing for a month.  That'll both give you priority access to support and remove any device limit at the same time.

Edit:  oops... forgot Understanding the device limit

Link to comment
  • Evernote Expert
3 hours ago, Boomshak said:

Unfortunately, I'm a free user and can't even log a request without paying 😅

The guest link I provided will let you submit an Account related issue such as inability to sign in.

Link to comment
  • 2 weeks later...

I had same issue today and submitted a ticket.  

Unfortunate that Evernote wants us to upgrade security settings and doesn't offer an easy way to do that for some of us, so will now receive a bunch of support tickets.

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...