Jump to content
  • 0

Encrypted notes get extra line breaks added (v. 1.9.0)



15 replies to this idea

Recommended Posts

I've noted that as well. A work around is to put some plain text in the note and only encrypt parts. That seems to solve the adding of extra line breaks each time you decrypt a note.

Doing that doesn't work at all for me... Using encryption is seriously broke.

It looks like part of the problem is the text editor in the Mac version - it's seriously broken as well.

Link to comment

I also get this problem. Sometimes when I open an encrypted note... a LOT of empty lines appear between the paragraphs.

Encryption really needs to be seriously rethought. I would like to:

- have this added lines bug solved

- be able to encrypt a note (not just parts of the text)

- be able to encrypt a notebook

If someone from Evernote reads this please give us a status on these issues.



Link to comment

Hi Dave,

Thanks for the quick reply. Do you have plans to add functionality to encrypt a note or the whole notebook? I'd say that's the most useful way to implement encryption in Evernote. At least the way I use it.



Link to comment

You can use OS X to encrypt your Home directory to encrypt your local database files. Evernote's service includes a set of features that are not compatible with "whole notebook" encryption at the service level. (E.g. image processing, search, mobile clients, web access to notes, etc.)

Link to comment

Well, I'd say at least the at note level could be done this way:

- sacrifice image search (or even image use) on encrypted notes

- ask for the decrypting password both on the web and on the mobile devices

And the "whole notebook" encryption could be implemented as a normal notebook in which all notes are individually encrypted as above. They could still be individually synchronized but would always need a password in order to be seen. And the image search would be impossible and that would be a reasonable trade-off for such an important feature.

Maybe I'm being simplistic since I don't know the real internal technical challenges involved but I really think this is a critical issue. Today there are things I keep out of Evernote just because of this. My personal diary and my health log for example.



Link to comment

I feel your pain -- I went through an extended interaction with the Evernote support folks on this several months ago -- trying out different pre-release versions with different pieces of text and different settings.  No luck; it finally got declared an official bug, and I was told it might be addressed in the future.  So far, it seems to be less important than getting their lines of t-shirts and socks up and running (https://www.evernote.com/market/feature/socks?sku=SOCK00106).  I'd like to think they'll get this fixed someday, but I'm not holding my breath.

Link to comment

For the benefit of anyone else who stumbles onto this thread, I did see a workaround for this bug, posted a few years (!!) ago:



It worked for me. Obviously not ideal but it beats the heck out of laboriously deleting all those extra lines every time..


The evernote editor itself is just SO flaky!! I know Editors are hard to get right, especially cross-platform; we all have expectations of how they should work, and we use products all day that do it right.. so when you encounter odd flakiness like this, it really jumps out (and irritates!). I would abandon this thing entirely but I've built up a dependency on it and it will be hard to kick the habit.


Another weirdness with encrypted text: If you are at the end of the encrypted block, and start hitting Return (aka Enter) to add lines, it seems to insert a table!

Link to comment


This topic is now archived and is closed to further replies.

  • Create New...