Jump to content
GrumpyMonkey

(Archived) Evernote for Mac -- UI Elements Unresponsive

Recommended Posts

App Locking Up

I've had problems recently with the Evernote app locking up on my Mac (2013 Macbook Air / 10.8.4 / Evernote Version 5.2.1 (401587)). Sometimes, when I try to clear a search, nothing happens. Sometimes, when I try a new search, nothing happens. And, sometimes, when I try to open a notebook, nothing happens. The screencast below shows me double clicking and trying to open notebooks without success. The only solution is to quit the app and start again. I often have to do this several times a day, and (subject to Murphy's Law) this often happens at the most inopportune times, when I cannot afford to spend time doing this.

Ideally, I would like to be able to click UI elements and have it respond immediately. I just reduced the size of my database considerably (I deleted about 3/4 of the size; half the notes) to try and overcome the lag and other issues, but it is still lagging and things are not working properly, so I don't think it is the large database size this time causing problems.

I have uninstalled / reinstalled several times. Is there anything else anyone can recommend?

https://www.evernote.com/shard/s74/sh/624f63db-3d73-4130-8ad3-3005f20b51a3/f35f311c890a63a1133d42d526521d98

  • Like 1

Share this post


Link to post

GM, thanks for sharing this issue.

 

I have been running EN Mac V3 on my main Mac, and EN Mac V5 on my test Mac.

I was getting very close to upgrading my main Mac when I saw your post.

 

Sadly, it looks like EN Mac V5 is STILL not ready for prime time.

 

EN Mac V3 is working great -- no real issues (except the on-going Search issues).

But I would really like to have the highlighter and Reminders features.

 

But, these new features are NOT worth losing basic capability, even if it is occasional.

Like you say, Murphy's Law is always hard at work.  :-)

Share this post


Link to post

GM, thanks for sharing this issue.

 

I have been running EN Mac V3 on my main Mac, and EN Mac V5 on my test Mac.

I was getting very close to upgrading my main Mac when I saw your post.

 

Sadly, it looks like EN Mac V5 is STILL not ready for prime time.

 

EN Mac V3 is working great -- no real issues (except the on-going Search issues).

But I would really like to have the highlighter and Reminders features.

 

But, these new features are NOT worth losing basic capability, even if it is occasional.

Like you say, Murphy's Law is always hard at work.  :-)

I don't think I would go back to V3, because the slower incremental search alone would dissuade me from taking that trip down memory lane. I don't know if my issue is widespread, so I am not sure my post should keep you from upgrading! It would be interesting to hear from others, especially if they have a solution. The search (not being able to clear it, the search not working in the search field, and old searches apparently still filtering even when they are not showing) is really the most difficult issue for me at the moment. It is connected to this unresponsiveness (I think), but the more data we gather, the easier it will be to find a solution. Right now, I'd settle for a workaround.

Share this post


Link to post

I don't think I would go back to V3, because the slower incremental search alone would dissuade me from taking that trip down memory lane. I don't know if my issue is widespread, so I am not sure my post should keep you from upgrading! It would be interesting to hear from others, especially if they have a solution. The search (not being able to clear it, the search not working in the search field, and old searches apparently still filtering even when they are not showing) is really the most difficult issue for me at the moment. It is connected to this unresponsiveness (I think), but the more data we gather, the easier it will be to find a solution. Right now, I'd settle for a workaround.

 

GM, looks like to me you have greater issues with V5 Search than with V3.

 

I make good use of Saved Searches, and Tag Searches (using the drop-down), so this minimizes the impact of the Incremental Search fiasco (what a bad idea!).

 

IAC, I'll wait to see what others post, but I have NO compelling reason to upgrade to EN Mac V5 at this time.

Share this post


Link to post
The search (not being able to clear it, the search not working in the search field, and old searches apparently still filtering even when they are not showing) is really the most difficult issue for me at the moment.

 

FWIW, I have seen all the search problems you describe above, I think since v5 came out.  No easy solution, except now I am programmed to press a few backspaces in the search field all the time, or press the "All notes" button before typing in my search term.

  • Like 1

Share this post


Link to post

The search (not being able to clear it, the search not working in the search field, and old searches apparently still filtering even when they are not showing) is really the most difficult issue for me at the moment.

FWIW, I have seen all the search problems you describe above, I think since v5 came out. No easy solution, except now I am programmed to press a few backspaces in the search field all the time, or press the "All notes" button before typing in my search term.

Glad to hear I am not the only one! A typical workflow for me is to search, start editing the note, have the note field go blank and a 0 notes show up in the center panel, try to search again to find my note, still have 0 notes, hit clear, nothing happens, force the app to quit, open, go to last updated, find my note, and continue editing.

This is a process I go through many times a day. Whenever anything is in the search field it seems to wreak havoc, and because my usage is pretty much built around searching, I am especially vulnerable to this bug. I have been reporting it since v5 came out as well, but it does seem that different versions introduce variations on the theme. It's weird, but no one else seems to complain about it. Are they not using search?

I have deleted all of my notes and worked with only a handful of them, but I find the same result, so I don't think it is the content of my account or database size causing it. I have tried using my notes in a different account, but run into the same problems there. I've tried relying on saved searches, but those don't work either. It is a complete mystery to me.

If you are encountering this kind of issue, one workaround is to use Spotlight for searching. You can avoid some of the pain, though there are lots of limitations to this as well, because you are working from outside the app.

Share this post


Link to post

The search showing 0 results issue should be fixed in our next beta. 

 

We hope to address general unresponsiveness very soon. The changes we are planning will make v5 *much* faster than the v3 client (even though syncing is already faster in v5 :) ).

  • Like 1

Share this post


Link to post
Guest
This topic is now closed to further replies.

×
×
  • Create New...