Jump to content
orionmd

Error 798: Discarding changes on notes

Recommended Posts

I did search for the issue, but didn't seem to find a post for this specific error.
It happens both on online notebooks and local notebooks, when I add a hyperlink to a file pointing to a smb share \\ 
And because of this error, discards the entirety of the last changes in the note when I switch to another note.
I would need to have those in my notes cause they refer to some processes that I'm using.
Could you guys confirm if there is a fix or workaround for the error?
I'm using Evernote version 6.19.2.8555 (308555) Public (CE Build ce-62.3.7750) on Windows 10 Version 1803.
 
Log:
13:22:54 [ERROR ] [15640] [11276] Note 798 ENML Validation error: Element "a", attribute "href", URL "%5C%5Csjkfs13%5CIT_OEM_INTEL%5CUtilitarios%5CTreeSize%20Professional" error: has invalid value
13:22:54 [ERROR ] [15640] [11276] Can't save note uid=798, error: CantConvertNoteContent
 
Thanks.

Share this post


Link to post
On 7/3/2019 at 12:32 PM, orionmd said:
I did search for the issue, but didn't seem to find a post for this specific error.
It happens both on online notebooks and local notebooks, when I add a hyperlink to a file pointing to a smb share \\ 
And because of this error, discards the entirety of the last changes in the note when I switch to another note.
I would need to have those in my notes cause they refer to some processes that I'm using.
Could you guys confirm if there is a fix or workaround for the error?
I'm using Evernote version 6.19.2.8555 (308555) Public (CE Build ce-62.3.7750) on Windows 10 Version 1803.
 
Log:
13:22:54 [ERROR ] [15640] [11276] Note 798 ENML Validation error: Element "a", attribute "href", URL "%5C%5Csjkfs13%5CIT_OEM_INTEL%5CUtilitarios%5CTreeSize%20Professional" error: has invalid value
13:22:54 [ERROR ] [15640] [11276] Can't save note uid=798, error: CantConvertNoteContent
 
Thanks.

ENML is the format that Evernote keeps its notes in; it's an XHTML derivative. See https://dev.evernote.com/doc/articles/enml.php for more info. Evidently your SMB link violates the Evernote validation rules (or the implementation has a bug); and if it doesn't validate, then it can't sync. Don't know of any workaround, but I'll maybe try to check it out later on.

Edit: Maybe if you post a sample URL that fails (or something like it), it'll make it easier to test out

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...