Jump to content

Note version stepping back in time

Recommended Posts

Hi, I have an issue where I'm seeing notes revert back to a previous version. Sequence of events:


I edit a note, everything appears normal.

Some time later I return to the note, and find that my changes have disappeared.

I check the note history and find that my edits are in the 'older version' not the current version. 

I can them import the older version, delete the current one and continue.


This is happening on the one laptop, not when changing between computers. However if I check on other devices I am finding the same note status.


I've seen this issue on at least a half a dozen notes. On one occasion (that I've found!) I lost all my edits, and they weren't in the history either, so that data was lost entirely.


I lodged a support ticket a week ago, then provided my activity logs, and a follow up email and have had no response (other than the automated one). 


Ticket number: 1052130 

Link to comment
  • Level 5*

Hi.  Certainly odd.  Subject to the usual caveats about backups,  Local Notebooks and unsynced notes you could try uninstalling and reinstalling the app on the laptop.  Do you have Evernote open on any other device?  If the 'old' note is automatically synced to the system with an updated status date while you're making your changes to the note elsewhere,  your changes could be seen as an old version and filed accordingly.  You could try syncing manually before you edit and often during the process,  to keep your version of the note as the most recently changed...  Not sure how Evernote can guard against this sort of thing - if you are logged in twice,  there's no way to tell which input is a 'real' change,  and which is an automatic sync.

Link to comment

Just a thought:  on your laptop, do you have the correct time AND timezone set?  Also, not that one should have to, but I find it's a good practice to do a manual synchronization every time I'm finished with a note.   (Either hit F9, click on the synch icon, or select "Sync" from the "Tools" menu.)

Link to comment

Thanks for taking the time to reply guys, much appreciated.


I've checked the time and time-zone and both look to be in order there. I often leave my PC at home on with Evernote open so yes both could be syncing at the same time. Maybe I'll try leaving it off and only having one of the windows apps open at a time (ie my desktop OR my laptop.


Usually this happens it is when I'm out and about on the laptop. The changes to the note must be syncing ok, as they are mostly making it into the cloud where EN makes it's backups and history. The problem is that an older version is being displayed as the current version, so as you both suggest it must be a update time-stamp type issue I guess.


What annoys me most is that I've logged a support ticket and sent my activity logs and have received no response from support. I'm a premium member (have been for years), and it seems the only way to reach them is through a web form and they aren't responding. Any ideas on that front?




Link to comment
  • Level 5*

I flagged your post for a forum admin to have a look at.  'Normal Service' should be an immediate acknowledgement,  which clearly you had,  and a follow up in around 5 working days.  (Evernote support get the weekends off...).  You might be at the point of getting a reply anyway,  but hopefully we can get a check that it didn't fall through any cracks...

Link to comment

I've just experienced this issue again. This time, I can rule out my desktop PC, it is switched off at home.


This morning I was editing a note, including three documents included in it as attachments. I've been diligently syncing my data regularly including just before I packed up for lunch.


Put my computer to sleep for lunch, after coming back from lunch, waking it up, I find all my work gone! again.


Look in the history and sure enough there it is as the most recent historical version. I restore the note, open the attachments and ALL MY WORK ISN'T THERE! 


Luckily I've fished out of the evernote attachments local directory in Windows a .backup file that contains the entire document, but this really shakes my confidence in the product. I'm also finding a lot of my to-do check boxes are ticking themselves randomly as well.


Lastly and probably most importantly, it has now been 9 days since I first reported this issue and I still haven't had a response from support.

Link to comment

Time to rule another thing out. I've just been working this last couple of hours on my laptop. I made edits to the note mentioned above to put back in the content I'd lost. Evernote has however synced after I've made these changes, and again reverted to the old version of the note wiping out my changes once again. This time, I haven't been away from my computer, it hasn't been to sleep, no notes have been opened on any of my other devices, nothing. Just working in this one place continually.

Link to comment
  • Level 5*

Hopefully not an insulting question, but any chance of multiple copies of the note in your data base, different notebooks or whatever?  And this is a note in a notebook that is yours only? 


Hard to imagine what in EN world would cause the server to keep force feeding a note back to you.  I assume (ouch) EN would normalize the note time to PC time across the devices so one bad time shouldn't mess things up.

Link to comment

Yes no change it is duplicate notes. I can see my edits right there in the history of the note, so I know they are making it to the EN servers. Clearly there is something else telling the EN server that an older version is more current so it is stepping ahead of the real current note. Yesterday I bit the bullet and remove Evernote from my laptop, and clear the whole database. I reinstalled and it is nearly finished downloading my note database again (11GB!). I'm trying not to use any evernote when it is doing this initial sync, but I've already noticed a note that has stepped back a version, so I don't think this will resolve it.


I also finally got a response from support this morning. Their solution: "Based on the errors within the activity log you sent, it looks like reinstalling Evernote on your Windows computer will help to resolve the issue you're experiencing."


Seems I'm one step ahead. Somehow I don't think this will resolve it though based on this mornings finds. Thinking more about the issue, I'm wondering if it is a time zone issue (as previously flagged). I did check all my devices are set on the same timezone and they are, but my two android devices are set to get time and date etc from the network, so maybe one of them is picking up dodgy time and date info at some points and syncing causing notes I've changed to have incorrect timestamps or something? So at the moment I've disabled this on both Android devices and I'll experiment to see if I can reproduce the issue afte the reinstall.

Link to comment
  • Level 5*

Yeah. only having one device able to sync would be a good control environment to see if you can modify a note and have it stick.


Last question, anything similar in the origins of the offending notes?  Don't know what would happen if you copied a note to a notebook and preserved date/time.  But since it is a new note it shouldn't make any difference, if you are even creating any notes that way.  Interested in what you determine.  Sorry for the pain.

Link to comment

Update on this issue, I'd been watching things carefully, Android devices on manual time settings, carefully syncing all the time. Today at work I did my monthly review of tasks and updated a lot of notes. Tonight I open the app at home on my desktop PC and I find one of my notes has gone back to what it was on the 15th April! There are 3 newer versions of the updated note in the history, then the one shown as 'current' is from mid April.


I've reinstalled again on my desktop now as well. I really think this is a server side issue though. I've reported back to EN support, so now we wait again.

Link to comment

The saga continues. Evernote support have advised they are "going to escalate this to our technical support team for further assistance". Two days later I was asked for titles of affected notes, which is a long list, this seems a regular thing now.


Today I've done some more investigation to try nut this out.


At 12:03 I made changes to a known problem note (I noticed on the weekend on my Android phone it was checking all the tick boxes by itself).

In my edits I noted the exact date and time of the changes.

I checked that it was sync over all my devices. Windows PC, Windows Laptop, Android Tablet, Android Phone, EN web interface.

Everything was perfect.

Now 90 minutes later I find the note has changed itself.

Looking at the history, the version I made at 12:03 is in there with a timestamp of 13:06:29 as the first 'older version'

The current version complete with a random tickbox is timestamped 13:06:13 as the 'current version'


Screenshot of history attached taken from the online web application (history is shown as the same in the Windows client)


Again, bugs are one thing, but the time it is taking support to respond and sort this out is poor, that is what has me most annoyed about it all.

The website says :

Contact Us - Live chat and email assistance are available for Evernote Premium, Business, and Market customers. Contact us for support.


Email support that has been going for 11 days now for something so fundamental is hardly 'premium'


Link to comment
  • 4 weeks later...

Thought I would come back and close the loop on this thread. Evernote eventually on the 3rd June said "The developers may have found the cause of the note issue and are currently working on it." 


Since then, every time I noticed a dodgy note, I imported the old version and deleted the current one, therefore basically starting a new note. It seems to have settled down however I did have it happen again overnight with something I worked on yesterday. Hopefully I've found all the corrupt notes and this issue is behind me.


I'm no wiser as to what caused the issue, and I'm still gobsmacked by how slow the responses were. Anyway hopefully 'case closed' (well EN think so anyway, they closed the ticket on the 9th June!)

Link to comment
  • 1 month later...


I think I have found the culprit in all this. I also have an Android smartwatch paired to my phone and had the Evernote for Android wear app installed. I got this watch (a Sony Smartwatch 3) about two weeks before I first reported the issues to evernote, so the timing makes sense now I look back on it. 

I spent some time looking through logs etc myself last night and worked out that my phone seemed to be updating notes even when I wasn't using it. On running a few more tests, I had my phone sitting open with the most recent notes displayed; I opened the Evernote app on my watch and simply hit 'recent notes' and boom 6 notes all jumped to the top as 'updated'. One of the notes had extra checkboxes marked that I hadn't done. A minute later that same note then had another 'update' and all the checkboxes were checked, all without me doing anything. This would explain how random this appeared to be, as my watch is on me all the time, hence the notes changing even when I wasn't using EN on a Windows or Android phone or tablet. I've often found that my watch will show me the most recent note I've been working on, at times it gives me random notes for no reason, and other times it gives me blank notes. Clearly the wear app isn't playing nicely.
I've removed the app from my watch, and I'll watch (no pun intended) my notes carefully to see if I see if I see any more funny business. I've reported the same back to Evernote who have been continuing to look at this issue these past 3 months. Hopefully case closed.
Link to comment


This topic is now archived and is closed to further replies.

  • Create New...