Jump to content

EN cannot open Database after hard drive crash

Recommended Posts



Windows 7. Hard drive died and replaced. Reinstalled EN then replaced the existing db with my old one (from backup). Both have the same name. Most notes are local (not synced). When EN is re-opened I get a pop-up:


Could not open Evernote database in "C\path to db\db.exb".


Please verify that the path is accessible and try again.


I have uninstalled and reinstalled many times but no joy.


Have I done this wrong? Any help appreciated.

Link to comment
  • Level 5*

Hi - more information required I think:  when you replaced the existing exb file with your old one - did you leave the other contents of the databases folder unchanged?  Or did you copy across the whole folder?  What's the actual path (less user name) to the database file?


It is possible to reinstall a large database by copying the database over - did it myself with nearly 19,000 records recently.  Not sure exactly what detail is going wrong here,  but I think the good old fashioned power switch boogie is required again.

  • Exit Evernote and uninstall.  Recycle power.
  • Reinstall Evernote and log in to your account.  Allow the server to create the account structure.
  • Exit Evernote again and rename the new exb file to something else,  then replace it with your old one.
  • (If you have the complete folder,  rename and replace the whole folder.)
Link to comment

Thanks for the help. I ran your steps, but it gives the error



Please verify that the path is accessible and try again.


I have tried with a recovered db file from the crashed drive and also a file from my backups, still no go.


So, I think it is a dead duck. Thanks for trying, very appreciated.

Link to comment
  • Level 5*

I'm very sorry to hear that.  I suggest a support request /feedback to Evernote so they're aware,  though you'll know that if you are a free user you are last in any priority.  If you're a premium user (and you could become premium for a month if you wanted...) you can use the chat option for a quicker response.  Even so I don't know what help they may be able to be with unsynced content.  Check in Help > Activities Log to see if anything useful shows up there.

Link to comment
  • 3 months later...


You weren't able to retrieve your local notebooks?

I'm facing same issue and I have one notebook which is a local notebook. I haven't done anything yet because I want to be sure I don't mess anything up.

Please help me out.

Link to comment
  • Level 5*


You weren't able to retrieve your local notebooks?


I'm facing same issue and I have one notebook which is a local notebook. I haven't done anything yet because I want to be sure I don't mess anything up.

Please help me out.


What happened to your original set-up,  and what happens now when you run Evernote?

Link to comment

Windows Crashed and on opening Evernote I get the error message:


Could not open Evernote database 


Please verify the path is accessible and try again


I had some local notebooks in the database so I don't want to delete everything and sync from server.

I have upgraded to Premium for this very issue for a month and raised a ticket Ticket# 935555

I have sent 2 emails to Support.

But no human response. Only got an automated response the first time.


I'm just trying to manage by using the WebApp  and Android app which aren't as functional as I would like.



Link to comment
  • Level 5*

You should have access to the Chat option (weekdays,  PST) to get hold of Support - they're busy,  so emails probably won't help much.


AFAIK the Can't Create Table error probably indicates a corrupted SQL database,  so your local notes may not be recoverable unless you have a backup somewhere.  If you rename the current database folder* you'll get a 'working' EN back,  minus those notes if you want to do that ahead of trying to restore the database.


* Rename database folder

Your database should be at C:\Users\<user>\AppData\Local\Evernote\Evernote\Databases

  1. Exit Evernote - File Exit
  2. Rename folder (F2) to databases.old
  3. Restart Evernote

Wait while folder is rebuilt.


Possible database fix

  • Use above process to rename the new folder to Databases.new and
  • Rename old folder back to Databases
  • Restart Evernote

If that crashes again,  rename -

  • Databases > Databases.old
  • Databases.new > Databases

You should be back to normal operations again,  though without the local notebooks.  If you can use a SQL editor you would be able to see the data in your old database,  but whether it will be in any useful form depends on the content and your requirements.  Attachments and pictures would probably not be available.

Link to comment
  • 2 years later...

I had the same problem and just fixed it so I thought I would share for anyone who references this issue in the future. I also had recently re-installed Windows 7 when my error started occurring. My solution will not help you retrieve unsynced data but if you are having the above problem, this will restore your last synced version of Evernote and allow you the program back at least.

Make sure you have exited Evernote and that it's background processes are turned off (for maximum efficacy). 

Go to the database folder: C:/Users/"yourname"/Evernote/Databases

Delete all files related to the account you are trying to access (they will have your username as the first word in the filename). 

Restart Evernote. It will ask for your password. Enter password and it should begin to download all files associated with the account, including the proper database file that you are needing. You should no longer have a problem logging in.

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...