Jump to content

(Archived) (Archived) Database Read/Write error


msbentley

Recommended Posts

[Edit]

Hi all,

I'm having this error more or less consistently on two devices now (one phone, one tablet) with the latest preview version (3.2.1 Beta 3). EN runs fine when I first boot the phone, but after a while I get periodic errors:

"Database Read/Write Error. Evernote is not able to open the database file.

android.database.sqlite.SQLiteDiskIOException: disk I/O error"

I have already sent a log from one device, but thought I should also flag it here. I can't see any obvious problems - the SD card is mounted, and Evernote directory accessible, etc. If anyone has suggestions, or wants me to dig out further information, please let me know!

Regards, Mark

Link to comment

I'ver been having exactly the same issue on my HTC Desire running CM7 since the latest Evernote update. Occasionally it works for a bit, but then the error comes back again. Tried uninstalling, clearing data, reinstalling, unmounting and remounting SD card... nothing consistently resolves it. Since there are no issues with other apps it looks pretty much certain this is a bug in the Evernote app itself.

I haven't bothered emailing support as I know I'll only get the stock, unhelpful answers like 'send a log file, restart the phone, reinstall the app, try the latest beta etc!

It's pretty annoying though as it renders one of the most-used and most useful apps on my phone pretty much useless 90% of the time :(

Link to comment

Interesting - I was wondering if CM7 was perhaps the common thread, since both of my devices are running it (albeit it different versions). Previous versions worked fine, but I just tried both the current market version (locked up my entire phone) and the latest beta (same read/write error)...

Anyone else had this error?

Link to comment

Hi! I've also had this issue (I believe), using the latest version of Evernote from the Market and version 2.2 of Android. I think it's this same error, because it happens after ~40min of note taking. It seems to be trying to sync, even though I set it to never do background syncing, and it uses 100% of my phone's cpu, locking it up and forcing me to restart it, or sometimes even remove the battery, because it won't respond. Also, during one of these events, I lost all the content of the note I was taking, even when I had uploaded it several times in that hour. I'm sorry if it's not the same problem, but if it is, does someone know of a solution for this?

Thanks!

Link to comment
  • 1 month later...

This may be unrelated...I get a similar error on HTC Desire running CM7 after installing for first time. It happens consistently on startup before application has opened saying it can't create the database file. Plenty of space available.

Is there a way to get a previous version of the Android App?

Thanks

Link to comment
  • 3 months later...

Also started getting this error message - Database Read/Write Error android.database.sqlite.SQLiteException: unable to open database file

Checked SD card - plenty of room

Restarted phone (HTC Desire S)

Remounted SD card

Uninstalled and re-installed app

Really irritating as I use Evernote a lot for business while on the move and am now faced with moving everything into Springpad

Has anyone found a solution to this problem. If so I'd be very grateful.

Thanks

Link to comment
  • 1 month later...

Any progress on this issue. I have had the identical problem described, and seemed to coincide with installing CM7 on my EVO. Unfortunately I am very reluctant to give up either CM7 or Evernote on my phone. Hopefully there is a fix? Thanks.

Link to comment

Hi, I have a Verizon Galaxy Nexus and just updated to the latest stock OS (Android 4.0.4 IMM76K) by unlocking my bootloader (but no root). I am getting the error despite it being a stock OS. None of my other apps are broken. Help!

Link to comment
  • 4 weeks later...
  • 1 month later...

Today while trying to use evernote on my tablet, I got the following error:

"Database Read/Write error

Evernote is not able to create the database file. If the problem persists then please restart your phone and make sure that the sdcard is not full.

android.database.sqlite.SQLiteCantOpenDatabaseException:unable to open database file"

I restarted the tablet, and i deleted some unnecessary files from the sdcard folder - now it says there are 763 mb available, but still I can not get evernote to run.....has anyone had this happen to them before?

Link to comment
  • 1 month later...
  • 3 weeks later...
  • 1 month later...
  • 1 month later...

I started getting this error about 3 days ago.

I am running Evernote on CM7.

It was working fine for over 10 days since I installed CM7 before the issue occurred.

I am wondering if it is related to a recent Evernote update.

As I do not have a backup of the previous Evernote app APK, I am unable to verify this. It wil be useful if we can get a previous version to try out.

I have done multiple re-installations of Evertnote, and also removal of the Evernote folder from my SD card. Not making any difference.

After a clean-up like this, Evernote will attempt to re-sync headers, thumbnails, etc. At some point, it will fail to sync, and from then on, it does not show any note or notebook (as if the install is brand new with zero data). After that, the database error will start popping up.

Link to comment

Hallo, i had the same issue running CM10 on my tablet. My solution: i have fixed permissions for the whole evernote folder (data/media/evernote) and the subfolders. Write permission was unchecked, so i checked it everywhere. After then i started evernote and it finally worked. The issue is i thing that evernote needs not only read the data in this folder but even write. And there is no write permission for the evernote folder, so thats why it isnt probably working.

Hope this will work for you

Link to comment

Thanks for the suggestion!

Checked folder permissions. Read/Write enabled. So no issue there.

The issue has continued recurring. I suspect it may be related to the Evernote app's connection to the server.

I usually get around it by force stopping Evernote (in the Android Applications settings), and then rebooting the tablet.

Annoying to have to do this. But seems to work so far.

Link to comment
  • 8 months later...
  • 4 months later...

Using Sony Xperia J6. Was using Evernote without issues until last week. Now I'm getting:

 

"Database Read/Write Error.

Evernote is not able to open the database file. If the problem persists then please restart your device and make sure that the memory card is mounted properly.

android.database.sqlite.

SQLiteException: Can't downgrade database from version 75 to 53"

 

This is a pain. Can anyone help resolve this?

Link to comment

Archived

This topic is now archived and is closed to further replies.

Guest
This topic is now closed to further replies.
×
×
  • Create New...