Jump to content

v10.86.8 possible bug with Tasks

Recommended Posts

I am not sure if there is any point in continuing to post bug reports here or sending them via the support ticket system, I'll continue doing so in the hope that someone from BS someday reads them.

Today the macOS client was once again updated (we all know we are in a constant update cycle nowadays). This time it was to v10.86.8.

The release notes say a "new task section for enhanced organization and efficiency" now exists. This sounds cool, especially because I have started using tasks in EN more in the last few months.

I immediately checked this new Task section on Mac and it looks great. I went inside one of my notes and inserted a new task at the start of the note, then I went back to the Tasks section. To my surprise, the task there didn't show the correct text, EN just took the existing text from the next line on the note and inserted it as the task text. If I go into the note I can still see the original text I used for the task, but the Tasks section shows an incorrect text.

I then deleted the task from the Tasks section and created it again inside the note, this time in another part of the note's body (not at the start). The crazy thing is that in the Tasks section EN again changed the text to the incorrect one it had chosen for the task I had previously deleted.

I repeated the last action several times deleting the task and creating it again, but EN always changed the text on the Tasks section.

In the end, the only thing I could do to solve the issue with this particular task was to create it inside the note, copy the text, go to the Tasks section, and change the text there pasting what I had copied. Twice the work.

Both task creation and display under the previous Tasks section have been very reliable until this new update.

I hope this is just a small glitch and not a generalized bug introduced to the Tasks module.

Anyone else have detected something like this?

Link to comment
  • Level 5*

Dunno about Evernote but I got confused by your intensive round of "change the task details".  I just tried setting up some test tasks in the new version and mine worked perfectly.  (Windows,  though..)

Maybe the update or your database got corrupted,  but I'd suggest a system restart and if that doesn't fix things try deleting your current database and starting over...

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...