Jump to content

macOS export fails with "a problem'' about half way through export of 6000 notes

Recommended Posts

There's no indication of what went wrong.  Export fails for both .enex and 'multiple web ages' formats. It also fails when offline (export without attachments) - at roughly the same percentage completion.

If I knew the order in which notes were exported, I might be able to isolate a bad note - I know it's not creation order.  With over 6000 notes and a 100 note selection limit, it's infeasible to partition the notebook export.

Any suggestion welcome.  As a side note: offline export does not export attachments, but it does run two orders of magnitude faster than online export - that may help somebody else shoot some other problem.

MacBook Pro Sonoma 14.0 with Evernote 10.70.2

Error Message:

Failed to Export Notes

There was a problem and we couldn't export your notes. Please try again.

Link to comment
  • Level 5*

Hi.  You're correct that the usual issue is a corrupted note.  Moving 6000 notes into smaller notebooks in 100-shot batches is annoying,  but on a desktop it is doable with repeated find / select all / move commands,  and if you split the big notebook into smaller pieces and check each piece,  once you've found the batch with the errored note it should be safe to try the rest in one go.  All the ENEX files can be imported back together later.

Support seems to have its act a little more together now,  so they may also be an option...  as you may know we're mostly other users here.

Link to comment

Hi gazumped,

I continue to be amazed by your positive attitude.  

An article by the Verge suggests using the legacy version of Evernote for Mac to export more than 100 notes at a time.  In your experience, does that trick work these days?   Obviously, I don't want to make my problem worse with some ill-advised fix. (https://www.theverge.com/23462732/evernote-export-notebook-how-to)

Thanks for your initial suggestion.  I am a little wary of creating some other problem if I try to split out small chunks, but maybe I'll give it a try. 

Link to comment
  • Level 5*
28 minutes ago, skkippy said:

your positive attitude

Thanks - I have worked for a succession of bosses whose only interest was "are you finished?" (with their job of choice).  It was never,  ever an option to say 'my software/ hardware failed;  my dog ate my homework;  I've been feeling a little poorly lately...  Even if I had to write something by hand,  the only option was (and still is) to keep on plugging away until the job is done.  Failure (as they say) is never an option....  y'might as well be cheerful while it happens!  :D

Our friends in the Verge seem to be suggesting (in a post originally written 5 years ago) you use something from the internet Archive to install the Legacy version.  We're currently getting lots of complaints that Legacy is no longer working for many users...  I wouldn't rely on that as a work-around.

  • Like 1
Link to comment

This may help others....

In an attempt to isolate the export problem, I created about 60 tags and attached each one to no more than 100 notes. I then selected notes using the new tags, one by one, and exported.  Of the roughly 60 exports, one failed with 'There was a problem...' BUT when i repeated the export, twice, it worked both times.

So I conclude the original failure was not an un-exportable note, but some other problem. I suppose the 'Please try again' suggestion in the Evernote error message might work - and for modest note volumes be practical.  (My two online attempts to export the full notebook of 6000 notes ran for over an hour before failing)

Later, for the hell of it, I re-tried the original 6000 note export and it succeeded, so the error was transient.

  • Like 1
Link to comment

I am having the same issue as skkippy when attempting to export a notebook with 707 notes.

I am running MacBook Pro Sonoma 14.1.2 and Evernote v10.71.2

First of all, there should be some feedback to the user on what exactly failed.  

So I tried the method of exporting 100 notes at a time.  All successful except for the fifth batch.  I exported the failed batch in smaller chunks - the first 50 notes, then 25 of remaining, then 12 of remaining, then the last 13 and all were successful.  No notes were opened/edited - only selected for export then moved to trash after successful export.

I did successfully export two other notebooks prior to this one, but they were smaller - less than 100 notes each.


Hope this helps.

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...