Jump to content

Old deleted notes are blank and I can't remove them

Recommended Posts

Often times when I use Evernote between my phone and my desktop the note in question will be duplicated once, if not many times. This is annoying and even more so because when I try to delete the duplicated note it often just leaves a blank page in my list of notes that I can't remove. See the attached photo. I can't do anything to that blank note. Does anyone know why this is happening or have any ideas on how to get rid of these blank notes that are cluttering my Evernote app? 


Link to comment
  • Level 5

Probably your local database on the Windows client got corrupted by all the duplication and deleting action. To rebuild it from the server you can use this procedure:

  1. Go to File > Sign Out [name] from the menu bar.
  2. Select the "Remove my Evernote data from this device" option, then click Sign out.
  3. Restart your computer.
  4. Sign back in to Evernote. Keep the app open while it downloads your notes from the server.
Link to comment

As a loyal user of Evernote, I deleted notes in the web-app, then re-started Evernote Mac and its still giving me the green swirling icon of death.  To now go back and require to remove trash, cache and re-load Evernote completely seems total overkill.

Seriously cannot just find the old notes in local cache, determine they were already deleted from the online database and purge them? Or at least offer the ability to move them or delete them manually?

This is sledge-hammer approach, and not something that should be required of an application that is literally designed to keep multiple copies of its application updated from the online site.

"Keep the app open while it downloads your notes from the server." right. So I have a decade of files, spanning gigs and gigs of data. For something as simple as syncing cache, this is dumb.   Please present a better option to delete local cache.

Edited by Sean Ackley
another thought
Link to comment
  • Level 5

What do you mean the procedure I posted does ?

Exactly, rebuild the local database. If it is a large database, it will take a while until you got it all back on your disk.

Don‘t like it ? Don’t use it, nobody forces you. Watch the beach ball spinning, think about the great hours on the beach, why not.

You came her for advise, you got it. If you want something official, ask support. If you don’t like what you get here, you could skip the forum and always ask support right away, if I think about it. We in the forum are other users, helping you pro bono. Thanks for nothing.

Link to comment
  • 1 year later...

I was having the same issue, I searched for a solution and found this post.   I followed the process defined by PinkElephant and it worked perfectly.  I had no intention of adding a comment until I read the responses from those PinkElephant tried to help.   

PinkElephant, your response was perfect and succinct.  I get that everyone wants all software to work perfectly but why do they crucify those with no control over the issue - the preverbal "kill the messenger"?   You are taking time out of your day, and at no cost, to help the community.   I just wanted to express my appreciation.  You solution worked.   Thanks


Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...