Jump to content

EN v10.33 windows desktop still very glitchy.

Go to solution Solved by PinkElephant,

Recommended Posts

I've been using the legacy version for windows as well as the IOS latest version on my iphone and they both work just fine.  However, v10 for windows is simply unusable.  I'm looking at it now and I see about 30 notes in my inbox that I specifically deleted an hour ago.  All my other devices running EN are correctly displaying my inbox has having a total of 11 notes; however, windows desktop v10 is showing 41.  Since you can't sync this version I tried quitting and signing out  (still not sure what the difference is but I did both).  I then waited at least 20 minutes and then signed back on again but I still see the deleted notes.  Also, I tried to access a notebook in destop v10 and it just hangs for 10 minutes ie: I can't see the notes on the side panel.  The legacy and iphone load the notebook notes immediately.  For now I can use Legacy and iphone but there is no way I could rely on Windows desktop v10 if those other options didn't exist.  It may be OK for the casual user who is storing a few recipes and some fun notes and clippings; it is not usable for someone trying to run a business or home finances on it.  

Link to comment
  • Level 5
  • Solution

You can't sync that version: Wrong

Hold down the ctrl key (I think so, maybe it is alt/opt) before clicking on the Help menu. There will be a new option "troubleshooting", inside of it the first 2 options are "Reload" and "Force Reload". Imagine what their purpose may be ... ?

You are probably in need of some troubleshooting as well. It looks as if your local Windows database took a hit somewhere down the road. You can fix it following this procedure:

  1. Go to File > Sign Out [name] from the menu bar.
  2. Select the "Remove my Evernote data from this device" option, then click Sign out.
  3. Restart your computer.
  4. Sign back in to Evernote
This should solve the other issues you described.
Link to comment

PinkElephant.  The Reload and Force Reload did not solve the problem.  Regarding your advice to fix the local windows database, does this involve a massive erasing of the entire database with a subsequent multi-day reloading of all the data again?  Also, can doing this  mess up the functioning of EN on my other platforms (which are thankfully working OK at this point?)  Currently, I am using both EN legacy and v10 on the same windows desktop. I do this mainly to vet the various versions of v10 that come along but I actually rely on Legacy for almost everything.  Therefore, I would hate to damage Legacy in any way simply because I'm playing with v10 at the same time.  Thanks in advance for all your excellent advice, as usual.



Link to comment
  • Level 5

V10 and Legacy each maintain their own database. A rebuild of one side does not affect the other. The link between the two is the EN server in the cloud.

When there is corrupted data in the local copy, rebuilding it is the only option with v10. The bad data sets will block a proper execution.

Rebuild will download the full set from the server - which may take a little, depending on the internet connection and the devices speed.

This is not much different with legacy - just that the database correction commands could be executed on the local copy without erasing it.

I was surprised when troubleshooting a difference in note count and search results between v10 client, v10 web and legacy client how many mistakes had accumulated in the legacy database, without noticing it.

Link to comment

Thanks PE.  You probably know more about EN than the vast majority of their own employees.  Your advice is the most helpful of any forum that I have ever participated in and it is truly greatly appreciated.

  • Thanks 1
Link to comment

Just as followup, this worked very well indeed.  The trick with the holding down the Ctrl key and clicking on Help and then going to "troubleshoot" is something that I would never have discovered myself and did not see in the help sections that they provided.  I think this is pure gold.

  • Like 1
Link to comment
  • Level 5

Actually there is something similar in legacy as well. It offers additional options to rebuild the search index, clean the local database from mistakes and so on. It is as well holding ctrl (Windows) and alt/opt (Mac) before opening the help menu. 

The options are different between clients. On legacy forcing a sync was done by (if I remember it correctly) holding down these keys before clicking on the (famed) sync button.

Because the role of the local database seems to be slightly different in legacy and v10, the effect in detail is probably different. But in general it is about healing problems with the local database, if possible. The ultimate option in both cases was a complete rebuild of the local database from the EN cloud server.

Link to comment

So, actually on testing this further I realize that it still doesn't work as it should.  For example, I have a pdf that I want to get into my inbox.  I save the pdf to my "add to evernote" folder but I don't see it appearing in desktop EN v10.  I keep doing reload and forced reload over and over and I still don't see it my inbox.  It's a crucial document so at this point I'm concerned that something went wrong.  Just for kicks I decide to open Legacy and I immediately see that the pdf has arrived safely.  However, when I go back to v10 the pdf is still not there.  After several more reloads/forced reloads it grudgingly makes an appearance.   I go through this same nonsense when I send an email to evernote from Gmail ie: I don't see it appearing in v10 for quite a while.  In Legacy I simply hit sync once or twice and then I see it.  This type of behavior makes v10 difficult to use in a critical business environment with sensitive documents and emails that need to be verifiably received.  In short, reload/forced reload is not really functioning anywhere as seamlessly as "Synch" does on Legacy.  

Link to comment
  • Level 5

The import folder works locally, not through the server. On Windows there has always been the import folder option.

From what you describe your import folder is connected to your legacy client.

Now you drop something into it and wonder why it doesn’t appear in v10 ?

Well, drop it to your folder. Legacy is down, so nothing happens. You can tinker around with v10 - it is the wrong place to tinker. Now you open legacy. Oh, something in the import folder - let‘s grab it …. Some time later: I will sync - with the EN server … some time later: v10 looks up on the EN server, finds a new note, courtesy from legacy, and syncs it down. Now it appears in this client as well. 

So instead of importing it directly, you used another app (legacy) and 2 syncs to and from a remote data center just to get something into your v10 client. No wonder it takes a little.

Set up a new import folder using v10, and drop it there. It works instantly.

  • Like 1
Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...