Jump to content

How do search a single notebook only in this new version?

Go to solution Solved by PinkElephant,

Recommended Posts

It was so easy to limit my search in older versions (much missed!). But I can't figure out how to do it now. I tried the "notebook:somename" and it keeps telling me invalid notebook. Besides, that a lot of unnecessary typing. I searched the docs, but nothing.

What's the secret?


Link to comment
  • Level 5
  • Solution

Here is how-to in the iOS (mobile) app, similar on Android.

  • Hit the search icon
  • In the search window, hit the filter icon top right
  • Now you can directly select tags, notebooks, dates, content and more from the popup menu. 

When you select a notebook („is located in“), the search is limited to this notebook.

Maybe the desktop clients do it a little differently, had no time to try.

When you already start from a notebook view, it is even more easy: When you hit the search icon and the search screen opens, the notebook will show in a preselection below the search field. Just tap on it (it turns to solid), and the search is restricted.




  • Like 3
Link to comment
2 hours ago, breadwild said:

What's the secret?

The approaches so far have been to search first and then filter for only the notes in the notebook you want.

An alternative approach is to start in the notebook you want to search and then click inside the search box. Immediately below the text box is the option to filter on that notebook.


The search syntax you quote is correct and works for me


Link to comment
  • 2 months later...

I have a similar problem.  I save searches by tag and notebook combo.  When I use the shortcut, the notebook shows up with an error message (but is still working!!!).  Fustrating.  Is this a program problem or a me problem?



Link to comment
  • Level 5

Did you use the search syntax for all  parts of the search ?

I had a similar problem in the iOS client, but the search itself worked and showed the correct results.

Trying the filters instead of the search syntax made the error go away, with the same search result as before.


Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...