Jump to content

Expected or Bug? Keyboard Shortcut F6 resets my Quick Search Ctrl+Q filter


Recommended Posts

I did a search for 'F6' and did not find anything helpful. Apologies if I missed something.

my version: Evernote Windows (6.13.14.7474 (307474) Public (CE Build ce-48.0.5483))

 

I'm really relying on Keyboard Shortcuts, so I wonder what I'm doing wrong here. Is this expected behaviour or a bug?

In Evernote, I mostly use CTRL + Q and type a few characters to navigate/jump to a notebook or tag, or some recent search such as 'intitle:{phrase}'.

But when I want to refine my search after the jump, I HAVE to use the mouse and click into the 'search notes' bar at the top. When I do that, it works fine. But I want to use a keyboard shortcut. So I hit F6 and what happens? I see All Notes. All of the previous filters are reset. Even though Evernotes' tooltip tells me to use F6.

use case: I hit CTRL+Q to jump to my notebook Reporting. Then i want to immediately search for some text, and hit F6 as suggested:

image.png.22f25176677bbdc38c4dc5c78c91001b.png

but this resets to All Notes.

It's actually 100% identical to pressing CTRL + Shift + A (All Notes).

 

there is also a tooltip when i hover over the magnifying glass: ALT + F6. however, pressing that on the keyboard does nothing at all.

 

in summary: i can search my notes by pressing into the bar with my mouse courser, but I don't want to have to do that.

What am I doing wrong?

 

related:

what also annoys me is this: in the search bar, there is no auto-completion (no tab-completion) or suggestions with type-ahead. why?
it works in the quick search though.

Link to comment
  • Level 5*

I see F6 working correctly (puts the cursor at the end of any existing text in the search box) in the 6.14.3 prerelease, as far as I can reproduce.

The Alt+F6 thing, I think, is intended to come into play if you use a "Search as you type delay" setting of 0 (Tools / Options / Search). In that case, the search won't start until you tell it to explicitly, rather than returning search results as you type. The hover text there says that should be when you press Enter or click on the Search button at the right of the search entry field. I think that the "Alt+F6" tooltip for that Search button is in error, possibly vestigial. I'd guess that Enter is usually a lot easier to type...

Link to comment

thanks jefito

Alt + F6: ok got it. not relevant for me then, I don't need the delay/no delay thing.

so I updated to the 6.14 beta 3. don't feel i should have to, and hopefully it is stable enough :) alas, it still does not work!

how can it work for you and not for me? this is so odd. i must be doing something wrong.

let me repost my steps:

  1. so i start in All Notes.
  2. i press Ctrl + Q and type "repo" because i'm lazy and select with the down-arrow the Notebooks: Reporting. Hit Enter.
  3. i now see a list of 5 notes in that notebook and want to narrow down: i press the F6 key
  4. Boom: it resets to All Notes :(

 

 

Link to comment
  • Level 5*
1 hour ago, Hanno1981 said:

thanks jefito

Alt + F6: ok got it. not relevant for me then, I don't need the delay/no delay thing.

so I updated to the 6.14 beta 3. don't feel i should have to, and hopefully it is stable enough :) alas, it still does not work!

how can it work for you and not for me? this is so odd. i must be doing something wrong.

let me repost my steps:

  1. so i start in All Notes.
  2. i press Ctrl + Q and type "repo" because i'm lazy and select with the down-arrow the Notebooks: Reporting. Hit Enter.
  3. i now see a list of 5 notes in that notebook and want to narrow down: i press the F6 key
  4. Boom: it resets to All Notes :(

 

 

You have to uncheck "Clear context on search" in Options\Search.

Evernote guessed that most people want a keyboard shortcut for a fresh search instead of filtering further, as filtering further is done by clicking and typing. But they gave everyone a choice which is great!

  • Like 2
Link to comment
  • Level 5*
1 hour ago, gustavgi said:

You have to uncheck "Clear context on search" in Options\Search.

Thanks for that -- was just about to add it. I think I've had it set for so long that it slipped my mind for a bit.

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...