Jump to content

Other Premium Feature not available : Support Chat

Recommended Posts


Since EN 8 launch the app is crashing on startup (iPhone 6s). Versions 8.0.1 and 8.0.2 didn't fix the problem.
I sent a Support Ticket friday 20th : no answer. I contacted EvernoteHelps via DM : no answer.

Now I want to access the Support Chat, but the "Chat Now" button is not functionning = nothing happens when I click.
I tried to access the Chat from two desktop computers, using Safari, Chrome, Firefox. Also tried from my iPhone.

To sum up :
- the Evernote app is broken.
- I'm unable to reach any support and specifically Chat Support which is a feature that I pay for.

Can you help ?

  • Like 1
Link to post
  • Level 5*

Hi.  I'd imagine the support team are kept pretty busy right now with issues arising from the recent updates to iOS,  so a quick human response is unlikely. 

If you sent a support request you should have received a ticket number - if you post it here we can get one of the Admin team to take a look to see what's going on...

Chat is a first come service - if you're in the right time zone (0700-1900 PST weekdays) and an agent is free you should get through.

Link to post
On 23/01/2017 at 6:09 PM, gazumped said:

Chat is a first come service - if you're in the right time zone (0700-1900 PST weekdays) and an agent is free you should get through.

To me it looks like the button is just not functionning. Shouldn't it open a window and then tells me I'm in a queue ?

Link to post
22 minutes ago, gazumped said:

Don't think so - it would make sense not to allow a connection unless there's a reasonable chance you'll get an answer within a few minutes at most...

Could you give it a try to confirm the button does nothing for you ?

It's here : https://evernote.com/contact/
Then click "Support Page" in the first paragraph, then fill in any subject and you'll get the Chat link at the bottom of the page.

Link to post
15 minutes ago, gazumped said:

OK - just tried it and got through to a chat window immediately..  we're currently in the 7-6 CST working day...

Thanks a lot for checking that for me !

On my account the button does nothing.
I tried using 3 different browsers, on 3 computers and also on my iPhone.
No luck for me.

  • Like 1
Link to post
  • Level 5*

:) Just checking!  OK you do have a problem - this is the latest iOS 8 release thread;  try the update (if that's relevant to your issue) and try posting in that thread to get the devs attention...


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...