Jump to content

Firefox Web Clipper Not Working


Recommended Posts

We have 4 window 10 computers at home running firefox. Web clipper on all computers stopped working this week. Problem -could not log in, received Checking credentials took too long.” Uninstall then reinstalling - same results. Also tried installing version 6.9.3 - that did not work. Installed 6.2.0 and it worked.

Link to comment

Using Windows 10, Anniversary edition, Evernote with Evernote Web Clipper 6.9.3 with Firefox 50.0.  When I click on the Web Clipper the form is there but no text.  I filled out the userid and password but nothing happened.  Anyone else having this problem?  Anyone have a solution to this.  Web Clipper is worthless this way.

web clipper.jpg

Link to comment
  • Level 5*

Hi @Terp66 - the latest update to Clipper has been ...interesting... all around.  One user found a 'cookies' fix that avoids some problems,  which is worth trying:  a few others have reverted back to 6.2 and switched off the upgrades option in Add-Ins to stay with that version for a while.

Older version of Clipper - https://addons.mozilla.org/en-GB/firefox/addon/evernote-web-clipper/versions/

Switch off updating - Firefox 'burger' menu > Add-ons > Extensions > Web Clipper Options - scroll down:  set Automatic Updates to OFF

If you prefer 6.9.3 and still have issues,  contact support directly if you can,  or message them on Twitter

Link to comment
  • 2 months later...

I've had the same problem (latest Firefox, Windows 7, Clipper 6.10...). Initially I had the 'red dot' version of the icon so when I clicked it I got a login popup where I duly put in my password. Since then I still have the 'red dot' icon but whenever I clicked it I get a brief blank popup which then closes. I switched the Clipper back to 6.9... then I got asked for my password again but this time the red dot is replaced by the simple elephant head & clipping works.

Further info:

Web login is working fine with my password. Other add-ons installed: NoScript, AdBlock-Plus (both up to date) and I ain't about to lower my security by disabling them.

Link to comment
  • Level 5*
13 hours ago, markymarkyate said:

I have exactly the same issue but Firefox on Mac El Capitan.  Cannot clip from Firefox and get a blank pop up with message ... waiting for www.evernote.com ... and then the pop up disappears.

Help appreciated.

See above for what help is available - only other options: contact support direct or via Twitter.

Link to comment

Evernote Firefox Web Clipper does not save notes.  The first session use of Web Clipper makes me log in even though I have "stay logged in for 30 days" checked off.  Nothing gets saved anywhere I can find it.  Second and subsequent tries to use Web Clipper for Firefox make the log in window flash briefly and disappear.  Nothing gets saved anywhere I can find it.  I have latest Firefox and Evernote Web Clipper for Firefox versions. Items I clip from other devices and browsers do show up in my desktop Evernote.

Evernote is pretty useless to me unless I can bring items from diverse sources together on my desktop. That very much includes clipping from my web browser.  Please fix this quickly.   I have Firefox 51.0.1 and Evernote Web Clipper for Firefox

Link to comment


This topic is now archived and is closed to further replies.

  • Create New...