Jump to content

Problem: Can't Hyperlink to local resources (new problem)

Recommended Posts

Recently I discovered, much to my great joy, that I could make hyperlinks to local resources...that is, resources on my harddrive(s)...


Today, EN was hanging, so I killed it with the taskmanager...


Now, the local hyperlinks I had have disappeared...AND I can't make new ones.


...Evernote is not automatically making them and...here are the things I've tried:


  1. Create the hyperlink manually via format->hyperlink-add (the dialog shows up, and shows the hyperlink that would be made.  In other words, everything looks fine, the dialog is usable, performs as one expects EXCEPT for the fact that after clicking okay to create the hyperlink, none is made. (I haven't actually dug into the individual notes on disk to look at the xml -- so I don't know if the hyperlink is not being made, or simply not displaying in the note.)
  2. Uninstalling and re-installing EverNote (I was using the most up-to-date version before, and so there is no difference in the version numbers.)


Is there some set of metadata I need to update?  When I re-installed, it immediately opened my previous Evernote account, which surprised me.

I appreciate any help.



P.S. Oh yeah...I'm running Windows 8, up-to-date


Update:  Just checked, the links are not being made in the note file ... at least I sure didn't see them in the note I tried to make one in and exported it.  (Whereas I could easily see the "note link" hyperlink reference.)

Link to comment
  • Level 5*

Hi.  I don't understand why your existing hyperlinks should have disappeared,  or why your system won't make local links now.  Have you restarted your computer since killing Evernote?  What happens if you create a hyperlink in another application and copy/ paste it into Evernote?  Or copy some text from a web page that contains a hyperlink?  Can you still make web links?

Link to comment



Thanks for your response...seems, on further investigation, to be limited to a very specific kind of local link.


...one I *thought* had been being made before...


so, here's what I've discovered will work, and links automatically made:


  1. f:\projects  -- on external harddrive
  2. file:///f:/_projects -- on external harddrive

What doesn't work is:


  1. f:\_projects
  2. f:\projects\2ndleveldir  (inconsistent -- sometimes I can get these to work, sometimes not)

Looks like Evernote does not detect directory names starting with an underscore automatically, and create a hyperlink -- although if I highlight the same link and select "hyperlink->Add", it will provide the correct hyperlink, which I can then put directly in the note and have recognized.


...OOPS - spoke too soon ... added a 2nd case that doesn't seem to work (at least on an external HD reference.)

...and additionally, doesn't seem to work if they are added in a bulleted list...
I'm going to have to spend some more time working on various test-cases. 

This is just plain weird.

Thanks for the question...you've helped me isolate the conditions under which this occurs.


In retrospect, now I'm not sure if those links actually were showing up in my notes previously.


Evernote seems to have some odd character set issues.


To make certain of my documents stand out, I've named them with asterisks surrounding them...only to discover the note search simply won't search for my triple asterisk designator.

...but, not too surprising.  While I'm thankful for the search box ... I really think the search function is not that good.  The results frequently surprise me, not in a good way.  Using quotes helps. :)


I suspect some of these limitations come about because of cross-platform compatability as well as internationalization/localization.  Unfortunately, search order is not consistent across platforms.

...however, I should think the "add hyperlink" should work under all conditions.

Most distressing...

Link to comment


This topic is now archived and is closed to further replies.

  • Create New...