Jump to content

Evernote Web Clipper


Recommended Posts

I keep getting the following notice:  This version of Evernote Web Clipper is no longer compatible with Evernote Service. Please install the latest version.


Logging into my evernote account and doing a search for Evernote Web Clipper for Chrome I see a note that I am automatically upgraded.  Someone is not getting the message.  Can anyone please tell me how to fix this?


Rick Raymond

Link to comment

I also started today with the same issue - Chrome browser Version 36.0.1985.125 m and Evernote Web Clipper 

Kept getting the pop up message that Evernote Web Clipper no longer compatible - this pop up consistently comes up after closing it so that my browser was totally unusable.


Here's how I got my browser working again.

-Open chrome with extensions disabled (--disable-extensions after the .exe)

-Go to settings and change on start-up behaviour to 'continue where you left off'

-Go to settings - extensions (you won't see any because they are disabled)

-Whilst the extensions page is visible, close chrome

-Restart chrome using your normal shortcut.

-Now the pop-up will keep coming up, but the visible window behind shows your extensions and you can disable Evernote.


This final stage crashed Chrome, but then when it restarted everything worked again, apart from the web clipper.  I will leave the web clipper off until a solution is found......


Link to comment

Same problem here!  Worked perfectly yesterday, but not today.  Noticed the reviews for Web Clipper are all starting to reflect this issue too, but no response from Evernote as yet?  Come on Evernote, acknowledge the problem, then fix it!

Link to comment

Same problem here. I uninstalled and re-installed the extension (Evernote Web Clipper 6.2 for Chrome, Mac) and it worked for a while until I opened my laptop at work (from sleep) and the errors returned.


It seems that completely closing Chrome and re-opening it does the trick so far.


This problem started with the latest 6.2 extension.

Link to comment
We just released a fix to patch this error popup.

Users should get auto updated to the latest version 6.2.1 which has the fix applied either in the background or on Chrome restart. 


To force updates manually:

1) Visit chrome://extensions and set it to developer mode and push the button 'Update Extensions Now' at the top of the page. 


And then verify you are running 6.2.1


Sorry for the inconvenience. 

Link to comment


This topic is now archived and is closed to further replies.

  • Create New...