Jump to content

Safari web clipper 6.0.6 not working with Safari 7.0.1 (Mavericks 10.9.1)


Recommended Posts

I've been unable to get the EN web clipper to work.  I click on the icon, absolutely nothing happens.  I've read some other forum posts about this, but most folks seemed to have little problem after v 6.0.3.


Anything to try (and yes, I have stopped/started Safari)?


And I tried in Chrome, too.  Same problem.  Nothing happens when I click the little elephant!



Link to comment

Well, an odd things happened....I finally installed the Firefox extension after the Chrome and Safari ones didn't work.  Then all three worked after the FF install.  Go figure!


(I also opened the options up from the Chrome extension not via clicking on the toolbar but by opening Chrome extensions...didn't change a thing, just looked, but perhaps that did it)

Link to comment

I tried downloading on Safari 7.0.1 and then, per your suggestion, went to Firefox and downloaded there.  I then cleared the downloads on Safari and retried but still had the same problem.  Any suggestions?  Thank you!


Link to comment
  • 4 weeks later...

I had the same problem as described above: web clipper 6.0.6 in Safari 7.0.1 did nothing. Installed Firefox, web clipper for Firefox, logged in and voila: Webclipper in Safari also working now. Strange ...


I too had same problem.. Saw your post.. Installed WebClipper via Firefox.. WOW! Safari WebClipper began working!!!! WTF! Did no change to Safari.. Just Firefox.. WEIRD!  It works! 

Link to comment

The first thing to check is to make sure you are running latest version which is


If necessary, please re-install from www.evernote.com/webclipper

I'm having the same issue with v 6.0.8 — just uninstalled, downloaded newest version, and reinstalled. Safari Prefs is showing it as version 6.0.8 (no ".1" at the end). Web Clipper is installed in Firefox and seems to be working fine in Firefox, though it's slow and flashes/flickers. However, when I click on the Evernote Web Clipper icon in Safari, nothing happens. Hmmm, let me amend that. Web Clipper works just fine on this page. However, I have 8 other tabs open in Safari and it doesn't work at all in any of them.

Link to comment

Installed web clipper on Safari 7.0.1 (mavericks).  The web clipper didn't work for safari webpages that were previously open (nothing happens on icon click).  But it seemed to work for webpages that were opened after the installation is complete.  Hope this helps!

Link to comment
  • 3 weeks later...

Web Cilpper worked after I updated to Mavericks. Weeks later it simply disappeared from Safari. I downloaded and ran the installer, but the installation wouldn't continue. Restarting Safari and then installing the extension did work. 


I had to reinstall Web Clipper on other Macs after updating to Mavericks, but this was different. 


IIRC on another Mac I had an older version of Web Clipper that Safari refused to load. Installing the older version of Web Clipper (from the download I had saved) just worked fine.



Link to comment

I've been having the same problem with Web Clipper and Safari. It worked fine before, but honestly I can't remember if it worked after upgrading to Mavericks or if that's what broke it. It works fine in Chrome and Firefox (although in FF I don't get the option to change the snapshot size) but when I click the button nothing happens. No login box, nothing.


Safari is Version 7.0 (9537.71), and Extensions says I have 6.1 of Web Clipper. It didn't say an update was needed, and I have it set to auto update. I also deleted the extension, restarted Safari, rebooted the computer, reinstalled the extension, etc etc etc, but it still won't work. 



Link to comment
  • 6 months later...

Yes I'm running Mavericks 10.9.4 and Webclipper disappears from my task bar about every one or two weeks.  I get it back by downloading and installing again, but it is getting annoying.  Must have had to do this more than 10 times now.  Any solutions?  Other than that it mostly works really well and I love it. 

Link to comment


This topic is now archived and is closed to further replies.

  • Create New...