Jump to content

(Archived) No URL can be entered on Skitch uploaded captures


jakab

Recommended Posts

The URL field in the "Note Info" in Evernote for captures uploaded by Skitch is disabled. These are captures of parts of a webpage from Safari.

 

The URL Field field is both empty (says "No URL") and disabled.

 

All other notes in Evernote have the URL field enabled, but not the notes uploaded by Skitch.

 

Don't know if this is a Skitch or Evernote problem.

 

Both Skitch and Evernote are at the latest version as of today. Running on OS X 10.8.4

 

Is this a bug or working as designed?

 

Thanks.

Link to comment

@jakab - That's by design. The notes in Evernote are locked to prevent things from being accidentally deleted. 

 

We can add capturing the URL to our feature backlog and see if we can do this. Not sure if we can grab the URL along with the window name, but we'll investigate and see what can be done. 

Link to comment

Thanks Joe for the prompt reply.

 

If you could capture the URL and put it in the URL filed of the Note Info, that would be ideal, even if the field remained disabled after capture.

 

Thanks for a great product.

 

...Peter

 

PS: I would be even happy if I had to capture the whole page and then edit down by cropping to what I really wanted later. I'm thinking it might be easier to figure out the URL of the page if the whole thing was captured rather than just a rectangle.

Link to comment

+1 For this feature! What then is the feature "Note URL" under options for? I would assume this is so when we take a screen grab using skitch it will, erm... *note* the url? But when the skitch screen grab is viewed in evernote and you choose the info icon, there's no sign of a url being "noted".

 

If you could expand on what the "Note URL" option is actually for, that would also be greatly appreciated.

 

Note URL:

http://i1363.photobucket.com/albums/r713/gavinfostered/note_url_zps5b3f1730.jpg

 

No Sign of URL:

http://i1363.photobucket.com/albums/r713/gavinfostered/but_no_url_zpsda6e0450.jpg

 

Thanks

Link to comment

Evernote Notes, have a series of different informational fields that are utilized by Evernote users, and other apps for different purposes. On a generic Evernote Note someone could use that field to note down an important URL that the overall doc relates to. 

 

Due to a way OS X works grabbing the underlying URL of a window can be a little tricky. Skitch currently doesn't have an easy and reliable method for doing this. We're still investigating options.

 

That said, if you're simply grabbing a screenshot of a webpage (or an article) and there are two workarounds for you to check out, until we have a different option built:

  • If you are trying to create a visual bookmark try Evernote Clipper. It allows for grabs of a webpage or specific web content and store it within Evernote. This should grab the URL as part of the capture.
  • If you are trying to mark up a webpage (and need the web content), then again grab the page via Evernote Clipper and then from within Evernote (v 5.2) open up the image in Skitch (v2.6) and you can mark it up that way. It does introduce some additional steps, but might meet your needs. 
Link to comment

Thanks Joe, the second workaround will work for me.

 

Please keep looking at options to make storing the URL automatically from Skitch more seamless.

 

Another workaround would be for Evernote to make the field in Note Info editable so we can paste the URL manually.

 

Thanks again.

 

 

...Peter

Link to comment

@Peter I hope the workaround works for you.

@Gavin, same as well. I hope it works for you. One thing to note if you are using a Mac you can also easily open and annotate with Skitch and Evernote now. We have similar support on the Mac, and are working to bring the same experience to our other platforms as well.

 

joe

Link to comment

Hi Joe, I think I might have found a bug on the "Mark up with Skitch" function.

 

On Evernote, right clicking on the note and selecting: Skitch -> Mark up with Skitch, works fine. But clicking on the "Mark up with Skitch" icon results in an request to join the Evernote Premium service and does not allow to proceed to editing the image.

 

Thanks.

 

Peter

 

See: https://www.evernote.com/pub/jakab/Public

Link to comment

@Peter 

 

We've seen something similar and believe we have it tracked down, but if you can answer a few questions and try something for me that will help us figure out if this is new or not:

 

  • Do you have more than 1 copy of Skitch installed? (Search in Spotlight and make sure there are no hidden copies)
  • Are both Evernote and Skitch from the Mac App Store? Direct Download? Or a mis-match of the two?

 

Try and do the following and see what happens:

  • Quit Skitch & Skitch Helper
  • Delete any other copies of Skitch you have installed other than your latest.
  • Launch Evernote and select a non-Skitch related PDF (if you don't have one just search on PDF W2 and you can get a tiny PDF from the IRS; just drop that into a new note)
  • Right click on the non-Skitch related PDF and select "Markup with Skitch"
  • After Skitch starts, you can close that PDF window (you don't need to mark up)
  • Go back to Evernote and see if the problem with the Markup with Skitch icon is resolved.

 

There's a bug that can pop up for several reasons one of which is if you have multiple versions of Skitch installed. We have a fix in the works in Evernote that will resolve most of these bugs. 

Link to comment

Hi Joe.

 

I only have one copy of Skitch. It was installed from the App Store (Version 2.6 (262903))

 

 

I only have one copy of Evernote. It was directly installed, I'm a long time user, before the App Store :-) (Version 5.2.0 (401495))

 

I created a new note using a PDF file I had. Saved it to Evernote.

Right clicked it and the Skitch option was not there, I assume since I'm not a Premium member.

I then selected Open with, and chose Skitch. It told me it would start a 30 day trial membership for me and opened the PDF in Skitch. The "Save to Evernote" button was not there.

Closed the window, tried the Open with Skitch icon, and got the notice to update to Premium, same as before.

Quit Skitch and tried again, same result.

 

Should I uninstall Evernote and get it from the App Store to eliminate a possible mismatch?

 

Thanks for staying on this.

 

...Peter

Link to comment

@jakab

I believe that what's going on is that you are marking up the image when you right-click on the note which is a feature available to all Evernote users. When you are selecting the Markup with Skitch icon you are choosing to markup the entire note which creates a PDF of the note and sends it to Skitch. However, PDF markup is a premium only feature and the Evernote app is presenting you with the option to upgrade to Premium so that you can complete your task. If you chose to markup just the image file, you should be able to complete your markup. I assume that you are a free user?

Thanks,

Lester

Link to comment

Hi Lester, yes, I'm a free user.

 

I think I understand the difference now. I was not aware that choosing the icon would create a PDF for Skitch to mark up.

 

I think i was most likely confused because the text of the action "Mark up with Skitch" is so similar on both methods. Maybe the description on the icon should be something like: Create PDF and Mark up with Skitch.

 

Thanks for the explanation.

 

...Peter

Link to comment

Archived

This topic is now archived and is closed to further replies.

Guest
This topic is now closed to further replies.
×
×
  • Create New...