Jump to content

(Archived) Skitch quits when I try to login


Recommended Posts

Up until recently, Skitch had been working just fine.  Now, each time I open it and try to login in with my Evernote credentials, it crashes.  I totally uninstalled it using AppCleaner and when I went to the App Store to reinstall it the App Store says it's still installed.  Obviously tried rebooting, etc....nothing works.  The App Store show Skitch as still installed but it's not. 


Next, I installed Skitch from the Evernote site and the same thing happens.  Using the most recent version of Mountain Lion on a relative new iMac.  Any ideas?  Thanks.

Link to comment

Joe, I'd like to try this, but earlier I uninstalled Skitch (MAS version) to see if a reinstall would help, but I can't reinstall it.  When I go to the MAS | Purchased Apps it shows Skitch as "Installed" and greyed out, so I can't reinstall it, or delete it from that list.

Link to comment

OK...figured this all out.  First, the fix about adding a computer name fixed the initial problem.  The reason that Skitch still showed up in the App Store as "Installed" is still a mystery.  One clue might be that it was off my computer...but still on Time Machine.  I named the computer, typed "Skitch" in Spotlight, found it on the Time Machine storage drive.  I copied if from there and pasted it into my Applications folder.  Opened it, signed in, and all if well again. 


Evernote truly does need to work on how all this interacts.  If I uninstall Skitch from my computer, it should be GONE...completely.  And further, when I uninstall it the Mac App Store should show it available to install again...which it doesn't.  When I called Apple Support they told me this was the developer's fault...not Apple's!  It's bad enough Evernote has taken such a wonderful app and thoroughly ruined it...but now it can't even be uninstalled correctly.

Link to comment

@larrymchj - Glad that the computer name fix worked. This bug should be squashed with the 2.6 release.


As for uninstall, I'm not really sure why an Apple rep told you that as app developers who use Apple's built in software (MAS) have nothing to do with install and uninstall. OS X handles the entire process and we have nothing to do with it. We simply upload our app to the store and Apple manages the install and reinstall process.


I have seen other apps (not Skitch) have the same problem. Two things that have worked for me in the past were 1) empty the trash (sometimes MAS detects an App being installed even if it is in your trash) and 2) check your application folder and make sure it was actually deleted. I've gone to the application folder dragged an app to the trash only to go back and find it still sitting in my application folder. 

Link to comment

No, it wasn't in the trash...checked there, and definitely not in /Applications.  I uninstalled it using AppCleaner, which even found the six or seven instances of Skitch crashing (the log files, I guess).  In any event, there was absolutely nothing Skitch on my machine, but it was still on the storage drive I use for Time Machine backups.  I'm a retired geek so didn't put a lot of stock in what the first-tier Apple Care girl told me.  Even they are often reading from a script until you get past their front line.  Anyway, it's all fixed now.  Thanks.

Link to comment


This topic is now archived and is closed to further replies.

This topic is now closed to further replies.
  • Create New...