Jump to content
  • 0

being forced to upgrade and can't get past the upgrade window to click on 'devices' so I can delete an old device.



I value my evernote free account and have done for years.

I also need daily access to my files and can't at present.

I only need to use it on 2 devices and can only guess that I am being blasted with 'upgrade' windows because I've somehow left an old device in use with evernote.

When I click on the link to check out my devices and make adjustments it doesn't work... 

Can anyone please help?

Thanks in advance, Janine


Link to comment

2 replies to this idea

Recommended Posts

  • 0

I'm getting the same since yesterday. My ipad was listed twice as a device so I revoked one of them, but it didn't fix it. Tried again from my laptop (the other device on my free plan), which still showed three devices synced, two of which were the same iPad. Tried revoking one of them again, still the same. Now I'm out of revokes and locked out of Evernote, which I need to be able to use...

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...